LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 08-09-2011, 09:35 PM   #1
rwrench
LQ Newbie
 
Registered: Aug 2011
Posts: 4

Rep: Reputation: Disabled
trying to update rails 3.0 on ubuntu 11.04


I've installed ruby and rvm on ubuntu. when i type rvm notes
I get this


bash >= 3.2 is required
curl is required
git is required (>= 1.7 recommended)
patch is required (for ree and some ruby-head's).

then later

# For Ruby (MRI & ree) you should install the following OS dependencies:
ruby: /usr/bin/apt-get install build-essential bison openssl libreadline6 libreadline6-dev curl git-core zlib1g zlib1g-dev libssl-dev libyaml-dev libsqlite3-0 libsqlite3-dev sqlite3 libxml2-dev libxslt-dev autoconf libc6-dev ncurses-dev

when i tried running the command above i get this
E: Could not open lock file /var/lib/dpkg/lock - open (13: Permission denied)
E: Unable to lock the administration directory (/var/lib/dpkg/), are you root?

thanks
 
Old 08-09-2011, 09:54 PM   #2
EDDY1
LQ Addict
 
Registered: Mar 2010
Location: Oakland,Ca
Distribution: wins7, Debian wheezy
Posts: 6,838

Rep: Reputation: 649Reputation: 649Reputation: 649Reputation: 649Reputation: 649Reputation: 649
Turn off automatic updates, log out & back in.
Quote:
aptitude update
Quote:
aptitude upgrade
That's what I had to do.
Now I have a 3.0 kernel
Debian Sid

You may have to run the above commands with sudo.

Last edited by EDDY1; 08-09-2011 at 09:56 PM.
 
Old 08-09-2011, 10:36 PM   #3
rwrench
LQ Newbie
 
Registered: Aug 2011
Posts: 4

Original Poster
Rep: Reputation: Disabled
still not working

i installed aptitude with sudo. then upgraded it.
i ran it - got the menu did a search for rails to clicked u to update.
logged out then in again but rails -v is still 2.3.5
 
Old 08-09-2011, 11:06 PM   #4
EDDY1
LQ Addict
 
Registered: Mar 2010
Location: Oakland,Ca
Distribution: wins7, Debian wheezy
Posts: 6,838

Rep: Reputation: 649Reputation: 649Reputation: 649Reputation: 649Reputation: 649Reputation: 649
Did your machine ask for reboot?
 
Old 08-09-2011, 11:11 PM   #5
rwrench
LQ Newbie
 
Registered: Aug 2011
Posts: 4

Original Poster
Rep: Reputation: Disabled
no it did not
 
Old 08-09-2011, 11:22 PM   #6
EDDY1
LQ Addict
 
Registered: Mar 2010
Location: Oakland,Ca
Distribution: wins7, Debian wheezy
Posts: 6,838

Rep: Reputation: 649Reputation: 649Reputation: 649Reputation: 649Reputation: 649Reputation: 649
Then reboot it & try another update.
Another thing you can do is open synaptic then click 'status button'
& 'Installed (upgradeable), then click on 'Mark All Upgrades'.

Last edited by EDDY1; 08-09-2011 at 11:25 PM.
 
Old 08-09-2011, 11:42 PM   #7
EDDY1
LQ Addict
 
Registered: Mar 2010
Location: Oakland,Ca
Distribution: wins7, Debian wheezy
Posts: 6,838

Rep: Reputation: 649Reputation: 649Reputation: 649Reputation: 649Reputation: 649Reputation: 649
http://blog.sudobits.com/2011/06/27/...tu-10-1011-04/
 
Old 08-10-2011, 03:47 AM   #8
rwrench
LQ Newbie
 
Registered: Aug 2011
Posts: 4

Original Poster
Rep: Reputation: Disabled
Angry after step5 installing rails i try rails new test and get this

/home/richardw/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubygems/dependency.rb:247:in `to_specs': Could not find activesupport (>= 0) amongst [] (Gem::LoadError)
from /home/richardw/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubygems/dependency.rb:256:in `to_spec'
from /home/richardw/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubygems.rb:1195:in `gem'
from /usr/share/rails-ruby1.8/railties/lib/rails_generator.rb:31:in `rescue in <top (required)>'
from /usr/share/rails-ruby1.8/railties/lib/rails_generator.rb:27:in `<top (required)>'
from <internal:lib/rubygems/custom_require>:29:in `require'
from <internal:lib/rubygems/custom_require>:29:in `require'
from /usr/share/rails-ruby1.8/railties/bin/rails:14:in `<main>'
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
getting rails console to work on Ubuntu 11.04 with RVM and rails 3.0.9 murankar Linux - Software 0 07-17-2011 03:28 PM
[SOLVED] [Ruby on Rails] backticks don't work under rails. bartonski Programming 1 09-08-2009 05:19 PM
[SOLVED] Installing Ruby on Rails -- "gem update --system is disabled on Debian". bartonski Debian 2 08-23-2009 10:17 PM
LXer: How to Install Ruby on Rails (ROR) in Ubuntu LXer Syndicated Linux News 0 11-07-2007 02:30 AM
LXer: Real world Rails: Caching in Rails LXer Syndicated Linux News 0 05-19-2007 10:16 PM


All times are GMT -5. The time now is 09:17 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration