LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 08-26-2008, 02:47 PM   #1
Sanford Stein
Member
 
Registered: Jun 2008
Location: Evanston, Illinois
Distribution: RHEL 6.4
Posts: 125

Rep: Reputation: 17
Trying to mount an external UBS drive with ntfs as read/write


I am trying to use an external USB drive for image backup. The drive was apparently configured with an ntfs file systems. I installed ntfsprogs and fuse. The drive will mount, but only for reading.

My line in /etc/fstab is:
/dev/sdd1 /media/usb ntfs rw,user,noauto 0 0

If I run dmesg | tail, I see:
NTFS-fs error (device sdd1): load_system_files(): $LogFile is not clean. Mounting read-only. Mount in Windows.

Any ideas how I can get this device to be read/write?

Thanks,
SS
 
Old 08-26-2008, 03:05 PM   #2
MS3FGX
Guru
 
Registered: Jan 2004
Location: NJ, USA
Distribution: Slackware, Debian
Posts: 5,852

Rep: Reputation: 351Reputation: 351Reputation: 351Reputation: 351
First, I would suggest you use NTFS-3G over NtfsProgs.

As for the actual problem, it sounds like the volume wasn't cleanly unmounted. The easiest way to fix this is to mount it under Windows (which will likely want to run a check on it) and then unmount it. Then it can be mounted under Linux.

If you are unable to get it mounted under Windows, you will have to force mounting it. This could lead to data loss however, so I would try to get it to a Windows machine if at all possible.
 
Old 08-26-2008, 04:06 PM   #3
Sanford Stein
Member
 
Registered: Jun 2008
Location: Evanston, Illinois
Distribution: RHEL 6.4
Posts: 125

Original Poster
Rep: Reputation: 17
Thank you for your reply, MSGF3X.

I cannot immediately gain access to a Windows system, so I'd like to try to force a
read/write mount. This is a test system so I am not worried about data loss.

I saw the 'force' option in other forums but when I added it to the options list in /etc/fstab I was told 'bad option'. Same thing when I tried '-o rw,force' on the command line.

What is the proper syntax? I have RHEL 5.1.

I did download and install ntfs-3g but, as you predicted, it did not solve my problem.

Thanks,
SS
 
Old 08-26-2008, 04:47 PM   #4
sydney-troz
Member
 
Registered: Feb 2007
Distribution: Kubuntu, it's obese barely-usable sibling, Ubuntu
Posts: 142

Rep: Reputation: 15
Another thing is it may have been used to hibernate a \/\/indoes system, I think I had the same problem once. If data loss is not a problem, why not just reformat?
 
Old 08-26-2008, 05:10 PM   #5
arizonagroovejet
Senior Member
 
Registered: Jun 2005
Location: England
Distribution: SLED, openSUSE
Posts: 1,009

Rep: Reputation: 171Reputation: 171
What distro are you using and what version (it's useful to add this to your profile). On any reasonable up to date distro you should not need to put anything in to /etc/fstab in order to mount the drive so remove the fstab entry. Install ntfs-3g (check your disto's package manager) then plug the USB drive in again. If it still doesn't mount read-write then unmount it, get http://flomertens.free.fr/ntfs-config/ run it and enable read/write then plug the USB drive back in again. The drive should now be read/write.
 
Old 08-27-2008, 12:31 AM   #6
uncle_philip
Member
 
Registered: Apr 2008
Location: sydney
Distribution: centos5.2
Posts: 50

Rep: Reputation: 15
[QUOTE=Sanford Stein;3260666]Thank you for your reply, MSGF3X.

I saw the 'force' option in other forums but when I added it to the options list in /etc/fstab I was told 'bad option'. Same thing when I tried '-o rw,force' on the command line.

If my memory is correct,

under ntfs-3g, to force to use the drive,
ntfs-3g 'drive' -o force
 
Old 08-27-2008, 12:37 AM   #7
pinniped
Senior Member
 
Registered: May 2008
Location: planet earth
Distribution: Debian
Posts: 1,732

Rep: Reputation: 50
I never had problems with ntfs-3g:

mount /dev/some_ntfs_partition /mnt -t ntfs-3g -o force (in most cases I don't need 'force')

The default is to mount the volume rw, so there is no need for -o rw
 
Old 08-27-2008, 09:04 AM   #8
Sanford Stein
Member
 
Registered: Jun 2008
Location: Evanston, Illinois
Distribution: RHEL 6.4
Posts: 125

Original Poster
Rep: Reputation: 17
I used 'ntfs-3g {device} {mount point} -o force' as recommended by Uncle Philip and it worked beautifully -- the $LogFile problem was cleared and I can now backup/restore.

Thanks to all of you for your responses. I appreciate everybody's suggestions and time.

SS
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
USB drive Read/Write - NTFS sp149 Linux - General 7 11-14-2007 04:11 PM
External hard-drive - readonly, can't make it read/write mooseman Linux - Hardware 3 05-18-2007 02:27 AM
How to mount a read write NTFS partition CircuitSix Linux - Hardware 3 12-07-2005 02:21 AM
write to external NTFS drive bluetwist Debian 2 07-29-2005 06:38 PM
Can't mount NTFS in read-write mode Tyco Linux - Hardware 4 06-08-2003 11:52 AM


All times are GMT -5. The time now is 01:12 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration