LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 05-29-2011, 01:13 AM   #1
chickenfish4
LQ Newbie
 
Registered: May 2011
Posts: 2

Rep: Reputation: Disabled
trying to install iceweasel from lenny-backports


i have been trying to install iceweasel 3.5.16 from lenny-backports , but when i run the command

apt-get -t lenny-backports install iceweasel

it just installs iceweasel 3

i also tried it with iceweasel=3.5.16 at the end and it just said it cant find 3.5.16, but i know the package is there cos iv seen it on the website

I have this line at the bottom of my sources.list file

deb http://backports.debian.org/debian-backports lenny-backports main

and if it makes any differnence im running lenny on a powerpc computer (well it's actually a wii)
 
Old 05-29-2011, 04:05 AM   #2
neonsignal
Senior Member
 
Registered: Jan 2005
Location: Melbourne, Australia
Distribution: Debian Jessie (Fluxbox WM)
Posts: 1,388
Blog Entries: 52

Rep: Reputation: 355Reputation: 355Reputation: 355Reputation: 355
I'm assuming that after you added the backports entry to sources.list, you ran
Code:
apt-get update
You can then use apt-cache to check if the backported packages are named differently (though it doesn't look like the iceweasel one is)
Code:
apt-cache search iceweasel
If you are going to specify a version number, you might need to use the full backport version string '3.5.16-7'
Code:
apt-get install iceweasel=3.5.16-7 -t lenny-backports

Last edited by neonsignal; 05-29-2011 at 04:07 AM.
 
1 members found this post helpful.
Old 06-01-2011, 03:09 AM   #3
chickenfish4
LQ Newbie
 
Registered: May 2011
Posts: 2

Original Poster
Rep: Reputation: Disabled
I didn't know you had to do apt-get update so i did that and it still didn't work, so i changed my line in sources.list to another mirror and then it worked
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
How to use VLC instead of Totem in Iceweasel, in Lenny? stardustdk Debian 2 08-14-2010 07:58 AM
Opinions on Best Way to upgrade from Lenny/Lenny Backports to Squeeze?? linus72 Debian 7 12-26-2009 10:44 AM
[SOLVED] Lenny 32-bit Iceweasel no sound agrestic Debian 1 09-07-2009 02:29 AM
The default Lenny kernel, of stable, sucks. Alternatives from backports? frenchn00b Debian 10 03-26-2009 06:37 PM
Kmail opening Iceweasel in foreground - Lenny Zelator Debian 3 12-12-2008 11:28 PM


All times are GMT -5. The time now is 11:49 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration