Linux - NewbieThis Linux forum is for members that are new to Linux.
Just starting out and have a question?
If it is not in the man pages or the how-to's this is the place!
Welcome to LinuxQuestions.org, a friendly and active Linux Community.
You are currently viewing LQ as a guest. By joining our community you will have the ability to post topics, receive our newsletter, use the advanced search, subscribe to threads and access many other special features. Registration is quick, simple and absolutely free. Join our community today!
Note that registered members see fewer ads, and ContentLink is completely disabled once you log in.
If you have any problems with the registration process or your account login, please contact us. If you need to reset your password, click here.
Having a problem logging in? Please visit this page to clear all LQ-related cookies.
Introduction to Linux - A Hands on Guide
This guide was created as an overview of the Linux Operating System, geared toward new users as an exploration tour and getting started guide, with exercises at the end of each chapter.
For more advanced trainees it can be a desktop reference, and a collection of the base knowledge needed to proceed with system and network administration. This book contains many real life examples derived from the author's experience as a Linux system and network administrator, trainer and consultant. They hope these examples will help you to get a better understanding of the Linux system and that you feel encouraged to try out things on your own.
Click Here to receive this Complete Guide absolutely free.
I have a tar of the gimp 2.8 setup. When I try to install it, I get the
following dependency problem -
Here are the last few lines of o/p -
checking for dcgettext... yes
checking if msgfmt accepts -c... yes
checking for gmsgfmt... (cached) /usr/bin/msgfmt
checking for xgettext... (cached) /usr/bin/xgettext
checking for iso-codes... yes
checking for BABL... no
configure: error: Package requirements (babl >= 0.1.10) were not met:
No package 'babl' found
Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.
Alternatively, you may set the environment variables BABL_CFLAGS
and BABL_LIBS to avoid the need to call pkg-config.
See the pkg-config man page for more details.
Now when I find the package in Synaptic, I get a package -
Dynamic, any to any, pixel format conversion library
But after I install this package I again get the same o/p.
If your using ubuntu 10.10 still I would recommend you to upgrade for the latest. However you can run
# sudo apt-get install gimp
which will installed a prepacked version of gimp. If you don't wish to upgrade and still want the latest you can try getting the packages from a later ubuntu repo and install them manually or recompile them from source. If you decide to compile them I would suggest you learn how to pack them into a .deb.
And if you find the needed version of libbabl your next stop will be GEGL and after that you will find out that you need a newer version of libglib and this is where it becomes hairy, because libglib is widely used, especially on Gnome system, so updating libglib can break many applications.
If you want to use GIMP 2.8 upgrading your distibution to recent version is the easiest way to go. Which is recommended anyways if you are still running the totally unsupported and therefore insecure Ubuntu 10.10.
Currently there is no method to install Gimp 2.8 on any version below 12.04.
In terms of is it possible ...
Unlikely for the following reason:
The dependencies of the latest versions of Gimp require a-lot of the latest underlying libraries that you will not find by default in any version below 12.04. Thus, you will need to recompile and rewrite portions of the code to get it to compile. The further away you get from 12.04, the larger the change required."