LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 07-10-2004, 03:01 PM   #1
cmgleipzig
LQ Newbie
 
Registered: Jun 2004
Distribution: SuSE 8.2
Posts: 6

Rep: Reputation: 0
Trying to install gaim, won't recognize pkgconfig


I've been trying to install the newest version of Gaim for about two hours now, and after tracking down pkgconfig and the latest version of glib, which it said I needed, I'm still unsuccessful. At this point, I'm not even really sure glib and pkgconfig have been properly installed - I see them there (everything is in /usr/bin/). When I try to configure Gaim, it says that pkgconfig isn't found. How can I make it see that pkgconfig is there?

Tried searching the forums, but didn't find anything that helped.
 
Old 07-10-2004, 03:30 PM   #2
Celettu
Member
 
Registered: Jan 2004
Distribution: VectorLinux 5.0 SOHO
Posts: 90

Rep: Reputation: 15
Said the same thing with me when I tried to compile from source, so I just went to a mild depencency purgatory to install an rpm. What distro do you use?
 
Old 07-10-2004, 04:05 PM   #3
cmgleipzig
LQ Newbie
 
Registered: Jun 2004
Distribution: SuSE 8.2
Posts: 6

Original Poster
Rep: Reputation: 0
rpm didn't work

I use SuSE 8.2.

I first tried the rpm, but that didn't work. There was a whole long list of dependencies and it put me at a loss for which/how/where/why to get them all.

I get these conflicts:
gaim 0.79-0rh9 conflict
Unresolved Requirements:
gaim requires gtkspell
gaim requires libgtkspell.so.0
gaim requires libpspell-modules.so.1
gaim requires libpspell.so.4
gaim requires libtcl8.3.so
gaim requires libtk8.3.so
gaim requires mozilla-nss
gaim requires perl(AutoLoader)
5 more...
gaim requires perl(Carp)
gaim requires perl(Exporter)
gaim requires perl(XSLoader)
gaim requires perl(strict)
gaim requires perl(warnings)

I'm given the option of not updating Gaim or ignoring the conflicts and risking system inconsistencies. It says to only ignore if you really know what you're doing, and that's definitely not describing me!

Advice?
 
Old 07-11-2004, 05:12 AM   #4
Celettu
Member
 
Registered: Jan 2004
Distribution: VectorLinux 5.0 SOHO
Posts: 90

Rep: Reputation: 15
The problem with these is that although there are many packages listed, sometimes you only need one and everything is solved. Me, I installed gtkspell (one dependency) and everything after that worked fine. Of course, I run suse 9.1, so that probably makes a difference...

Best place to look for rpms is here.

San

Last edited by Celettu; 07-21-2004 at 06:26 PM.
 
Old 07-11-2004, 11:25 AM   #5
cmgleipzig
LQ Newbie
 
Registered: Jun 2004
Distribution: SuSE 8.2
Posts: 6

Original Poster
Rep: Reputation: 0
What could happen if I ignore these dependencies

Thanks - I might just go ahead, install gtkspell and see if that allows it to move on.

I know that gtkspell is used for the "check spelling" function in gaim - if that's not important to me, what's the worst that could happen if I ignore the dependencies I posted above and proceed. Does anyone know - will it function reasonably?
 
Old 07-21-2004, 06:28 PM   #6
Celettu
Member
 
Registered: Jan 2004
Distribution: VectorLinux 5.0 SOHO
Posts: 90

Rep: Reputation: 15
Never tried, and I won't advise it either. You could get very funny results.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
can't install pkgconfig; root problem? Fresha Linux - Software 7 03-21-2012 05:01 PM
Help!!! Can't install glib 2.4.7, because the configure script can't find pkgconfig RJARRRPCGP Linux - Newbie 3 11-22-2004 01:20 AM
Help!!! Can't install glib, because configure can't find pkgconfig RJARRRPCGP Linux - Newbie 1 11-20-2004 10:43 PM
pkgconfig-0.15.0 tar.gz install help SuSE_User Linux - Software 8 08-03-2004 03:48 AM
making gaim 0.71 recognize gtk+2.2.0 fobius Linux - Software 1 12-25-2003 11:44 PM


All times are GMT -5. The time now is 04:29 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration