LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 04-18-2009, 11:45 PM   #1
devinmcelheran
Member
 
Registered: Jan 2009
Location: Ontario, Canada
Distribution: Debian 7.3.0
Posts: 134

Rep: Reputation: 16
Trying to Install Extra Compiz Fusion Plugins


I've tried a few times to compile some compiz fusion plugins, but when I do, I get an output telling me that there's no target for my "make" command, but theres a "Makefile" file in the folder that I cd'd to. Any help is greatly appreciated. Thanks.
 
Old 04-18-2009, 11:49 PM   #2
hurry_hui
Member
 
Registered: Oct 2008
Location: Near Jakarta
Distribution: Slackware, Arch, Slax, Porteus, Tiny Core, Slitaz
Posts: 355
Blog Entries: 1

Rep: Reputation: 51
Can you post the output? As for temporary guess I think you don't have any /usr/src/linux. If you have such directory maybe you don't have .config file under it.
 
Old 04-18-2009, 11:58 PM   #3
devinmcelheran
Member
 
Registered: Jan 2009
Location: Ontario, Canada
Distribution: Debian 7.3.0
Posts: 134

Original Poster
Rep: Reputation: 16
It's in this folder /usr/src/linux-headers-2.6.24-24-generic, I'm not sure if that's the right one though, I don't know anything about that. I ran it again to get the output, and it worked, but with a bunch of errors, I'm trying to compile the atlantis plugin, I had it before, but my file system went bad, I had a big error that the system couldn't fix itself, and I have no idea how, so I had to reinstall everything. Now, I think I'm just missing a library or something, but I can't tell, the output would be a few pages long. Have any thoughts?
 
Old 04-19-2009, 01:18 AM   #4
John VV
Guru
 
Registered: Aug 2005
Posts: 12,901

Rep: Reputation: 1713Reputation: 1713Reputation: 1713Reputation: 1713Reputation: 1713Reputation: 1713Reputation: 1713Reputation: 1713Reputation: 1713Reputation: 1713Reputation: 1713
did you read the "Makefile"
sometimes you will need to do this ( one of them )
Code:
make
make all
make OLinux
make MLinux 
make sense    ( chkrootkit requires this )
make -f makefile
what did the two files " README " and " INSTALL " say to do ?
 
Old 04-22-2009, 06:30 PM   #5
devinmcelheran
Member
 
Registered: Jan 2009
Location: Ontario, Canada
Distribution: Debian 7.3.0
Posts: 134

Original Poster
Rep: Reputation: 16
There's neither an "INSTALL" or "README" in the src files, there's only a "MAKEFILE.am"
 
Old 04-22-2009, 07:33 PM   #6
John VV
Guru
 
Registered: Aug 2005
Posts: 12,901

Rep: Reputation: 1713Reputation: 1713Reputation: 1713Reputation: 1713Reputation: 1713Reputation: 1713Reputation: 1713Reputation: 1713Reputation: 1713Reputation: 1713Reputation: 1713
if it is from cvs or svn then a " configure" file must be made
this should do it
Code:
autoreconf -v -i 
-- then run --
./configure --prefix= ?????
and can you post a link to the "plugin " you downloaded

Last edited by John VV; 04-22-2009 at 07:35 PM.
 
Old 04-23-2009, 10:40 AM   #7
devinmcelheran
Member
 
Registered: Jan 2009
Location: Ontario, Canada
Distribution: Debian 7.3.0
Posts: 134

Original Poster
Rep: Reputation: 16
so I just cd to the src directory and use those commands? And I've been trying to do a few plugins, none of them have worked. I even tried the "Elements" Script from http://www.elementsplugin.com/downlo...-recent.tar.gz I think I might be missing a dependency, some library or something, because I get a bunch of errors when I try to "make && make install".
 
Old 04-23-2009, 03:02 PM   #8
John VV
Guru
 
Registered: Aug 2005
Posts: 12,901

Rep: Reputation: 1713Reputation: 1713Reputation: 1713Reputation: 1713Reputation: 1713Reputation: 1713Reputation: 1713Reputation: 1713Reputation: 1713Reputation: 1713Reputation: 1713
Quote:
I think I might be missing a dependency, some library or something, because I get a bunch of errors
can you post those errors so we can help .

Question why did you not use the install script
http://www.elementsplugin.com/downloads/

the install script uses apt-get and will auto download the missing stuff

and that plugin ( the elements-most-recent.tar.gz)
contains this
Code:
.
|-- Makefile
|-- elements.c
|-- elements.xml.in
|-- images
|   |-- autumn1.png
|   |-- autumn2.png
|   |-- bubbles1.png
|   |-- bubbles2.png
|   |-- fireflies1.svg
|   |-- fireflies2.svg
|   |-- plugin-elements.png
|   |-- snow1.png
|   |-- snow2.png
|   `-- stars1.png
`-- plugin.info
there IS A MAKEFILE
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
compiz fusion plugins oguejiofor obiora Linux - Software 1 12-17-2008 04:37 PM
Help needed in installing unsupported compiz fusion plugins (Atlantis,Snowglobe) .B. Linux - Software 0 12-11-2007 06:49 PM
Where to find Compiz Fusion Plugins LinuxNoob75 Linux - Desktop 7 08-15-2007 03:12 PM
compiz fusion plugins BCarey Slackware 5 08-04-2007 03:26 PM
Compiz - How do I include the compiz-extra plugins? lostinpurdy Linux - Desktop 2 05-29-2007 02:00 AM


All times are GMT -5. The time now is 02:50 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration