LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 11-23-2009, 08:31 PM   #1
rconner
LQ Newbie
 
Registered: Nov 2009
Posts: 2

Rep: Reputation: 0
Trying to configure graphical environment on Ubuntu 9.04 Server


I'm very new to the Linux world, so be gentle. I've been trying to configure the server to run a graphical interface. I have read numerous configuration guides and posts, but nothing seems to fix the issue. I tried to change the run levels from 2 to 5, but still no help. Can someone give some guidance?
 
Old 11-23-2009, 10:10 PM   #2
Davno
Member
 
Registered: Mar 2004
Location: Montreal, Canada
Distribution: Mandriva 2010.2
Posts: 148

Rep: Reputation: 24
Quote:
Originally Posted by rconner View Post
I'm very new to the Linux world, so be gentle. I've been trying to configure the server to run a graphical interface. I have read numerous configuration guides and posts, but nothing seems to fix the issue. I tried to change the run levels from 2 to 5, but still no help. Can someone give some guidance?
To change runlevel permanently modify (as root) the file /etc/inittab. Look for a line like this:
Code:
id:5:initdefault:
Make a backup of your original inittab before so you can copy it back in case of problem.
 
Old 11-24-2009, 12:10 AM   #3
linuxlover.chaitanya
Senior Member
 
Registered: Apr 2008
Location: Nagpur, India
Distribution: Cent OS 5/6, Ubuntu Server 10.04
Posts: 4,629

Rep: Reputation: Disabled
No. Changing the runlevel will not help. Ubuntu server edition does not install X by default. So no matter what run level you choose it would not boot up in graphical environment until you install X server and all the related X packages.
To boot into graphical environment just install the desktop packages and you would be booting X.

Do
Quote:
sudo apt-get install ubuntu-desktop
And it is done.
 
Old 11-24-2009, 07:22 AM   #4
knudfl
LQ 5k Club
 
Registered: Jan 2008
Location: Copenhagen, DK
Distribution: pclos2016, Slack14.1 Deb Jessie, + 50+ other Linux OS, for test only.
Posts: 16,276

Rep: Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154
@ Davno : And Debian uses runlevel 2 as default,
usually no reason to change it, and not at all an
easy thing to do.

.....

Last edited by knudfl; 11-24-2009 at 07:26 AM.
 
Old 11-24-2009, 08:29 AM   #5
Davno
Member
 
Registered: Mar 2004
Location: Montreal, Canada
Distribution: Mandriva 2010.2
Posts: 148

Rep: Reputation: 24
@ knudfl : What is so hard about editing a file ?
And rconner did ask how to do it:
Code:
I tried to change the run levels from 2 to 5, but still no help
As for default of each distro, i agree i don't know them all.
 
Old 11-24-2009, 09:23 AM   #6
rconner
LQ Newbie
 
Registered: Nov 2009
Posts: 2

Original Poster
Rep: Reputation: 0
I just tried to install "ubuntu-desktop". It comes back telling me "Couldn't find the ubuntu-desktop package". I have a stupid question - do you need the internet access to get this "ubuntu-desktop" package? If so, that's part of the problem. We don't have internet access yet.
 
Old 11-24-2009, 09:36 AM   #7
knudfl
LQ 5k Club
 
Registered: Jan 2008
Location: Copenhagen, DK
Distribution: pclos2016, Slack14.1 Deb Jessie, + 50+ other Linux OS, for test only.
Posts: 16,276

Rep: Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154
@ Davno
No reason to change it means : Don't do it.
May sound like contradictions : Using run level 2
.. and is automatically taking you to the graphical
login ( e.g. gdm ) when a window manager is installed.

Don't know exactly how it works, never had reasons
for changing it.
Default : the file /etc/X11/default-display-manager
says e.g. /usr/bin/kdm . Change the line to : none
.. and the log in is CLI.
https://lists.ubuntu.com/archives/ub...ly/087620.html
Quote:
Ubuntu uses the Debian model, and the default runlevel is 2, unless
otherwise configured - so init 3 won't help, I'm afraid, unless you
enjoy reconfiguring runlevels .
 
Old 11-24-2009, 10:30 AM   #8
knudfl
LQ 5k Club
 
Registered: Jan 2008
Location: Copenhagen, DK
Distribution: pclos2016, Slack14.1 Deb Jessie, + 50+ other Linux OS, for test only.
Posts: 16,276

Rep: Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154
@ rconner : Ubuntu 9.04.

Have you got the install DVD ? cd set ?
( It's a problem finding anything but live ones
on the internet, there should exist a 4 cd set.)
http://iso.linuxquestions.org/ubuntu/
If not already added to /etc/apt/sources.list,
please insert the DVD or cd and do the command
sudo apt-cdrom add

After that it should be possible to install
a 'Desktop Environment' = 'Gnome' with
sudo apt-get install ubuntu-desktop
.....

Last edited by knudfl; 11-24-2009 at 11:01 AM.
 
Old 11-25-2009, 12:13 AM   #9
linuxlover.chaitanya
Senior Member
 
Registered: Apr 2008
Location: Nagpur, India
Distribution: Cent OS 5/6, Ubuntu Server 10.04
Posts: 4,629

Rep: Reputation: Disabled
Quote:
Originally Posted by rconner View Post
I just tried to install "ubuntu-desktop". It comes back telling me "Couldn't find the ubuntu-desktop package". I have a stupid question - do you need the internet access to get this "ubuntu-desktop" package? If so, that's part of the problem. We don't have internet access yet.
Yes, either you need an internet connection to install the packages or a cd/dvd. Apt is configured to download and install packages from internet repositories and you would need to enable your optical media repository which is disabled by default.
If you just want GUI for administering your server you can do it with webmin . No need for a complete desktop environment. Just install the X server and firefox or any web browser and webmin. It will allow you to administer your server through your web browser.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Graphical use of ubuntu server 8.04 124vikas.dange@gmail.com Linux - Newbie 4 08-28-2009 01:30 AM
LXer: How to Install and Configure DHCP Server in Ubuntu Server LXer Syndicated Linux News 0 12-22-2008 12:10 PM
java graphical installer on ubuntu server acidjuice Linux - Server 1 09-16-2008 01:15 PM
LXer: Set Up Ubuntu-Server 6.10 As A Firewall/Gateway For Your Small Business Environment LXer Syndicated Linux News 0 11-26-2006 10:54 AM
How Does an X Server tie in with Window Managers, Graphical Environment, & X Clients? TGWDNGHN Programming 8 08-04-2006 05:33 AM


All times are GMT -5. The time now is 12:52 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration