LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 06-16-2011, 10:30 PM   #1
trist007
Senior Member
 
Registered: May 2008
Distribution: Slackware
Posts: 1,033

Rep: Reputation: 69
Troubleshooting autofs...


I have /var/ftp/pub on Computer A being exported via nfs. I'm running defaults, master map file is defined as auto.master in /etc/sysconfig/autofs.

On Computer B, I can manually mount the nfs share with no problem. However, it doesn't seem to mount with autofs.

I'm running Centos 5.5 on Computer B. I have the following configs
Code:
/etc/auto.master
/misc  /etc/auto.misc
Code:
/etc/auto.misc
pub   -fstype=nfs  computerA:/var/ftp/pub
Now /misc does not exist on computer B. I run service start autofs. It starts up no problem. Yet when I go to /misc, there's nothing in there. I temporarily disabled selinux as well as iptables to help with troubleshooting. Any ideas of what else to check? I mean I can manually mount the share in compouter B no problem.

Last edited by trist007; 06-16-2011 at 10:32 PM.
 
Old 06-16-2011, 11:40 PM   #2
trist007
Senior Member
 
Registered: May 2008
Distribution: Slackware
Posts: 1,033

Original Poster
Rep: Reputation: 69
Does autofs require NIS to work?
 
Old 06-16-2011, 11:41 PM   #3
chrism01
LQ Guru
 
Registered: Aug 2004
Location: Sydney
Distribution: Centos 6.8, Centos 5.10
Posts: 17,260

Rep: Reputation: 2328Reputation: 2328Reputation: 2328Reputation: 2328Reputation: 2328Reputation: 2328Reputation: 2328Reputation: 2328Reputation: 2328Reputation: 2328Reputation: 2328
iirc, the default is lazy mounting ie it won't 'appear' until you go all the way into the target dir ie /misc/pub ( not just /misc )
http://www.linuxtopia.org/online_boo...ig-autofs.html

PS @trist007: NIS is not reqd
 
Old 06-16-2011, 11:59 PM   #4
trist007
Senior Member
 
Registered: May 2008
Distribution: Slackware
Posts: 1,033

Original Poster
Rep: Reputation: 69
Ah, haha, I see. Thanks chrism01.
 
Old 06-17-2011, 12:08 AM   #5
Tinkster
Moderator
 
Registered: Apr 2002
Location: in a fallen world
Distribution: slackware by choice, others too :} ... android.
Posts: 23,067
Blog Entries: 11

Rep: Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910
Quote:
Originally Posted by trist007 View Post
I have /var/ftp/pub on Computer A being exported via nfs. I'm running defaults, master map file is defined as auto.master in /etc/sysconfig/autofs.

On Computer B, I can manually mount the nfs share with no problem. However, it doesn't seem to mount with autofs.

I'm running Centos 5.5 on Computer B. I have the following configs
Code:
/etc/auto.master
/misc  /etc/auto.misc
Code:
/etc/auto.misc
pub   -fstype=nfs  computerA:/var/ftp/pub
Now /misc does not exist on computer B. I run service start autofs. It starts up no problem. Yet when I go to /misc, there's nothing in there. I temporarily disabled selinux as well as iptables to help with troubleshooting. Any ideas of what else to check? I mean I can manually mount the share in compouter B no problem.
Auto-mounted directories don't appear until needed. A simple way
for you to deal with this would be to
ln -s /misc/pub /pub


As soon as you 'cd /pub' (or, obviously, /misc/pub), it will get
mounted, and you can use it to your hearts content (if the other
parameters in e.g., the share are correct). And yes, tab-expansion
won't work for this ;}


Cheers,
Tink


P.S.: Got to learn not to click "quote" and walk away

Last edited by Tinkster; 06-17-2011 at 12:09 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
autofs under / Micro420 Red Hat 9 03-04-2010 05:00 PM
autofs sl4ckw4re Slackware 1 09-18-2006 01:51 PM
autofs kemkem42 Linux - Software 1 09-22-2005 02:22 PM
Using Autofs guygriffiths Linux - Software 1 09-17-2003 11:31 AM
Autofs...help please yourcompadre Linux - Networking 0 06-03-2003 10:07 PM


All times are GMT -5. The time now is 04:07 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration