LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 12-11-2005, 08:50 PM   #1
szofiel
LQ Newbie
 
Registered: Sep 2005
Location: Mexico
Distribution: Ubuntu, Gentoo
Posts: 9

Rep: Reputation: 0
Troubles with X Server


Hi! I would like to know how to solve this "little" problem:

After an APT-GET, my Debian seems to get stuck and prints this:

(gnome-terminal:4937): Gtk-WARNING **: cannot open display:
Traceback (most recent call last):
File "/usr/bin/apt-listchanges", line 218, in ?
main()
File "/usr/bin/apt-listchanges", line 187, in main
frontend.display_output(changes)
File "/usr/lib/site-python/apt_listchanges.py", line 451, in display_output
raise OSError('Subprocess ' + shellcommand + ' exited with status ' + str(status))
OSError: Subprocess x-terminal-emulator -T apt-listchanges -e sensible-browser /tmp/tmp7IbQRu.html exited with status 1
dpkg-preconfigure: cannot connect to X server
(Leyendo la base de datos ...
350349 ficheros y directorios instalados actualmente.)
Preparando para reemplazar tetex-bin 3.0-10.1 (usando .../tetex-bin_3.0-11_i386.deb) ...
frontend: cannot connect to X server
dpkg: error al procesar /var/cache/apt/archives/tetex-bin_3.0-11_i386.deb (--unpack):
el subproceso pre-installation script devolvió el código de salida de error 1
Preparando para reemplazar linux-image-2.6.14-2-686 2.6.14-4 (usando .../linux-image-2.6.14-2-686_2.6.14-5_i386.deb) ...
frontend: cannot connect to X server
dpkg: error al procesar /var/cache/apt/archives/linux-image-2.6.14-2-686_2.6.14-5_i386.deb (--unpack):
el subproceso pre-installation script devolvió el código de salida de error 1
frontend: cannot connect to X server
dpkg: error al reorganizar:
el subproceso post-removal script devolvió el código de salida de error 1
Preparando para reemplazar linux-image-2.6.14-2-386 2.6.14-4 (usando .../linux-image-2.6.14-2-386_2.6.14-5_i386.deb) ...
frontend: cannot connect to X server
dpkg: error al procesar /var/cache/apt/archives/linux-image-2.6.14-2-386_2.6.14-5_i386.deb (--unpack):
el subproceso pre-installation script devolvió el código de salida de error 1
frontend: cannot connect to X server
dpkg: error al reorganizar:
el subproceso post-removal script devolvió el código de salida de error 1
Preparando para reemplazar linux-image-2.6.14-2-686-smp 2.6.14-4 (usando .../linux-image-2.6.14-2-686-smp_2.6.14-5_i386.deb) ...
frontend: cannot connect to X server
dpkg: error al procesar /var/cache/apt/archives/linux-image-2.6.14-2-686-smp_2.6.14-5_i386.deb (--unpack):
el subproceso pre-installation script devolvió el código de salida de error 1
frontend: cannot connect to X server
dpkg: error al reorganizar:
el subproceso post-removal script devolvió el código de salida de error 1
Preparando para reemplazar yasm 0.4.0-0.0 (usando .../archives/yasm_0.4.0-3_i386.deb) ...
Desempaquetando el reemplazo de yasm ...
dpkg: error al procesar /var/cache/apt/archives/yasm_0.4.0-3_i386.deb (--unpack):
intentando sobreescribir `/usr/include/libyasm/bytecode.h', que está también en el paquete libyasm0-dev
dpkg-deb: el subproceso paste fue terminado por la señal (Tubería rota)
Se encontraron errores al procesar:
/var/cache/apt/archives/tetex-bin_3.0-11_i386.deb
/var/cache/apt/archives/linux-image-2.6.14-2-686_2.6.14-5_i386.deb
/var/cache/apt/archives/linux-image-2.6.14-2-386_2.6.14-5_i386.deb
/var/cache/apt/archives/linux-image-2.6.14-2-686-smp_2.6.14-5_i386.deb
/var/cache/apt/archives/yasm_0.4.0-3_i386.deb
Updating Debian Packages of System Configurations (dpsyco).
No samba users to configure, skipping.
sync: opción inválida -- c
Pruebe `sync --help' para más información.
E: Sub-process /usr/bin/dpkg returned an error code (1)



Any solutions?

Thank you very much...
 
Old 12-12-2005, 08:21 PM   #2
ctkroeker
Senior Member
 
Registered: May 2005
Location: Paraguay
Posts: 1,565
Blog Entries: 1

Rep: Reputation: 50
Looks like:

Se encontraron errores al procesar:
/var/cache/apt/archives/tetex-bin_3.0-11_i386.deb
/var/cache/apt/archives/linux-image-2.6.14-2-686_2.6.14-5_i386.deb
/var/cache/apt/archives/linux-image-2.6.14-2-386_2.6.14-5_i386.deb
/var/cache/apt/archives/linux-image-2.6.14-2-686-smp_2.6.14-5_i386.deb
/var/cache/apt/archives/yasm_0.4.0-3_i386.deb


had some errors or they are corrupted.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
X server troubles simon Linux - Newbie 5 05-26-2005 03:50 PM
Having troubles connecting to a vino vnc server from windows xp using tightvnc,help? brynjarh Linux - Software 0 01-12-2005 05:28 AM
RPM and x server troubles ..... fellsin Linux - General 4 01-11-2005 04:12 PM
Having troubles installing server applications ddzc Linux - Software 1 11-03-2003 01:34 PM
httpd server troubles peter79 Linux - Software 2 02-11-2002 06:59 AM


All times are GMT -5. The time now is 02:54 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration