LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 10-22-2002, 04:52 PM   #1
Judda
LQ Newbie
 
Registered: Oct 2002
Location: UK
Posts: 14

Rep: Reputation: 0
Question trouble with X under vmware


Hi there I am running Redhat 7.2 in a VMWare workstation on a Windows 2000 box, the plan was the get up to speed with Redhat in a virtual machine before I switch for real.

Redhat is installed ok, but X will not run, Xconfigurator always says there is a problem with my settings.

I have a Nvidia GeForce2 Ti card (64mb), the monitor is unknown, no label or badge :-( but it can do 1024x768 under Windows2k.

I have updated the redhat install with the current version of XFree86 (all good learning stuff here !) but still cannot get X to run, I do at least get a little flicker now !

The error I get on StartX is:

Fatal server error:
AddScreen/ScreenInit failed for driver 0
XIO: fatal IO error 104 (Connection reset by peer) on X server ":0.0" after 0 requests (o known processed) with 0 events remaining.

I think that maybe I need to forget about Xconfigurator and configure the /etc/X11/XF86Config-4 file, but I really don't have a clue where to start...

Any clues ?

Thanks
Judda
 
Old 10-23-2002, 08:12 AM   #2
sihere
LQ Newbie
 
Registered: Dec 2001
Posts: 27

Rep: Reputation: 15
Talking Hopefully some help!

I have ran various versions of Linux under VMware and XP, what I generally do is install Linux but do not start X (use linux 2) as start-up so X does not run, then using the menu select Vmware tools, follow the instructions for running the script (well documented as I managed it 1st time), then (if I remember correctly) the system restarts, at this point all will be well....
As a matter of fact I am installing Redhat tonight again for a MySQL test so I will come back later, let me know if you have any problems.

Si
 
Old 10-23-2002, 08:13 AM   #3
sihere
LQ Newbie
 
Registered: Dec 2001
Posts: 27

Rep: Reputation: 15
Sorry, I should had said I also have a GeForce 2 card...So here goes.

Si
 
Old 10-23-2002, 04:26 PM   #4
Judda
LQ Newbie
 
Registered: Oct 2002
Location: UK
Posts: 14

Original Poster
Rep: Reputation: 0
Thanks

Excellent I will give that a try.

Thanks
 
Old 10-23-2002, 05:52 PM   #5
Judda
LQ Newbie
 
Registered: Oct 2002
Location: UK
Posts: 14

Original Poster
Rep: Reputation: 0
Question X but no file manager

OK I followed the vmwaretools install, I can now run X Windows !
However, I don't get a file manager, IE:Gnome, kde etc

Does anyone know how to start KDE when X starts ?

Thanks for your help
 
Old 10-24-2002, 05:23 PM   #6
sihere
LQ Newbie
 
Registered: Dec 2001
Posts: 27

Rep: Reputation: 15
I is not an expert but I imagine you just add it to the rc5 script (runlevel 5 script).....Must admit that I set-up mine by getting the linux install to do all the work and b4 the 1st reboot used the vmware tools to go!!!!!!
Also, when X boots up you should get a logon screen, in this is the window managers available (if you installed any that is :-( )

Si
 
Old 10-25-2002, 04:03 AM   #7
Judda
LQ Newbie
 
Registered: Oct 2002
Location: UK
Posts: 14

Original Poster
Rep: Reputation: 0
Thanks,

Yeah there is a lot to be said for doing the right tasks in the Correct Order !

Thanks
Judda
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Having trouble with vmware rlh989 SUSE / openSUSE 3 06-07-2005 02:38 AM
VMWare r/w weird trouble waiser Linux - General 1 12-08-2004 05:23 PM
VMWARE trouble lbtheone Linux - Software 1 10-17-2004 11:17 PM
VMware trouble citrus Linux - General 1 01-27-2004 11:25 AM
VMWare trouble with RH9 jovix Linux - General 1 05-29-2003 04:05 AM


All times are GMT -5. The time now is 04:28 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration