LinuxQuestions.org
Latest LQ Deal: Complete CCNA, CCNP & Red Hat Certification Training Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 01-01-2009, 08:02 PM   #1
scotthill
LQ Newbie
 
Registered: Jan 2009
Posts: 25

Rep: Reputation: 15
Trouble with networking, Apache and otherwise pervasive ignorance.


I maintain a few web pages on a commercially hosted LAMP server and now I've upgraded to allow root access so I can install some MySQL and PHP extensions. So before I touch the production box, I thought it wise to set up a linux server at home to use it as a development tool so I know what I'm doing somewhat. I've been working with Fedora 9 for a week and frankly I'm very frustrated. Maybe some experienced folks could help me with the low hanging fruit. Issues:

1) NO PORT 80. I haven't been able to get port 80 to show up on my local network. Port sluth on my XP box can find port 80 for my XP box -- XAMPPed, the network printer, and the router but not from my Fedora/Apache box. Apache says it is on and http://localhost pulls up the Apache splash screen on the Fedora box. The port sluth on the XP box does find ports 22 and 111 open on the Fedora box. I specifically enabled port 80 in the firewall and even turning the firewall off all together hasn't brought port 80 to the network. I've disabled SELinux with no help.

2) BOOT ERROR LOG FILE. There is an error on boot that shows up for about 2 seconds and I can't read it that fast. I assume it is in a log file somewhere but I don't know the name, where it is or how to read it.

3) SU IN GNOME FILE BROWSER? File Browser is a nice tool but I can't see anything but the home directory. How do I get SU permissions inside of File Browser. Is it possible to set up a user with SU permissions on all the time?

4) NETWORK CARD DISABLED ON BOOT. I set the Network for a static IP address of 192.168.1.100 and a net mask of 255.255.255.0 and now on power up the network card is always disabled. I can manually turn it on and then the box finds the gateway and the internet just fine from that point on. Still no port 80 visible on the network but I can ping the box OK.

5)SAMBA I can't make Samba work but at this point I feel like such a complete idiot that I'm really not surprised. Why does it need to be this tough?

6)The good news is that I was able to get my network printer to work which only took 17 trial and error attempts before I found the right combination of blows and incantations. So there is hope. Who knows what I f'ed up in the process.

Thanks for helping,
Newbie @ Scott Hill
 
Old 01-01-2009, 10:49 PM   #2
enyawix
Member
 
Registered: Sep 2003
Location: ky
Distribution: gentoo
Posts: 399

Rep: Reputation: 32
Ok lets take this one step at a time.

I will focus on your network setup first. Type ifconfig what do you get? ifconfig Will output your network setup. Next type route, route will output your network routing table. Last type hostname. Hostname will out put your computer's hostname. Post what you get from ifconfig, route, and hostname hear.
 
Old 01-01-2009, 11:53 PM   #3
scotthill
LQ Newbie
 
Registered: Jan 2009
Posts: 25

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by enyawix View Post
I will focus on your network setup first. Type ifconfig what do you get? ifconfig Will output your network setup. Next type route, route will output your network routing table. Last type hostname. Hostname will out put your computer's hostname. Post what you get from ifconfig, route, and hostname hear.
I entered SU + password then entered ifconfig and got:

[root@linuxserver Isuzu]# ifconfig
bash: ifconfig: command not found


Same story for route. I think I need to set the search path to something I don't know what or how.


Host name is linuxserver which is what I had set it up with.


Some additional data. The Apache server is throwing an error on boot. It happens so fast that I can't read it all but I think it's say that it can't bind to 192.168.1.100

Also everytime I start Firefox it comes up in the "offline" mode and if I turn offline to on line then it browses OK.

Also the little network box in the upper right hand corner of of the Gnome desktop has a red x on it suggesting that it's not up. I can ping 192.168.1.100 from elsewhere on the network just fine but locally some things think the network is NFG.
 
Old 01-02-2009, 12:30 AM   #4
enyawix
Member
 
Registered: Sep 2003
Location: ky
Distribution: gentoo
Posts: 399

Rep: Reputation: 32
ok try /sbin/ifconfig and /sbin/route from su
 
Old 01-02-2009, 01:43 AM   #5
scotthill
LQ Newbie
 
Registered: Jan 2009
Posts: 25

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by enyawix View Post
ok try /sbin/ifconfig and /sbin/route from su
Got it thanks:

[root@linuxserver Isuzu]# /sbin/ifconfig
eth0 Link encap:Ethernet HWaddr 00:48:54:8F:16:B8
inet addr:192.168.1.100 Bcast:192.168.1.255 Mask:255.255.255.0
inet6 addr: fe80::248:54ff:fe8f:16b8/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:3155 errors:0 dropped:0 overruns:0 frame:0
TX packets:2825 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:2070739 (1.9 MiB) TX bytes:504924 (493.0 KiB)
Interrupt:17 Base address:0xe000

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:6386 errors:0 dropped:0 overruns:0 frame:0
TX packets:6386 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:319460 (311.9 KiB) TX bytes:319460 (311.9 KiB)

[root@linuxserver Isuzu]# /sbin/route
Kernel IP routing table
Destination Gateway Genmask Flags Metric Ref Use Iface
192.168.1.0 * 255.255.255.0 U 0 0 0 eth0
link-local * 255.255.0.0 U 0 0 0 eth0
default dslrouter 0.0.0.0 UG 0 0 0 eth0
[root@linuxserver Isuzu]#

[root@linuxserver Isuzu]# hostname
linuxserver
 
Old 01-02-2009, 03:34 AM   #6
enyawix
Member
 
Registered: Sep 2003
Location: ky
Distribution: gentoo
Posts: 399

Rep: Reputation: 32
ok the default gateway from /sbin/route looks strange. try this

/sbin/route add default gw ?

the ? needs to be your gateway ip address

my gate way is 192.168.0.1 so I use
/sbin/route add default gw 192.168.0.1

this will disable the firewall

iptables -F
iptables -F -t mangle

iptables -X
iptables -X -t mangle

iptables -Z

iptables -P INPUT ACCEPT
iptables -P OUTPUT ACCEPT
iptables -P FORWARD ACCEPT

iptables -A INPUT -i lo -j ACCEPT
iptables -A OUTPUT -o lo -j ACCEPT

now try starting apache or restarting apache
 
Old 01-02-2009, 04:41 AM   #7
scotthill
LQ Newbie
 
Registered: Jan 2009
Posts: 25

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by enyawix View Post
ok the default gateway from /sbin/route looks strange. try this /sbin/route add default gw ?
my gate way is 192.168.0.1 so I use
/sbin/route add default gw 192.168.0.1
OK I did this:

[root@linuxserver Isuzu]# /sbin/route add default gw 192.168.1.1
SIOCADDRT: File exists
[root@linuxserver Isuzu]# /sbin/route
Kernel IP routing table
Destination Gateway Genmask Flags Metric Ref Use Iface
192.168.1.0 * 255.255.255.0 U 0 0 0 eth0
link-local * 255.255.0.0 U 0 0 0 eth0
default dslrouter 0.0.0.0 UG 0 0 0 eth0


So my gateway is 192.168.1.1 and I entered that into the route command then why does it come up with 192.168.1.0 ?

The firewall has been turned of through the System->Admin->Firewall

I think I will do an "ifconfig eth0 down" and start over.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
LXer: Pervasive support LXer Syndicated Linux News 0 11-24-2006 02:54 PM
LXer: Innovations in Pervasive Computing LXer Syndicated Linux News 0 06-25-2006 08:21 AM
Connecting iodbc with Pervasive client odbc jlowry Linux - Software 0 09-28-2004 07:13 PM
Mandrake and my ignorance Brianstech Linux - Software 19 06-14-2004 03:47 PM
Linux Mail: Confusion and Ignorance james1980 Linux - Software 3 04-02-2004 04:25 AM


All times are GMT -5. The time now is 02:45 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration