LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 04-29-2015, 08:29 AM   #31
esraam
Member
 
Registered: Apr 2015
Posts: 110

Original Poster
Rep: Reputation: Disabled

Quote:
Originally Posted by pan64 View Post
looks like the file is still there:

please try to remove/rename that file
this is the new result after renaming the file :


#startx :
[[[
(==) Log file: "/var/log/Xorg.0.log", Time: Wed Apr 29 15:27:10 2015
(==) Using system Config directory "/usr/share/X11/xorg.conf.d"
Initializing built-in extension Generic Event Extension Initializing built-in extension Generic Event Extension
Initializing built-in extension SHAPE
Initializing built-in extension MIT_SHM
Initializing built-in extension XInputExtension
Initializing built-in extension XTEST
Initializing built-in extension BIG_REQUESTS
Initializing built-in extension SYNC
Initializing built-in extension XKEYBOARD
Initializing built-in extension XC-MISC
Initializing built-in extension SECURITY
Initializing built-in extension XINERAMA
Initializing built-in extension XFIXES
Initializing built-in extension RENDER
Initializing built-in extension RANDR
Initializing built-in extension COMPOSITE
Initializing built-in extension DAMAGE
Initializing built-in extension MIT-SCREEN-SAVER
Initializing built-in extension DOUBLE-BUFFER
Initializing built-in extension RECORD
Initializing built-in extension DPMS
Initializing built-in extension Present
Initializing built-in extension X-Resource
Initializing built-in extension XVideo
Initializing built-in extension Xvideo-MotionCompensation
Initializing built-in extension SELinux
Initializing built-in extension XFree86-VidModeExtension
Initializing built-in extension XFree86-DGA
Initializing built-in extension XFree86-DRI
Initializing built-in extension DRI2
Loading extension GLX
(EE)
Fatal server error :
(EE) no screens found(EE)
(EE)
Please consult the Scientific linux support at http://www.scientificlinux.org/maillists for help .
(EE) Please also check the log file at " /var/log/Xorg.0.log" for additional information.
(EE)
(EE) Server terminated with error (1). Closing log file .
giving up.
xinit: Connection refused ( errno 111) : unable to connect to Xserver
xinit: No Such process (errno 3) : Server error.

]]]


Still have the same errors ... How can I solve this ?

Thanks
 
Old 04-29-2015, 08:35 AM   #32
pan64
LQ Guru
 
Registered: Mar 2012
Location: Hungary
Distribution: debian i686 (solaris)
Posts: 8,104

Rep: Reputation: 2267Reputation: 2267Reputation: 2267Reputation: 2267Reputation: 2267Reputation: 2267Reputation: 2267Reputation: 2267Reputation: 2267Reputation: 2267Reputation: 2267
Please also check the log file at " /var/log/Xorg.0.log" for additional information.
 
Old 04-29-2015, 08:43 AM   #33
esraam
Member
 
Registered: Apr 2015
Posts: 110

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by pan64 View Post
Please also check the log file at " /var/log/Xorg.0.log" for additional information.
This is my log file /var/log/Xorg.0.log
X.Org X Server 1.15.0
Release Date : 2013-12-27
[261610.926] X Protocol Version 11, Revision 0
[261610.927] Build Operating System s16 2.6.32-504.e16.x86_64
[261610.927] Current Operating System: Linux master.fci 2.6.32-504
[261610.928] Kernel command line: ro root=/dev/mapper/vg_master-lv_root rd_No_LUKS KEYBOARDTYPE=pc KEYTABlE=us LANG=en_US.UTF-$
[261610.929] Build Date: 11 December 2014
[261610.929] Build ID: xorg-x11-server 1.15.0-25.s16
[261610.929] Current version of pixman: 0.32.4
[261610.930] Before reporting problems, check http://www.scientificlinux.org/maillists
to make sure that you have the latest version.
[261610.930] Markers: (--) probed, (**)from config file, (==) default setting,
(++) from command line , (!!) notice, (ll) informational,
(WW) warning, (EE) error, (NI) not implemented, (??)unknown.
[261610.932] (==) Log file: "/var/log/Xorg.0.log"
[261610.932] (==) Using Config file: "/etc/X11/xorg.conf"
[261610.933] (==) Using system config directory "/usr/share/x11/xorg.conf.d"
[261610.933] (==) ServerLayout "X.org Configured"
[261610.933] (**) :--> Screen "Screen0" (0)
[261610.933] (**) : :-->Monitor "Monitor0"
[261610.933] (**) : :-->Device "Card0"
[261610.933] (**) :--> Input Device "Mouse0"
[261610.933] (**) :--> Input Device "Keyboard0"
[261610.933] (==) Automatically adding devices
[261610.933] (==) Automatically enabling devices
[261610.933] (==) Not automatically adding GPU devices
[261610.933] (WW) The directory "/usr/local/share/fonts/misc/" does not exist
[261610.933] Entry deleted from font path
[261610.933] (WW) The directory "/usr/local/share/fonts/TTF/" does not exist
[261610.933] Entry deleted from font path
[261610.933] (WW) The directory '/usr/local/share/fonts/OTF/" does not exist
Entry deleted from font path
[261610.933] (WW) The directory '/usr/local/share/fonts/Type1/" does not exist
Entry deleted from font path
[261610.933] (WW) The directory '/usr/local/share/fonts/100dpi/" does not exist
Entry deleted from font path
[261610.933] (WW) The directory '/usr/local/share/fonts/75dpi/" does not exist
Entry deleted from font path
[261610.933] (**) FontPath set to:
catalogue:/etc/X11/fontpath.d,
built-ins
[261610.933] (**) ModulePath set to "/usr/lib/xorg/modules"
[261610.933] (WW) Hotplugging is on, devices using drive 'kbd', 'mouse' or 'vmouse' will be disabled.
[261610.933] (WW) Disabling Mouse0
[261610.933] (WW) Disabling Keyboard0
[261610.933] (ll) Loader magic: 0x823020
[261610.933] (ll) Module ABI versions:
[261610.933] X.Org ANSI C Emulation: 0.4
[261610.933] X.Org Video Driver: 15.0
[261610.933] X.Org XInput driver: 20.0
[261610.933] X.Org Server Extension: 8.0
[261610.934] (--) PCI :*(0:0:2:0) 8086:0412:1458:d000 rev6, Mem @ 0xf0000000/4194304, 0xe0000000/26843546, I/O @ 0x0000f000/64$
[261610.934] Initializing built-in extension Generic Event Extension
[261610.935] Initializing built-in extension SHAPE
[261610.935] Initializing built-in extension MIT_SHM
[261610.935] Initializing built-in extension XInputExtension
[261610.936] Initializing built-in extension XTEST
[261610.936] Initializing built-in extension BIG_REQUESTS
[261610.936] Initializing built-in extension SYNC
[261610.937] Initializing built-in extension XKEYBOARD
[261610.937] Initializing built-in extension XC-MISC
[261610.937] Initializing built-in extension SECURITY
[261610.938] Initializing built-in extension XINERAMA
[261610.938] Initializing built-in extension XFIXES
[261610.938] Initializing built-in extension RENDER
[261610.938] Initializing built-in extension RANDR
[261610.939] Initializing built-in extension COMPOSITE
[261610.939] Initializing built-in extension DAMAGE
[261610.939] Initializing built-in extension MIT-SCREEN-SAVER
[261610.940] Initializing built-in extension DOUBLE-BUFFER
[261610.940] Initializing built-in extension RECORD
[261610.940] Initializing built-in extension DPMS
[261610.941] Initializing built-in extension Present
[261610.941] Initializing built-in extension X-Resource
[261610.941] Initializing built-in extension XVideo
[261610.941] Initializing built-in extension Xvideo-MotionCompensation
[261610.942] Initializing built-in extension SELinux
[261610.942] Initializing built-in extension XFree86-VidModeExtension
[261610.942] Initializing built-in extension XFree86-DGA
[261610.943] Initializing built-in extension XFree86-DRI
[261610.943] Initializing built-in extension DRI2
[261610.943] (II) "glx" will be loaded. This was enabled by default and also specified in the config file.
[261610.943] (WW) "xwayland" is not to be loaded by default. Skipping.
[261610.943] (II) LoadModule: "glx"
[261610.943] (WW) Warning, couldn't open module glx
[261610.943] (II) UnloadModule: "glx"
[261610.943] (II) Unloading glx
[261610.943] (EE) Failed to load module "glx" (module does not exist,0)
[261610.943] (II) LoadModule: "radeon"
[261610.943] (WW) Warning, couldn't open module radeon
[261610.943] (II) UnloadModule "radeon"
[261610.943] (II) Unloading radeon
[261610.943] (EE) Failed to load module "radeon" (module does not exist, 0)
[261610.943] (EE) No drivers available.
[261610.943] (EE)
Fatal server error:
[261610.944] (EE) no screens found(EE)
[261610.944] (EE)
Please consult the scientific Linux support
at http://www.scientificlinux.org/maillists
for help.
[261610.945] (EE) Please also check the log file at "/var/log/Xorg.0.log" for additional information.
[261610.943] (EE)
]]]

I couldn't figure out how to solve the problem from the log file .
Hope you can .
Many thanks for your great effort to help
 
Old 04-29-2015, 08:55 AM   #34
pan64
LQ Guru
 
Registered: Mar 2012
Location: Hungary
Distribution: debian i686 (solaris)
Posts: 8,104

Rep: Reputation: 2267Reputation: 2267Reputation: 2267Reputation: 2267Reputation: 2267Reputation: 2267Reputation: 2267Reputation: 2267Reputation: 2267Reputation: 2267Reputation: 2267
[261610.943] (EE) No drivers available. The directory /usr/lib/xorg/modules/drivers is empty (or does not exist).
So it looks like you need to (re)install a driver. probably you need to install the package xorg-x11-drv-intel.
 
Old 04-29-2015, 08:57 AM   #35
esraam
Member
 
Registered: Apr 2015
Posts: 110

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by pan64 View Post
[261610.943] (EE) No drivers available. The directory /usr/lib/xorg/modules/drivers is empty (or does not exist).
So it looks like you need to (re)install a driver. probably you need to install the package xorg-x11-drv-intel.
#yum groupinstall "xorg-x11-drv-intel"

and got :
Warning : Group Xorg-x11-drv-intel does not exist
No packages in any requested group available to install or update

so What ?
 
Old 04-29-2015, 09:01 AM   #36
pan64
LQ Guru
 
Registered: Mar 2012
Location: Hungary
Distribution: debian i686 (solaris)
Posts: 8,104

Rep: Reputation: 2267Reputation: 2267Reputation: 2267Reputation: 2267Reputation: 2267Reputation: 2267Reputation: 2267Reputation: 2267Reputation: 2267Reputation: 2267Reputation: 2267
that is not a group, but a single package. so try yum install <package>
 
Old 04-29-2015, 09:51 AM   #37
esraam
Member
 
Registered: Apr 2015
Posts: 110

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by pan64 View Post
that is not a group, but a single package. so try yum install <package>
I installed the package finally
thanks .
Then I typed
#startx
the desktop opened but hangup !
I restarted my computer and since then it is loading and I am unable to open the terminal !
I have now a complete black screen with a circle ( the mouse) loading ..loading ...loading till no end !
I tried Alt+f2 to go to the terminal but nothing happened .

What do you think I should do ?

Many thanks for your great effort
 
Old 04-29-2015, 09:53 AM   #38
pan64
LQ Guru
 
Registered: Mar 2012
Location: Hungary
Distribution: debian i686 (solaris)
Posts: 8,104

Rep: Reputation: 2267Reputation: 2267Reputation: 2267Reputation: 2267Reputation: 2267Reputation: 2267Reputation: 2267Reputation: 2267Reputation: 2267Reputation: 2267Reputation: 2267
I would say you need to (re)install other xorg related packages too. Use Ctrl-Alt-F2 to go to the terminal.
 
Old 04-29-2015, 10:01 AM   #39
esraam
Member
 
Registered: Apr 2015
Posts: 110

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by pan64 View Post
I would say you need to (re)install other xorg related packages too. Use Ctrl-Alt-F2 to go to the terminal.
I would say you need to (re)install other xorg related packages too "
What are the related packages ?

ctrl-Alt-F2 : now does nothing at all .
Iam stuck in the black desktop with a mouse loading .
 
Old 04-29-2015, 10:08 AM   #40
pan64
LQ Guru
 
Registered: Mar 2012
Location: Hungary
Distribution: debian i686 (solaris)
Posts: 8,104

Rep: Reputation: 2267Reputation: 2267Reputation: 2267Reputation: 2267Reputation: 2267Reputation: 2267Reputation: 2267Reputation: 2267Reputation: 2267Reputation: 2267Reputation: 2267
unfortunately I'm not really familiar with scientific linux, but probably:
yum grouplist will print list the group of packages, you need to find the x, xorg related group (yum grouplist | grep -i xorg)
If Ctrl-Alt-F1 (or similar) does not work you need to reset your linux (or switch off/on)
 
Old 04-29-2015, 10:22 AM   #41
esraam
Member
 
Registered: Apr 2015
Posts: 110

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by pan64 View Post
unfortunately I'm not really familiar with scientific linux, but probably:
yum grouplist will print list the group of packages, you need to find the x, xorg related group (yum grouplist | grep -i xorg)
If Ctrl-Alt-F1 (or similar) does not work you need to reset your linux (or switch off/on)
I did reset the linux .
and still unable to open the cli
Before this last installation ,
I used to press Alt+F2 and this switches to the cli .
Now , It does nothing . neither does the ctrl-alt-f2 or cltrl-alt-f1
even after I restarted the computer .
loading ....loading ....loading with no end !
 
Old 04-29-2015, 10:27 AM   #42
pan64
LQ Guru
 
Registered: Mar 2012
Location: Hungary
Distribution: debian i686 (solaris)
Posts: 8,104

Rep: Reputation: 2267Reputation: 2267Reputation: 2267Reputation: 2267Reputation: 2267Reputation: 2267Reputation: 2267Reputation: 2267Reputation: 2267Reputation: 2267Reputation: 2267
so you need to go into single user mode. I assume during boot you have a menu to select normal boot or recovery mode. But again, I'm not really familiar with that os.
 
Old 04-29-2015, 10:29 AM   #43
esraam
Member
 
Registered: Apr 2015
Posts: 110

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by pan64 View Post
so you need to go into single user mode. I assume during boot you have a menu to select normal boot or recovery mode. But again, I'm not really familiar with that os.

" so you need to go into single user mode "
how ?

When I restart the computer , It opens the scientific linux directly without giving choices of normal boot or recover mode .
How can I force it to enter recovery mode ?

Last edited by esraam; 04-29-2015 at 10:59 AM.
 
Old 04-29-2015, 11:31 AM   #44
jpollard
Senior Member
 
Registered: Dec 2012
Location: Washington DC area
Distribution: Fedora, CentOS, Slackware
Posts: 4,602

Rep: Reputation: 1241Reputation: 1241Reputation: 1241Reputation: 1241Reputation: 1241Reputation: 1241Reputation: 1241Reputation: 1241Reputation: 1241
Quote:
Originally Posted by esraam View Post
This is my log file /var/log/Xorg.0.log
X.Org X Server 1.15.0
Release Date : 2013-12-27
[261610.926] X Protocol Version 11, Revision 0
[261610.927] Build Operating System s16 2.6.32-504.e16.x86_64
[261610.927] Current Operating System: Linux master.fci 2.6.32-504
[261610.928] Kernel command line: ro root=/dev/mapper/vg_master-lv_root rd_No_LUKS KEYBOARDTYPE=pc KEYTABlE=us LANG=en_US.UTF-$
[261610.929] Build Date: 11 December 2014
[261610.929] Build ID: xorg-x11-server 1.15.0-25.s16
[261610.929] Current version of pixman: 0.32.4
[261610.930] Before reporting problems, check http://www.scientificlinux.org/maillists
to make sure that you have the latest version.
[261610.930] Markers: (--) probed, (**)from config file, (==) default setting,
(++) from command line , (!!) notice, (ll) informational,
(WW) warning, (EE) error, (NI) not implemented, (??)unknown.
[261610.932] (==) Log file: "/var/log/Xorg.0.log"
[261610.932] (==) Using Config file: "/etc/X11/xorg.conf"
This says you still have a /etc/X11/xorg.conf file.
Quote:
[261610.933] (==) Using system config directory "/usr/share/x11/xorg.conf.d"
[261610.933] (==) ServerLayout "X.org Configured"
[261610.933] (**) :--> Screen "Screen0" (0)
[261610.933] (**) : :-->Monitor "Monitor0"
[261610.933] (**) : :-->Device "Card0"
[261610.933] (**) :--> Input Device "Mouse0"
[261610.933] (**) :--> Input Device "Keyboard0"
[261610.933] (==) Automatically adding devices
[261610.933] (==) Automatically enabling devices
[261610.933] (==) Not automatically adding GPU devices
[261610.933] (WW) The directory "/usr/local/share/fonts/misc/" does not exist
[261610.933] Entry deleted from font path
[261610.933] (WW) The directory "/usr/local/share/fonts/TTF/" does not exist
[261610.933] Entry deleted from font path
[261610.933] (WW) The directory '/usr/local/share/fonts/OTF/" does not exist
Entry deleted from font path
[261610.933] (WW) The directory '/usr/local/share/fonts/Type1/" does not exist
Entry deleted from font path
[261610.933] (WW) The directory '/usr/local/share/fonts/100dpi/" does not exist
Entry deleted from font path
[261610.933] (WW) The directory '/usr/local/share/fonts/75dpi/" does not exist
Entry deleted from font path
[261610.933] (**) FontPath set to:
catalogue:/etc/X11/fontpath.d,
built-ins
[261610.933] (**) ModulePath set to "/usr/lib/xorg/modules"
This says you are still trying to use a 32 bit modules directory. It doesn't exist or is empty. On a 64 bit system they aren't supposed to exist UNLESS you are running a 32 bit X server (you aren't).

The specification ** says it comes from the given configuration file.
Quote:
[261610.933] (WW) Hotplugging is on, devices using drive 'kbd', 'mouse' or 'vmouse' will be disabled.
[261610.933] (WW) Disabling Mouse0
[261610.933] (WW) Disabling Keyboard0
[261610.933] (ll) Loader magic: 0x823020
[261610.933] (ll) Module ABI versions:
[261610.933] X.Org ANSI C Emulation: 0.4
[261610.933] X.Org Video Driver: 15.0
[261610.933] X.Org XInput driver: 20.0
[261610.933] X.Org Server Extension: 8.0
[261610.934] (--) PCI :*(0:0:2:0) 8086:0412:1458:d000 rev6, Mem @ 0xf0000000/4194304, 0xe0000000/26843546, I/O @ 0x0000f000/64$
[261610.934] Initializing built-in extension Generic Event Extension
[261610.935] Initializing built-in extension SHAPE
[261610.935] Initializing built-in extension MIT_SHM
[261610.935] Initializing built-in extension XInputExtension
[261610.936] Initializing built-in extension XTEST
[261610.936] Initializing built-in extension BIG_REQUESTS
[261610.936] Initializing built-in extension SYNC
[261610.937] Initializing built-in extension XKEYBOARD
[261610.937] Initializing built-in extension XC-MISC
[261610.937] Initializing built-in extension SECURITY
[261610.938] Initializing built-in extension XINERAMA
[261610.938] Initializing built-in extension XFIXES
[261610.938] Initializing built-in extension RENDER
[261610.938] Initializing built-in extension RANDR
[261610.939] Initializing built-in extension COMPOSITE
[261610.939] Initializing built-in extension DAMAGE
[261610.939] Initializing built-in extension MIT-SCREEN-SAVER
[261610.940] Initializing built-in extension DOUBLE-BUFFER
[261610.940] Initializing built-in extension RECORD
[261610.940] Initializing built-in extension DPMS
[261610.941] Initializing built-in extension Present
[261610.941] Initializing built-in extension X-Resource
[261610.941] Initializing built-in extension XVideo
[261610.941] Initializing built-in extension Xvideo-MotionCompensation
[261610.942] Initializing built-in extension SELinux
[261610.942] Initializing built-in extension XFree86-VidModeExtension
[261610.942] Initializing built-in extension XFree86-DGA
[261610.943] Initializing built-in extension XFree86-DRI
[261610.943] Initializing built-in extension DRI2
[261610.943] (II) "glx" will be loaded. This was enabled by default and also specified in the config file.
[261610.943] (WW) "xwayland" is not to be loaded by default. Skipping.
[261610.943] (II) LoadModule: "glx"
[261610.943] (WW) Warning, couldn't open module glx
[261610.943] (II) UnloadModule: "glx"
[261610.943] (II) Unloading glx
[261610.943] (EE) Failed to load module "glx" (module does not exist,0)
since the module directory is likely empty this makes sense.
Quote:
[261610.943] (II) LoadModule: "radeon"
[261610.943] (WW) Warning, couldn't open module radeon
[261610.943] (II) UnloadModule "radeon"
[261610.943] (II) Unloading radeon
[261610.943] (EE) Failed to load module "radeon" (module does not exist, 0)
[261610.943] (EE) No drivers available.
[261610.943] (EE)
And that makes sense because you don't have a radeon device.
Quote:
Fatal server error:
[261610.944] (EE) no screens found(EE)
[261610.944] (EE)
Please consult the scientific Linux support
at http://www.scientificlinux.org/maillists
for help.
[261610.945] (EE) Please also check the log file at "/var/log/Xorg.0.log" for additional information.
[261610.943] (EE)
]]]

I couldn't figure out how to solve the problem from the log file .
Hope you can .
Many thanks for your great effort to help
My Xorg.0.log file shows the following:
Code:
[    51.680]
X.Org X Server 1.15.0
Release Date: 2013-12-27
[    51.680] X Protocol Version 11, Revision 0
[    51.680] Build Operating System: sl6 2.6.32-504.el6.x86_64
[    51.680] Current Operating System: Linux herbie.localdomain 2.6.32-504.16.2.el6.x86_64 #1 SMP Tue Apr 21 10:35:19 CDT 2015 x86_64
[    51.681] Kernel command line: ro root=/dev/mapper/vg_herbie-lv_root rd_NO_LUKS LANG=en_US.UTF-8 rd_LVM_LV=vg_herbie/lv_root rd_NO_MD SYSFONT=latarcyrheb-sun16 crashkernel=128M  KEYBOARDTYPE=pc KEYTABLE=us rd_NO_DM rd_LVM_LV=vg_herbie/lv_swap rhgb quiet
[    51.681] Build Date: 09 April 2015  11:06:31PM
[    51.681] Build ID: xorg-x11-server 1.15.0-26.sl6
[    51.681] Current version of pixman: 0.32.4
[    51.681]    Before reporting problems, check http://www.scientificlinux.org/maillists
        to make sure that you have the latest version.
[    51.681] Markers: (--) probed, (**) from config file, (==) default setting,
        (++) from command line, (!!) notice, (II) informational,
        (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[    51.682] (==) Log file: "/var/log/Xorg.0.log", Time: Tue Apr 28 10:03:38 2015
[    51.683] (==) Using system config directory "/usr/share/X11/xorg.conf.d"
[    51.684] (==) No Layout section.  Using the first Screen section.
[    51.684] (==) No screen section available. Using defaults.
Note: no reference to "Using /etc/X11/xorg.conf". This implies you have a bad file.

Code:
[    51.684] (**) |-->Screen "Default Screen Section" (0)
[    51.684] (**) |   |-->Monitor "<default monitor>"
[    51.684] (==) No monitor specified for screen "Default Screen Section".
This is the built in configuration default.

Skipped a bunch:
Code:
[    51.684] (==) ModulePath set to "/usr/lib64/xorg/modules"
[    51.684] (II) The server relies on HAL to provide the list of input devices.
        If no devices become available, reconfigure HAL or disable AutoAddDevices.
[    51.685] (II) Loader magic: 0x823020
[    51.685] (II) Module ABI versions:
[    51.685]    X.Org ANSI C Emulation: 0.4
[    51.685]    X.Org Video Driver: 15.0
[    51.685]    X.Org XInput driver : 20.0
[    51.685]    X.Org Server Extension : 8.0
[    51.689] (--) PCI:*(0:0:2:0) 1234:1111:1af4:1100 rev 0, Mem @ 0xfd000000/16777216, 0xfebd4000/4096, BIOS @ 0x????????/65536
Note the default module path for 64 bit systems is /usr/lib64/xorg/modules, not /usr/lib/xorg/modules. /usr/lib is only for 32 bit binaries.

Skipping some more.
[code]
[ 51.690] (II) LoadModule: "glx"
[ 51.692] (II) Loading /usr/lib64/xorg/modules/extensions/libglx.so
[ 51.702] (II) Module glx: vendor="X.Org Foundation"
[ 51.702] compiled for 1.15.0, module version = 1.0.0
[ 51.702] ABI class: X.Org Server Extension, version 8.0
[ 51.702] (==) AIGLX enabled
[ 51.702] Loading extension GLX
[ 51.702] (==) Matched modesetting as autoconfigured driver 0
[ 51.702] (==) Matched fbdev as autoconfigured driver 1
[ 51.702] (==) Matched vesa as autoconfigured driver 2
[ 51.702] (==) Assigned the driver to the xf86ConfigLayout

Note again the reference to /usr/lib64/xorg/modules/extensions/libglx.so for the module.

Also note that the driver identified is for fbdev and vesa.
Code:
[    51.702] (II) LoadModule: "modesetting"
[    51.702] (II) Loading /usr/lib64/xorg/modules/drivers/modesetting_drv.so
[    51.703] (II) Module modesetting: vendor="X.Org Foundation"
[    51.703]    compiled for 1.15.0, module version = 0.8.0
[    51.703]    Module class: X.Org Video Driver
[    51.703]    ABI class: X.Org Video Driver, version 15.0
[    51.703] (II) LoadModule: "fbdev"
[    51.704] (II) Loading /usr/lib64/xorg/modules/drivers/fbdev_drv.so
[    51.704] (II) Module fbdev: vendor="X.Org Foundation"
[    51.704]    compiled for 1.15.0, module version = 0.4.3
[    51.704]    Module class: X.Org Video Driver
[    51.704]    ABI class: X.Org Video Driver, version 15.0
[    51.704] (II) LoadModule: "vesa"
[    51.705] (II) Loading /usr/lib64/xorg/modules/drivers/vesa_drv.so
[    51.705] (II) Module vesa: vendor="X.Org Foundation"
[    51.705]    compiled for 1.15.0, module version = 2.3.2
[    51.705] (II) Module vesa: vendor="X.Org Foundation"
[    51.705]    compiled for 1.15.0, module version = 2.3.2
[    51.705]    Module class: X.Org Video Driver
[    51.705]    ABI class: X.Org Video Driver, version 15.0
[    51.705] (II) modesetting: Driver for Modesetting Kernel Drivers: kms
[    51.705] (II) FBDEV: driver for framebuffer: fbdev
[    51.705] (II) VESA: driver for VESA chipsets: vesa
[    51.706] (++) using VT number 1
We now have a working driver
Code:
[    51.713] (EE) open /dev/dri/card0: No such file or directory
[    51.713] (WW) Falling back to old probe method for modesetting
[    51.713] (EE) open /dev/dri/card0: No such file or directory
[    51.713] (II) Loading sub module "fbdevhw"
[    51.713] (II) LoadModule: "fbdevhw"
[    51.714] (II) Loading /usr/lib64/xorg/modules/libfbdevhw.so
[    51.715] (II) Module fbdevhw: vendor="X.Org Foundation"
[    51.715] (II) Loading /usr/lib64/xorg/modules/libfbdevhw.so
[    51.715] (II) Module fbdevhw: vendor="X.Org Foundation"
[    51.715]    compiled for 1.15.0, module version = 0.0.2
[    51.715]    ABI class: X.Org Video Driver, version 15.0
[    51.743] (EE) open /dev/fb0: No such device
[    51.743] (EE) Screen 0 deleted because of no matching config section.
[    51.743] (II) UnloadModule: "modesetting"
[    51.743] (EE) Screen 0 deleted because of no matching config section.
[    51.743] (II) UnloadModule: "fbdev"
so the fbdev module wasn't appropriate.
Code:
[    51.743] (II) Loading sub module "vbe"
[    51.743] (II) LoadModule: "vbe"
[    51.743] (II) Loading /usr/lib64/xorg/modules/libvbe.so
[    51.744] (II) Module vbe: vendor="X.Org Foundation"
[    51.744]    compiled for 1.15.0, module version = 1.1.0
[    51.744]    ABI class: X.Org Video Driver, version 15.0
[    51.744] (II) Loading sub module "int10"
[    51.744] (II) LoadModule: "int10"
[    51.744] (II) Loading /usr/lib64/xorg/modules/libint10.so
[    51.745] (II) Module int10: vendor="X.Org Foundation"
[    51.745]    compiled for 1.15.0, module version = 1.0.0
[    51.745]    ABI class: X.Org Video Driver, version 15.0
[    51.745] (II) VESA(0): initializing int10
[    51.746] (II) VESA(0): Primary V_BIOS segment is: 0xc000
[    51.747] (II) VESA(0): VESA BIOS detected
[    51.747] (II) VESA(0): VESA VBE Version 3.0
[    51.747] (II) VESA(0): VESA VBE Total Mem: 16384 kB
[    51.747] (II) VESA(0): VESA VBE OEM: SeaBIOS VBE(C) 2011
[    51.747] (II) VESA(0): VESA VBE OEM Software Rev: 0.0
[    51.747] (II) VESA(0): VESA VBE OEM Vendor: SeaBIOS Developers
[    51.747] (II) VESA(0): VESA VBE OEM Product: SeaBIOS VBE Adapter
[    51.747] (II) VESA(0): VESA VBE OEM Product Rev: Rev. 1
[    51.771] (II) VESA(0): Creating default Display subsection in Screen section
        "Default Screen Section" for depth/fbbpp 24/32
[    51.771] (==) VESA(0): Depth 24, (--) framebuffer bpp 32
[    51.771] (==) VESA(0): RGB weight 888
[    51.771] (==) VESA(0): Default visual is TrueColor
So instead it is using the VESA module.

Now yours might be different here as you have a real VGA device - mine is emulated and isn't made by Intel.

Most of what follows this is a list of video modes, and ones not used, along with what was selected (it is a long list).

But this should show you some of the differences between a working startup (with no xorg.conf file) and yours.

You really appear to have a bogus /etc/X11/xorg.conf file.
 
Old 05-04-2015, 04:45 AM   #45
esraam
Member
 
Registered: Apr 2015
Posts: 110

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by pan64 View Post
unfortunately I'm not really familiar with scientific linux, but probably:
yum grouplist will print list the group of packages, you need to find the x, xorg related group (yum grouplist | grep -i xorg)
If Ctrl-Alt-F1 (or similar) does not work you need to reset your linux (or switch off/on)
I can't thank you enough for your effort
i installed all xorg packages and the gui started .
but when I pressed ctrl+alt+f2 .. it switched to the terminal mode and
on trying
#startx :
it gave the following error :
-XSERVERTransSocketUNIXCreatedListener: .... SocketCreatedListener() failed
_XSERVTransMakeAllCOTSServerListeners : server already running
(EE)
Fatal Server error:
(EE) Cannot establish any listening sockets - Make sure an X server isn't already running (EE)

What do you think ?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
trouble shooting tomact server hirdesh Linux - Server 9 04-24-2012 08:06 AM
Trouble shooting grub hari85 Linux - Newbie 4 07-22-2010 03:22 AM
Shooting Trouble with Knoppix frankbell Linux - Hardware 2 06-21-2010 04:44 PM
Recommend a trouble shooting book newbe45 Linux - General 4 01-31-2008 12:36 PM
Rhce trouble shooting binumvk Linux - Certification 3 06-23-2004 01:51 PM


All times are GMT -5. The time now is 06:42 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration