LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Closed Thread
  Search this Thread
Old 06-01-2013, 06:17 PM   #16
suicidaleggroll
LQ Guru
 
Registered: Nov 2010
Location: Colorado
Distribution: OpenSUSE, CentOS
Posts: 5,258

Rep: Reputation: 1947Reputation: 1947Reputation: 1947Reputation: 1947Reputation: 1947Reputation: 1947Reputation: 1947Reputation: 1947Reputation: 1947Reputation: 1947Reputation: 1947

Quote:
Originally Posted by fearthepenguin View Post
the name is zeldatp.iso and it's on my desktop
Don't tell us, tell mount...

Code:
mount -o loop ~/Desktop/zeldatp.iso /mnt
 
Old 06-01-2013, 06:22 PM   #17
fearthepenguin
LQ Newbie
 
Registered: Jun 2013
Posts: 15

Original Poster
Rep: Reputation: Disabled
ok suicidaleggroll, when i try that i get "mount: only root can do that" even though i am root user. ugh. i use "su" command to log in as root through terminal and i get "/root/Desktop/zeldatp.iso: No such file or directory"

EDIT: when i attempt to log in as root from login screen by typing "root" instead of my username, i then type my password and it says "System Administrator is not allowed to log in from this screen" otherwise i'm pretty sure my username is root user though i was the first user name

Last edited by fearthepenguin; 06-01-2013 at 06:26 PM.
 
Old 06-01-2013, 06:31 PM   #18
suicidaleggroll
LQ Guru
 
Registered: Nov 2010
Location: Colorado
Distribution: OpenSUSE, CentOS
Posts: 5,258

Rep: Reputation: 1947Reputation: 1947Reputation: 1947Reputation: 1947Reputation: 1947Reputation: 1947Reputation: 1947Reputation: 1947Reputation: 1947Reputation: 1947Reputation: 1947
Quote:
Originally Posted by fearthepenguin View Post
ok suicidaleggroll, when i try that i get "mount: only root can do that" even though i am root user.
Apparently you're not. What distro are you using?


Quote:
Originally Posted by fearthepenguin View Post
i use "su" command to log in as root through terminal and i get "/root/Desktop/zeldatp.iso: No such file or directory"
Now you're root. In the command I gave "~" is a shortcut to the current user's home directory. Now that you're root, "~/Desktop" is pointing to root's desktop, but that's not where the file lives.

Open a terminal, and type "pwd". That's where your home is. Now cd to Desktop and run "pwd" again, that's your desktop. If you run "ls" you should see your iso file. Now su to root and run "pwd" again. Notice you've changed directories, you're now in root's home. If you cd to Desktop, you'll be sitting in root's desktop, which is not where your file is. Just give mount the full path to the iso file, it's probably "/home/user/Desktop/zeldatp.iso", replacing "user" with whatever your username is (the one who's desktop the file is on).


Quote:
Originally Posted by fearthepenguin View Post
EDIT: when i attempt to log in as root from login screen by typing "root" instead of my username, i then type my password and it says "System Administrator is not allowed to log in from this screen"
That's good, you should never log into the DE as root. It's an incredible security risk. I'm glad to see that more and more distros are blocking people from doing it.

Quote:
Originally Posted by fearthepenguin View Post
otherwise i'm pretty sure my username is root user though i was the first user name
What? "root" is a user, a special user that exists on all Linux systems and has the power of god. The first user that is created during installation is no more special than any other user that is created, it is not root. Only root is root. If you open a terminal and type "whoami", it will tell you your user name. If this does not say "root", then you're not root.

Last edited by suicidaleggroll; 06-01-2013 at 06:36 PM.
 
Old 06-01-2013, 06:35 PM   #19
bigrigdriver
LQ Addict
 
Registered: Jul 2002
Location: East Centra Illinois, USA
Distribution: Debian Jessie 8.4
Posts: 5,873

Rep: Reputation: 348Reputation: 348Reputation: 348Reputation: 348
Instructions from a download site:
Quote:
NOTE: Download this ISO and use a compatible emulator to play. New? Read our tutorial!
Recommended emulator: Dolphin (Windows) | Dolphin (Mac)
You need to extract this ISO using: 7-Zip (Windows) | The Unarchiver (Mac)
So, this is not a Linux .iso. It is intented for windows or mac users to use the emulator at indicated in the instructions, or to open the archive with the win or mac archive tool listed.
 
Old 06-01-2013, 06:41 PM   #20
fearthepenguin
LQ Newbie
 
Registered: Jun 2013
Posts: 15

Original Poster
Rep: Reputation: Disabled
bigrigdriver, im not intending to use an emulator, i just merely wish to see the contents. no im not using a usb loader, i wouldnt know how.
 
Old 06-01-2013, 06:45 PM   #21
fearthepenguin
LQ Newbie
 
Registered: Jun 2013
Posts: 15

Original Poster
Rep: Reputation: Disabled
suicidaleggroll, i put in terminal "mount -o loop ~/home/owen/Desktop/zeldatp.iso /mnt" and my result was "/root/home/owen/Desktop/zeldatp.iso: No such file or directory" though i must admit, you've been the most help thus far
 
Old 06-01-2013, 06:48 PM   #22
suicidaleggroll
LQ Guru
 
Registered: Nov 2010
Location: Colorado
Distribution: OpenSUSE, CentOS
Posts: 5,258

Rep: Reputation: 1947Reputation: 1947Reputation: 1947Reputation: 1947Reputation: 1947Reputation: 1947Reputation: 1947Reputation: 1947Reputation: 1947Reputation: 1947Reputation: 1947
Quote:
Originally Posted by fearthepenguin View Post
suicidaleggroll, i put in terminal "mount -o loop ~/home/owen/Desktop/zeldatp.iso /mnt" and my result was "/root/home/owen/Desktop/zeldatp.iso: No such file or directory" though i must admit, you've been the most help thus far
Close, but get rid of the "~". "~" is a shortcut to the current user's home directory. If you're currently logged in as owen, then "~" is a shortcut for "/home/owen". If, however, you're currently logged in as root (which you are), then "~" is a shortcut for "/root". This is why when you put "~/home/owen/Desktop/zeldatp.iso" it came back with "/root/home/owen/Desktop/zeldatp.iso". Since the file does not live in /root, then leave off ~. Everything else you have is fine.
 
Old 06-01-2013, 06:50 PM   #23
bigrigdriver
LQ Addict
 
Registered: Jul 2002
Location: East Centra Illinois, USA
Distribution: Debian Jessie 8.4
Posts: 5,873

Rep: Reputation: 348Reputation: 348Reputation: 348Reputation: 348
The tilde ~ represents the users home directory. If logged in as normal users that's /home/<username>; if logged in as root it's /root.

Login as root and cd (change directory) to the folder you downloaded the .iso into, then run the mount command.

cd /home/<username>/<download folder>
then run mount.

Last edited by bigrigdriver; 06-01-2013 at 06:52 PM.
 
Old 06-01-2013, 06:53 PM   #24
suicidaleggroll
LQ Guru
 
Registered: Nov 2010
Location: Colorado
Distribution: OpenSUSE, CentOS
Posts: 5,258

Rep: Reputation: 1947Reputation: 1947Reputation: 1947Reputation: 1947Reputation: 1947Reputation: 1947Reputation: 1947Reputation: 1947Reputation: 1947Reputation: 1947Reputation: 1947
This might be of some use, namely "Tutorial One"

http://www.ee.surrey.ac.uk/Teaching/Unix/
 
Old 06-01-2013, 07:18 PM   #25
fearthepenguin
LQ Newbie
 
Registered: Jun 2013
Posts: 15

Original Poster
Rep: Reputation: Disabled
not understanding how tutorial one could be helpful but whatever. here's what i typed this time

"mount -t iso9660 -o loop /home/owen/Desktop/zeldatp.iso /mnt"

and as usual an error as result

"mount: wrong fs type, bad option, bad superblock on /dev/loop0,
missing codepage or helper program, or other error
In some cases useful info is found in syslog - try
dmesg | tail or so"
 
Old 06-01-2013, 07:23 PM   #26
suicidaleggroll
LQ Guru
 
Registered: Nov 2010
Location: Colorado
Distribution: OpenSUSE, CentOS
Posts: 5,258

Rep: Reputation: 1947Reputation: 1947Reputation: 1947Reputation: 1947Reputation: 1947Reputation: 1947Reputation: 1947Reputation: 1947Reputation: 1947Reputation: 1947Reputation: 1947
Did you try without the "-t iso9660" option?
 
Old 06-01-2013, 07:27 PM   #27
fearthepenguin
LQ Newbie
 
Registered: Jun 2013
Posts: 15

Original Poster
Rep: Reputation: Disabled
without "-t iso9660", i get "mount: you must specify the filesystem type"
 
Old 06-01-2013, 07:31 PM   #28
suicidaleggroll
LQ Guru
 
Registered: Nov 2010
Location: Colorado
Distribution: OpenSUSE, CentOS
Posts: 5,258

Rep: Reputation: 1947Reputation: 1947Reputation: 1947Reputation: 1947Reputation: 1947Reputation: 1947Reputation: 1947Reputation: 1947Reputation: 1947Reputation: 1947Reputation: 1947
Could be a bad iso file, or just one that doesn't have a normal layout so mount doesn't know how to interpret it.
 
Old 06-01-2013, 08:27 PM   #29
273
LQ Addict
 
Registered: Dec 2011
Location: UK
Distribution: Debian Sid AMD64, Raspbian Wheezy, various VMs
Posts: 6,011

Rep: Reputation: 1621Reputation: 1621Reputation: 1621Reputation: 1621Reputation: 1621Reputation: 1621Reputation: 1621Reputation: 1621Reputation: 1621Reputation: 1621Reputation: 1621
Ahem...
Quote:
Originally Posted by 273 View Post
Since archive manager can't open the file I think it's worth asking whether you have verified that this file is not corrupt in some way?
 
Old 06-01-2013, 10:01 PM   #30
mandyapenguin
Member
 
Registered: Nov 2011
Location: India
Distribution: RedHat, Cent OS, Fedora, Debian, Ubuntu
Posts: 106

Rep: Reputation: Disabled
Quote:
Originally Posted by fearthepenguin View Post
the name is zeldatp.iso and it's on my desktop
Then try these below
Code:
whoami
Make sure you are the same user, in which user's Desktop directory your file exist and then run
Code:
cd ~/Desktop
If "whoami" command shows any other user, instead of the user where your file is kept, then first login to that user using
Code:
su that_username
cd ~/Desktop
make sure whether your file is exist.
Code:
ls -l zeldatp.iso
if exist, then mount
Code:
sudo mount -o loop zeldatp.iso /mnt
or if you already login as root
Code:
mount -o loop zeldatp.iso /mnt
ls /mnt
Or first you search for that file to make sure the path.
Code:
find /root/ /home -type f -name "zeldatp.iso"
Note down the file's full path and then mount it.
Code:
sudo mount -o loop /full/path/of/zeldatp.iso /mnt
or
mount -o loop /full/path/of/zeldatp.iso /mnt

ls /mnt
You can use the below command to become root user
Code:
sudo su
You can run the above commad only if you are allowed for sudo. Here you have to provide your password instead of root to become root. If you have already set root password, then you can also run "su" command to become root
Code:
su
provide the root user's password

Please post the output of below command, from this below command you can make sure that what type of file it is.
Code:
find /root /home -type f -name "zeldatp.iso" -exec file {} \;
If it is really an ISO file and if you are not sure whether that file is in root user's desktop or normal user's desktop then you can try this single command which will search for your file in both(/root & /home) directories, mount it and list it's contents,
Code:
find /root /home -type f -name "zeldatp.iso" -exec mount -o loop {} /mnt \; && ls -l /mnt/

or

find /root /home -type f -name "zeldatp.iso" -exec mount -o loop -t iso9660 {} /mnt \; && ls -l /mnt/

Last edited by mandyapenguin; 06-01-2013 at 10:23 PM.
 
  


Closed Thread


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] trouble opening terminal glenellynboy Linux - Newbie 14 09-19-2011 05:38 PM
Trouble in opening file fron read only disk kaushikakali Linux - Newbie 6 07-21-2008 07:17 PM
k3b-trouble locating iso file to copy from hdc to hdd handydan Linux - Software 1 02-25-2007 01:11 PM
Opening NRG, BIN and ISO files herve2001 Slackware 5 12-03-2005 02:03 AM
Trouble opening index.php file to install eZ publish jedson Linux - Software 2 11-01-2004 08:22 AM


All times are GMT -5. The time now is 04:28 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration