LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 09-20-2014, 05:55 PM   #91
JeremyBoden
Senior Member
 
Registered: Nov 2011
Distribution: Debian
Posts: 1,025

Rep: Reputation: 203Reputation: 203Reputation: 203

Is this external drive connected via a USB interface or connected via external a SATA cable?

Personally, I've never succeeded in getting an external drive that uses a USB interface to boot.
 
Old 09-20-2014, 07:17 PM   #92
EDDY1
LQ Addict
 
Registered: Mar 2010
Location: Oakland,Ca
Distribution: wins7, Debian wheezy
Posts: 6,838

Rep: Reputation: 649Reputation: 649Reputation: 649Reputation: 649Reputation: 649Reputation: 649
My external drive used to be an internal laptop drive that I put in an enlosure. I actually had 2, but dropped 1 of them. Both had os on them originally with all drivers installed, but the 1 I presently use was an upgrade from wheezy to jessie with gnome & a lot of gtk errors so I reinstalled os with xfce but this time while it was in the enclosure & it works fine on anything except mac & uefi machines. In bios it's listed as a hdd (initio)

The main difference with having mine on external is that instead of mounting a system with broken grub is that I can run update-grub & it will be added to my grub allowing me to boot directly into the broken os, unmount & remove usb, install grub.

Last edited by EDDY1; 09-20-2014 at 07:18 PM.
 
Old 09-21-2014, 08:00 AM   #93
beenlord
Member
 
Registered: Jul 2014
Distribution: mint
Posts: 81

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by EDDY1 View Post
My external drive used to be an internal laptop drive that I put in an enlosure. I actually had 2, but dropped 1 of them. Both had os on them originally with all drivers installed, but the 1 I presently use was an upgrade from wheezy to jessie with gnome & a lot of gtk errors so I reinstalled os with xfce but this time while it was in the enclosure & it works fine on anything except mac & uefi machines. In bios it's listed as a hdd (initio)

The main difference with having mine on external is that instead of mounting a system with broken grub is that I can run update-grub & it will be added to my grub allowing me to boot directly into the broken os, unmount & remove usb, install grub.
so i mount my external drive and run update grub? and that should allow me to boot into it from the usb somehow?
 
Old 09-21-2014, 11:00 AM   #94
EDDY1
LQ Addict
 
Registered: Mar 2010
Location: Oakland,Ca
Distribution: wins7, Debian wheezy
Posts: 6,838

Rep: Reputation: 649Reputation: 649Reputation: 649Reputation: 649Reputation: 649Reputation: 649
You would have to already have grub on usb.
 
Old 09-21-2014, 11:08 AM   #95
beenlord
Member
 
Registered: Jul 2014
Distribution: mint
Posts: 81

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by EDDY1 View Post
You would have to already have grub on usb.
ok, so how do i boot into my external drive?

Last edited by beenlord; 09-21-2014 at 11:22 AM.
 
Old 09-21-2014, 01:33 PM   #96
yancek
LQ Guru
 
Registered: Apr 2008
Distribution: PCLinux, Slackware
Posts: 6,983

Rep: Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295
You have an internal hard drive with windows on it. You have a 500GB external drive with Mint on it (or at least you did originally). You did not have your windows drive attached when you installed Mint. The external drive would ordinarily have been the second drive and referred to as sdb. If you go back to post #17 and your output of grub.cfg you will see that the entry for Mint on the second drive/first partition is set root=(hd0,msdos1) which is the equivalent of sda1, not sda2. In later posts, your Mint shows as being on sda1.

A more accurate way to get information is to leave the windows drive attached, have the Mint external drive attached and then boot from Mint or whicever OS you are now trying to use and run: sudo fdisk -l This will show information on all drives and if they are different sizes it should be easier to determine which shows as sda/sdb, etc. The normal method of installing Grub to the mbr of the second drive on Ubuntu/Mint is: sudo grub-install /dev/sdb

Your normal.mod error is a little odd if you actually have the file in i386-pc directory.
 
Old 09-21-2014, 01:37 PM   #97
yancek
LQ Guru
 
Registered: Apr 2008
Distribution: PCLinux, Slackware
Posts: 6,983

Rep: Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295
You have an internal hard drive with windows on it. You have a 500GB external drive with Mint on it (or at least you did originally). You did not have your windows drive attached when you installed Mint. The external drive would ordinarily have been the second drive and referred to as sdb. If you go back to post #17 and your output of grub.cfg you will see that the entry for Mint on the second drive/first partition is set root=(hd0,msdos1) which is the equivalent of sda1, not sda2. In later posts, your Mint shows as being on sda1.

A more accurate way to get information is to leave the windows drive attached, have the Mint external drive attached and then boot from Mint or whicever OS you are now trying to use and run: sudo fdisk -l This will show information on all drives and if they are different sizes it should be easier to determine which shows as sda/sdb, etc. The normal method of installing Grub to the mbr of the second drive on Ubuntu/Mint is: sudo grub-install /dev/sdb

Your normal.mod error is a little odd if you actually have the file in i386-pc directory.

Your boot-repair info from your last post now shows Grub installed in the mbr of both your windows drive and the Linux external drive. It shows Mint on sda1 and windows on sdc1. The entry in that grub.cfg now points to Mint on sda1 which is how it is seen. There is no entry for windows so what exactly can you boot now?
 
Old 09-21-2014, 02:26 PM   #98
beenlord
Member
 
Registered: Jul 2014
Distribution: mint
Posts: 81

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by yancek View Post
You have an internal hard drive with windows on it. You have a 500GB external drive with Mint on it (or at least you did originally). You did not have your windows drive attached when you installed Mint. The external drive would ordinarily have been the second drive and referred to as sdb. If you go back to post #17 and your output of grub.cfg you will see that the entry for Mint on the second drive/first partition is set root=(hd0,msdos1) which is the equivalent of sda1, not sda2. In later posts, your Mint shows as being on sda1.

A more accurate way to get information is to leave the windows drive attached, have the Mint external drive attached and then boot from Mint or whicever OS you are now trying to use and run: sudo fdisk -l This will show information on all drives and if they are different sizes it should be easier to determine which shows as sda/sdb, etc. The normal method of installing Grub to the mbr of the second drive on Ubuntu/Mint is: sudo grub-install /dev/sdb

Your normal.mod error is a little odd if you actually have the file in i386-pc directory.

Your boot-repair info from your last post now shows Grub installed in the mbr of both your windows drive and the Linux external drive. It shows Mint on sda1 and windows on sdc1. The entry in that grub.cfg now points to Mint on sda1 which is how it is seen. There is no entry for windows so what exactly can you boot now?
well like i said i detatched the data cables for my internal drives out of fear of accidentally overwriting them while trying to fix linux, at the moment i can only boot into a usb liveboot of mint 17 that i have plugged in to a usb port in the back of my pc, my bios has the drive order of the usb first and the external usb drive second. whenever i set it to boot from the external drive it gives me the error
 
Old 09-21-2014, 03:39 PM   #99
fatmac
Senior Member
 
Registered: Sep 2011
Location: Surrey/Hants Border, UK
Distribution: BSD & Linux - As long as they are Lightweight
Posts: 1,704

Rep: Reputation: Disabled
Every time you change the drives around you are reordering their designations.
(Likely this is why there is confusion.)

Put your Windows drive back into the machine, that should/will be /dev/sda, put your live pendrive in, that should/will be /dev/sdb, finally attach your usb drive, that should/will be /dev/sdc.

Before doing anything else, check that those are how they are designated. (run 'dmesg | less' in a terminal)

Once the drives designations have been confirmed, 'we' can assist you.
 
Old 09-21-2014, 03:58 PM   #100
yancek
LQ Guru
 
Registered: Apr 2008
Distribution: PCLinux, Slackware
Posts: 6,983

Rep: Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295
Quote:
well like i said i detatched the data cables for my internal drives out of fear of accidentally overwriting them while trying to fix linux
That is something that peeple commonly do. Of course in that situation, you will obviously not be able to boot windows on that drive from Grub installed on the other drive as the grub installation would have no way of knowing there was any other operating system installed on a drive that was not attached. You would have to run update-grub after attaching the windows drive. That doesn't do anything to explain why you have the normal.mod error, or at least why you had it when you initially posted.

Do you also get the same error when you set the BIOS to boot from the first/ internal drive?

Last edited by yancek; 09-21-2014 at 04:01 PM.
 
Old 09-21-2014, 04:00 PM   #101
beenlord
Member
 
Registered: Jul 2014
Distribution: mint
Posts: 81

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by fatmac View Post
Every time you change the drives around you are reordering their designations.
(Likely this is why there is confusion.)

Put your Windows drive back into the machine, that should/will be /dev/sda, put your live pendrive in, that should/will be /dev/sdb, finally attach your usb drive, that should/will be /dev/sdc.

Before doing anything else, check that those are how they are designated. (run 'dmesg | less' in a terminal)

Once the drives designations have been confirmed, 'we' can assist you.
ok i'll try it in a bit
 
Old 09-21-2014, 04:21 PM   #102
beenlord
Member
 
Registered: Jul 2014
Distribution: mint
Posts: 81

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by yancek View Post
Do you also get the same error when you set the BIOS to boot from the first/ internal drive?
from my windows drives? no those work fine, if i recall grub is disk specific and installed onto the first few kb's of a hard disk.
 
Old 09-21-2014, 05:22 PM   #103
JeremyBoden
Senior Member
 
Registered: Nov 2011
Distribution: Debian
Posts: 1,025

Rep: Reputation: 203Reputation: 203Reputation: 203
Once you get things sorted out, you can use UUID's to make sure you are addressing the right partition on the right disk.
A UUID doesn't change if you connect a disk to a different port or even if you disconnect other disks.

But you must have GRUB installed on the disk you are booting from.
 
Old 09-22-2014, 02:30 PM   #104
beenlord
Member
 
Registered: Jul 2014
Distribution: mint
Posts: 81

Original Poster
Rep: Reputation: Disabled
well i typed in dmesg | less and a bunch of text showed up, too much to copy and past, so what should i do? D:
 
Old 09-22-2014, 03:03 PM   #105
JeremyBoden
Senior Member
 
Registered: Nov 2011
Distribution: Debian
Posts: 1,025

Rep: Reputation: 203Reputation: 203Reputation: 203
It was only one screenful of text - but could you try an alternative - with both disks + the live USB plugged in?
Code:
inxi -D
Purely as an example I get (for my two internal SATA drives):-
Code:
Drives:    HDD Total Size: 1250.3GB (30.5% used) 1: id: /dev/sda model: ST1000DM003 size: 1000.2GB 
           2: id: /dev/sdb model: SAMSUNG_SP2504C size: 250.1GB
Note that I boot from /dev/sda which also holds my GRUB configuration.

Because you have to boot from a live USB stick (could you confirm this?) - I would expect yours to appear somewhat differently.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Trouble Formatting Hard Drive in Linux Mint (Trying to Install Another OS) JayReed Linux - Newbie 13 01-21-2014 03:12 PM
Maxtor One Touch 4 USB 500GB External HDD Not showing up in Linux Mint Elyssa nonexist Linux - Hardware 6 12-24-2008 08:58 AM
Freecom 500GB External Hard Drive not visible gilbertt Linux - Hardware 3 11-13-2008 09:02 PM
Installing linux to an external hard drive. xxterrorxx Linux - Newbie 1 08-04-2008 01:51 AM
Linux won't recognize new 500GB Seagate second hard drive Grexsnip Linux - Hardware 6 07-05-2007 11:23 PM


All times are GMT -5. The time now is 10:21 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration