LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices



Reply
 
Search this Thread
Old 12-16-2008, 11:56 PM   #1
kim,jw
LQ Newbie
 
Registered: Dec 2008
Posts: 8

Rep: Reputation: 0
Post Trouble in installing Perl module GD-2.41


Now I was trying to install Perl module GD, version 2.41,
but failed with error message requiring libgd 2.0.28 or higher.

So I downloaded gd-2.0.35 and did './configure' under gd-2.0.35 dir.,
but also failed, and I found the following from REAME in GD-2.41 directory :

---------------------------------------------------
=> IMPORTANT: This version of GD REQUIRES libgd 2.0.28 or higher. If you <=
=> have an older version of libgd installed you must remove libgd.a, <=
=> libgd.so (if present) and gd.h. Then install the new version of <=
=> libgd from www.boutell.com (see below). This particularly <=
=> applies to users of Linux systems. Older versions of GD are <=
=> available at http://www.cpan.org. <=
-----------------------------------------------------


Then, searching whether those files were in my system,
I got the result :

-----------------------------------------------------
[root@gac ex]# find / -name "libgd.so*"
/usr/lib64/libgd.so.2
/usr/lib64/libgd.so
/usr/lib64/libgd.so.2.0.0
/usr/lib/libgd.so.2
/usr/lib/libgd.so.2.0.0

[root@gac ex]# find / -name "libgd*.so*"
/usr/lib64/libgdk-1.2.so.0.9.1
/usr/lib64/libgdk_pixbuf_xlib.so.2.0.0
/usr/lib64/libgdk-x11-2.0.so
/usr/lib64/libgdk_pixbuf-2.0.so
/usr/lib64/libgdbm.so.2
/usr/lib64/libgdk_pixbuf-2.0.so.0
/usr/lib64/libgdk_pixbuf_xlib-2.0.so
/usr/lib64/libgdk_pixbuf_xlib.so.2
/usr/lib64/libgdk_pixbuf-2.0.so.0.400.13
/usr/lib64/libgdk_pixbuf.so.2
/usr/lib64/libgd.so.2
(and other files, 44 ones were listed here in total)

[root@gac ex]# find / -name "libgd*.*a*"
/usr/lib64/libgdk.la
/usr/lib64/libgdk.a
/usr/lib64/libgd.a
/opt/rocks/lib/graphviz/libgdtclft.la
/opt/rocks/lib/graphviz/libgdtclft.a

[root@gac ex]# find / -name "gd.h"
/export/home/edu2000/fpc/fpc/w/wgd/gd.h
/usr/include/gd.h
/opt/rocks/include/graphviz/gd.h
-----------------------------------------------------

Here, which files should I remove to install successfully?
Because I suspect some of those might be set up when I did './configure'
in the gd-2.0.25 directory, and others might had been there for programs
that I do not know, which means I should not get rid of them.

For example,
/usr/lib64/libgd.so.2
/usr/lib64/libgd.so
/usr/lib64/libgd.so.2.0.0
Are these totally different, just differ in version, or in something else?
Otherwise, without any concern about files of similar names
just I could remove the three all as well as "/usr/lib64/libgd.a",
and install "gd-2.0.35" again?
(that is, with the files left there :
/usr/lib64/libgdk-1.2.so.0.9.1, /usr/lib64/libgdk_pixbuf_xlib.so.2.0.0,
/usr/lib64/libgdk-x11-2.0.so, and so many. )

Can I do as the same for the three "gd.h" without breaking their roles
in other programs? (No problem if gd.h would be set up in higher version?)

Any comment or tips will be very appreciated.
 
Old 12-17-2008, 08:55 AM   #2
TB0ne
Guru
 
Registered: Jul 2003
Location: Birmingham, Alabama
Distribution: SuSE, RedHat, Slack,CentOS
Posts: 15,107

Rep: Reputation: 2720Reputation: 2720Reputation: 2720Reputation: 2720Reputation: 2720Reputation: 2720Reputation: 2720Reputation: 2720Reputation: 2720Reputation: 2720Reputation: 2720
Quote:
Originally Posted by kim,jw View Post
Now I was trying to install Perl module GD, version 2.41,
but failed with error message requiring libgd 2.0.28 or higher.

So I downloaded gd-2.0.35 and did './configure' under gd-2.0.35 dir.,
but also failed, and I found the following from REAME in GD-2.41 directory :

---------------------------------------------------
=> IMPORTANT: This version of GD REQUIRES libgd 2.0.28 or higher. If you <=
=> have an older version of libgd installed you must remove libgd.a, <=
=> libgd.so (if present) and gd.h. Then install the new version of <=
=> libgd from www.boutell.com (see below). This particularly <=
=> applies to users of Linux systems. Older versions of GD are <=
=> available at http://www.cpan.org. <=
-----------------------------------------------------

Well, the error message says it all. Your libgd is < 2.0.28. Upgrade it. You don't say what version/distro of Linux you're using, so it's hard to be specific as to how.

Download the latest libgd package from whatever source repository you have set up, and upgrade your libgd, and (probably), your libgd-devel packages.
 
Old 12-18-2008, 03:40 AM   #3
kim,jw
LQ Newbie
 
Registered: Dec 2008
Posts: 8

Original Poster
Rep: Reputation: 0
Thanks a lot for reply!
Saying my system, if it's right to confirm the version at /proc/version,
that is < Linux version 2.6.9-55.0.2.ELsmp (gcc version 3.4.6 20060404 (Red Hat 3.4.6-8)) >.
I have heard -- it's not my own, but with colleagues -- the system is Gentoo Linux,
but I don't know that make sense with the version above. (Sorry, I'm just a newbie.)

Anyway,

>Well, the error message says it all. Your libgd is < 2.0.28. Upgrade it. You don't say what version/distro of Linux you're >using, so it's hard to be specific as to how.

=> Yes, I know the version of my libgd is older, so I downloaded the latest one, ver. 2.0.35,
but I felt I had to remove the older one prior to installing the new one.
(Actually I've installed the new version, but failed of course.)
At that moment, I could not make sure which files I should delete among the many, as listed above,
especially due to the files with simliar names to libgd.a and libgd.so, located at various paths.

It looks like that simply it's right to delete only those files, like libgd.so.2, libgd.so, and libgd.so.2.0.0,
named exactly the same, not those like libgdk.la or libgdk.a, but now I'm just not sure to do.
 
Old 12-18-2008, 09:49 AM   #4
TB0ne
Guru
 
Registered: Jul 2003
Location: Birmingham, Alabama
Distribution: SuSE, RedHat, Slack,CentOS
Posts: 15,107

Rep: Reputation: 2720Reputation: 2720Reputation: 2720Reputation: 2720Reputation: 2720Reputation: 2720Reputation: 2720Reputation: 2720Reputation: 2720Reputation: 2720Reputation: 2720
Quote:
Originally Posted by kim,jw View Post
Thanks a lot for reply!
Saying my system, if it's right to confirm the version at /proc/version,
that is < Linux version 2.6.9-55.0.2.ELsmp (gcc version 3.4.6 20060404 (Red Hat 3.4.6-8)) >.
I have heard -- it's not my own, but with colleagues -- the system is Gentoo Linux,
but I don't know that make sense with the version above. (Sorry, I'm just a newbie.)

Anyway,

>Well, the error message says it all. Your libgd is < 2.0.28. Upgrade it. You don't say what version/distro of Linux you're >using, so it's hard to be specific as to how.

=> Yes, I know the version of my libgd is older, so I downloaded the latest one, ver. 2.0.35,
but I felt I had to remove the older one prior to installing the new one.
(Actually I've installed the new version, but failed of course.)
At that moment, I could not make sure which files I should delete among the many, as listed above,
especially due to the files with simliar names to libgd.a and libgd.so, located at various paths.

It looks like that simply it's right to delete only those files, like libgd.so.2, libgd.so, and libgd.so.2.0.0,
named exactly the same, not those like libgdk.la or libgdk.a, but now I'm just not sure to do.
No, you don't delete any files manually. If you downloaded the newer package, you can do an "rpm --upgrade <package name>", and the system will take care of everything for you. Much safer and cleaner that way.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Installing Perl ZLIB module acidtone Debian 3 05-15-2007 10:40 AM
Installing perl module problem satimis Programming 1 03-28-2006 04:37 PM
installing perl module vickr1z Linux - Newbie 1 09-22-2004 08:12 AM
Problems Installing Perl GD module kaplan71 Linux - Software 0 08-19-2004 03:17 PM
Installing a perl module - howto Rum Linux - Software 1 07-03-2002 05:45 PM


All times are GMT -5. The time now is 12:35 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration