LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 01-05-2006, 02:37 PM   #1
secondvijai007
LQ Newbie
 
Registered: Dec 2005
Posts: 5

Rep: Reputation: 0
Unhappy Trouble getting Wine to work on Debian


Hi! As you have probably guessed, I am very new to Linux (Just over 2 weeks), and I really need some help configuring Wine on my laptop. I really did an extensive search on google, and I could find anything so I'm really stuck and need your help. I have installed wine (I think) already, and after breaking my head in the root terminal, I was able to get it to recognize the command. When I try to install something from a CD using say, wine Setup.exe - I get the following message:
Quote:
fixme:bitmap:SetDIBits shouldn't require a DC for DIB_RGB_COLORS
Application tries to create a window, but no driver could be loaded.
Make sure that your X server is running and that $DISPLAY is set correctly.
I am using kernel 2.6.8-2-386 and running Debian Sarge(3.1). The version of wine im trying to fix i believe is 0.9.3. Any help would be greatly appreciated.

Oh, and by the way I do have X server running (I am assuming because I am using KDE desktop) and also, my $DISPLAY setting is :0.0

Thanks!

Last edited by secondvijai007; 01-05-2006 at 02:53 PM.
 
Old 01-05-2006, 05:01 PM   #2
pljvaldez
LQ Guru
 
Registered: Dec 2005
Location: Somewhere on the String
Distribution: Debian Wheezy (x86)
Posts: 6,094

Rep: Reputation: 271Reputation: 271Reputation: 271
I feel like I saw that error when I was doing something else as root and it turned out that root was trying to use the xserver, but that root's $DISPLAY variable wasn't set up. So I just had to type export $DISPLAY or something like that (I can't seem to find it now...)
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Trouble running wine from src wine:error while loading shared libraries: libwine.so.1 brynjarh Linux - Newbie 2 05-28-2013 11:59 AM
Wine - Diablo II LOD TCP/IP doesn't work +where is my wine.conf brainlesspinkey Linux - Games 7 08-26-2007 09:10 AM
wine trouble jumpman890 Linux - Software 2 02-26-2004 12:00 AM
wine trouble Mr.Mounsey Linux - Software 1 12-01-2003 08:58 PM
Wine trouble darksecant Linux - Software 24 09-01-2003 03:40 PM


All times are GMT -5. The time now is 10:46 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration