LinuxQuestions.org
Latest LQ Deal: Complete CCNA, CCNP & Red Hat Certification Training Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 10-07-2004, 12:16 AM   #1
adam_the_noob
LQ Newbie
 
Registered: Oct 2004
Posts: 2

Rep: Reputation: 0
Trouble getting modem to work in SUSE 9.1


ok after i configure the modem i get this in the error log"

SuSE Meta pppd (smpppd-ifcfg), Version 1.16 on linux.
Status is: disconnected
trying to connect to smpppd
connect to smpppd
Status is: disconnected
Status is: connecting
pppd[0]: Plugin passwordfd.so loaded.
pppd[0]: --> WvDial: Internet dialer version 1.54.0
pppd[0]: --> Initializing modem.
pppd[0]: --> Sending: ATM1
pppd[0]: --> Sending: ATQ0
pppd[0]: --> Re-Sending: ATM1
pppd[0]: --> Modem not responding.
pppd[0]: Connect script failed
Status is: disconnected
pppd[0] died: Connect script failed (exit code 8)

Plz help me
 
Old 10-07-2004, 04:06 AM   #2
jk73
LQ Newbie
 
Registered: Oct 2004
Posts: 3

Rep: Reputation: 0
I was in a similar situation just recently with a winmodem on SuSE 9.1: I got it to work by typing "slmodemd" from a root console, then trying to connect.

I'm new to Linux, so hopefully someone else could provide a better more detailed response to this issue. (Please!)
 
Old 10-07-2004, 06:30 AM   #3
DaneM
Member
 
Registered: Oct 2003
Location: Chico, CA, USA
Distribution: Linux Mint
Posts: 848

Rep: Reputation: 107Reputation: 107
Hello everybody.

I kind-of sounds like the dialer hasn't found the modem at all. I'm not familiar with Suse's modem dialing tool (I use KPPP), but I imagine that somewhere there's an option to "query modem." Try this and hopefully you'll get something like:

ATI: 5601
ATI 1: C084
ATI 2: OK
ATI 3: U.S. Robotics 56K FAX INT V5.22.70
ATI 4: U.S. Robotics 56K FAX INT Settings... B0 E0 F1 L0 M0 Q1 V1 X4 Y0
BAUD=115200 PARITY=N WORDLEN=8 DIAL=TONE ON HOOK CID=0
&A3 &B1 &C1 &D2 &G0 &H1 &I0 &K1 &M4 &N0 &P1 &R2 &S0
&T5 &U0 &Y1 S00=000
ATI 5: U.S. Robotics 56K FAX INT NVRAM Settings... Template Y0 DIAL=TONE
B0 E1 F1 L1 M1 Q0 V1 X4 BAUD=115200 PARITY=N WORDLEN=8
&A3 &B1 &C1 &D2 &G0 &H1 &I0 &K1 &M4 &N0 &P1 &R2 &S0
&T5 &U0 &Y1 S00=000 S02=
ATI 6: Template Y1 DIAL=TONE B0 E1 F1 L1 M1 Q0 V1 X4
BAUD=115200 PARITY=N WORDLEN=8 &A3 &B1 &C1 &D2 &G0
&H2 &I2 &K1 &M4 &N0 &P1 &R1 &S0 &T5 &U0 &Y1 S00=000
S02=043 S03=013 S04=010 S05=008 S06=004 S07=
ATI 7: Configuration Profile... Product type US/Canada Internal Product ID:
00561002 Options V32bis,V.80,V.34+,V.90,V.92 Fax Options
Class 1/Class 2.0 Line Options Caller ID, Distinctive Ring Clo

This is what KPPP displays for my modem. Suse's tool might just say "modem found" or "modem not found." Make sure that the program is pointing to the right COM port. /dev/modem usually works, but it's sometimes nonexistant or improperly linked. Try ttyS0, ttyS1, etc. until you get a good response from your modem. You also might want to try minicom to putz around and make sure that everything looks peachy. Type this in a console:

Code:
su
<password>
minicom
This should pop up a blue box that says "initializing modem" and then give you a command line of sorts. Try typing "ATZ" and then "ATDT 5555555". You might not see everything that you're typing. If my memory serves me well this should cause your modem to dial "555-5555" (an invalid number where I live). If all this goes smoothly then /dev/modem is linked to the right COM port and your modem drivers are working. If not then you can try linking /dev/modem to different serial port (like ttyS1, etc.). Before doing this, WRITE DOWN WHERE IT'S CURRENTLY LINKED TO! To find this out, type "ls -l /dev/modem". To change where it's linked to, type this from the command prompt:

Code:
su
<password>
rm /dev/modem
ln -s /dev/ttyS1 /dev/modem
This will link /dev/modem to /dev/ttyS1. Experiment with different ones if you want.

I hope this helps! I'm no expert, so if anybody else has some suggestions, please chime in!

--Dane
 
Old 10-07-2004, 08:11 PM   #4
adam_the_noob
LQ Newbie
 
Registered: Oct 2004
Posts: 2

Original Poster
Rep: Reputation: 0
didn't work
the command slmodemd didn't work
 
Old 10-08-2004, 05:43 AM   #5
jk73
LQ Newbie
 
Registered: Oct 2004
Posts: 3

Rep: Reputation: 0
Go to the Suse web site & there is a winmodem driver package in the downloads/updates/9.1 section: I think its called: "31 Aug 2004 ltmodem: Driver for modems with lucent chipsets "

Get the rpm, and install it. Go to YaST/System/Run level editor/, probably best to stay in 'simple mode' find slmodem (SmartLink modem driver) in the list and enable it to run at boot time (this effectively loads the driver software you downloaded and installed), then your dialer should initialise the modem and connect to your ISP.

This was the situation for me. Hope this helps!
 
Old 10-21-2004, 09:35 PM   #6
whit_wolf1
LQ Newbie
 
Registered: Sep 2004
Distribution: ubuntu, Centos, Redhat, Vmware ESX, Debian, SLES
Posts: 24

Rep: Reputation: 15
HElp

i tryed the ltmodem and i didnt work or i didnt install right please help
what can i do
 
Old 10-22-2004, 03:48 AM   #7
carrie
Member
 
Registered: Sep 2004
Location: liliput - Guinea
Distribution: RH-3
Posts: 68

Rep: Reputation: 15
Hello,

PREFACE .

linux@user#newbie --help
connecting to linuxquestions.org
linux@user#THANKS!

>>I tryied 2 install the modem for 2.6 kernel; it is not enough with the driver, u need the kernel sources and a gcc compiler, but (the rpm denies to istallīem), it installs automatically with YAST, anyway I tough 2 install it the right way but it just donīt work, but I had a little advance at the buy of Suse pro and let YAST Install the driver itself, and YES it seems 2 use the slmodemd and in fact the device is /dev/ttySL0 -or-
/dev/slmr0 but I donīt know what 2 do now; Idid this:
-------------------------------------------------------------------------------------------------------------
1) wvdial canīt find the devices avobe

2) kppp tests the SL= and seems 2 work the ATI, but at the time 2 connect, justrare bin simbols apear in the log

3)when I try with Kinternet, it sayssomething like this:
>>
Suse Meta pppd (smpppd-ifcfg) version 1.16 on linux
statuss is disconnected
trying t connect 2 smpppd
connect 2 smpppd
status is disconected
status is connecting
status is dissconected
pppd (0) died pppd options error (exit code 2)

4)
linux@user# slmodemd
unable to create device /dev/slmr0
linux@user#

I donīt know what to do (who will save us?)
yours

Last edited by carrie; 10-22-2004 at 03:58 AM.
 
Old 11-23-2004, 06:59 PM   #8
tiox
LQ Newbie
 
Registered: Nov 2004
Location: Costa Rica
Distribution: Suse 9.1 personal
Posts: 4

Rep: Reputation: 0
i have the same problem,
k internet doesnt seem to detect the modem at all, in yast themodem appears to be configured,however nothing happens
 
Old 01-03-2005, 08:52 AM   #9
ruan567
LQ Newbie
 
Registered: Sep 2004
Distribution: Mandrake 10
Posts: 6

Rep: Reputation: 0
Same problem

I am also having the exact same problem with the new ltmodem driver running on Suse 9.1 personal [no other modifications made after installation from ISO image]

Could this be a bug in the ltmodem rpm?

Ruan
 
Old 01-15-2005, 01:33 AM   #10
suranga
LQ Newbie
 
Registered: Jan 2005
Location: Singapore
Distribution: SUSE LINUX Prof 9.2
Posts: 14

Rep: Reputation: 0
Hi adam_the_noob,
I too have the same problem when I have the Motorola PCI modem plugged in. SUSE Hardware database shows only 3 chip-sets to support SUSE.
1 SiS7013 56k Modem
2 SmartPCI562
3 VIA AC97 Modem Codec (VT82C686/686A/686B)
I had Aztech modem with SmartPCI562 Chip. When I replaced the Motorola with Aztech, I don't have this problem anymore, This is just my experience, I am totally a newbie to Linux.
But this suggest that it is a problem with driver. Why not try scanModem utility from http://linmodems.technion.ac.il

Carrie,
Now I got the same problem you have. He-he, I get "options error (exit code 2)" Hmmm, ....

Last edited by suranga; 01-15-2005 at 01:44 AM.
 
Old 01-15-2005, 10:17 AM   #11
K. Carl
LQ Newbie
 
Registered: Jan 2004
Distribution: SuSE 9.3
Posts: 10

Rep: Reputation: 0
I had no luck whatever in cofiguring a PCI winmodem, however others have had success. My solution was to obtain an old exernal modem connected via a serial cable. That was operational within 30 minutes of making my hardware connections.

Disclaimer: I'm also quite inexperienced, but this worked for me.

Regards,
K. Carl
 
Old 01-16-2005, 12:52 AM   #12
suranga
LQ Newbie
 
Registered: Jan 2005
Location: Singapore
Distribution: SUSE LINUX Prof 9.2
Posts: 14

Rep: Reputation: 0
Hi,
I could get my Aztech SmartPCI562 to work perfect.
Many thanks to jk73 for directing us to search for updates manually at Suse Downloads.
You all should try it too. http://www.novell.com/linux/download/updates/index.html
I only had to use the patch "29 Oct 2004 smartlink-softmodem" in Suse 9.2.
So, this will solve the problem of some of you but, not all. If you have one with Lucent chip there is an update posted in December. Hope that'll do ...
Oh, don't forget to reboot before you try to connect.
 
Old 02-10-2005, 02:02 PM   #13
DoDo1523
LQ Newbie
 
Registered: Feb 2005
Posts: 1

Rep: Reputation: 0
Exclamation

hi im DoDo1523 im a new user in linux and i have a problem
when i try to connect to the internet the modem cuts off and the log says :
pppd[0]died : pppd options error (exit code 2)

so plz if anyone one can propose somthing to fix this problem i will be very thankfull to him
PLz help

My e-mail is : ndodo15@hotmail.com

Last edited by DoDo1523; 02-10-2005 at 02:04 PM.
 
Old 02-10-2005, 09:50 PM   #14
suranga
LQ Newbie
 
Registered: Jan 2005
Location: Singapore
Distribution: SUSE LINUX Prof 9.2
Posts: 14

Rep: Reputation: 0
DoDo, The posts above seems to have number of suggestions. Follow them. Go to the suse web and find if your modem chip-set is supported. If yes, look for the patch rpm in downloads. This might work. Use the scanmodem utility to find your modem chip-set, if you don't know it yet.
Regards
Suranga
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Getting 56k modem to work with SUSE 10 al2cane SUSE / openSUSE 4 10-21-2005 05:41 AM
Can't get my cable modem to work with SUSE 9.1 Hrothgar15 Linux - Newbie 1 08-14-2005 04:40 PM
Trouble getting built in Wifi to work with Suse 9.1 (HP laptop) mello Linux - Wireless Networking 1 09-14-2004 02:24 PM
how to make my modem work in suse 9.0 pssarr Linux - Newbie 2 04-21-2004 04:29 PM
Suse 8.2 found modem, but it doesn't work jmacdono Linux - Hardware 12 10-17-2003 06:53 PM


All times are GMT -5. The time now is 04:34 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration