LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 07-18-2011, 08:05 PM   #1
awww
Member
 
Registered: Nov 2010
Posts: 38

Rep: Reputation: Disabled
Unhappy Troble installing PECL uploadprogress


Hi im tryin to install PECL uploadprogress through shh and i keep getting this error i dont know why could anyone help me

Code:
[root@~]# pecl install uploadprogress
WARNING: channel "pecl.php.net" has updated its protocols, use "channel-update pecl.php.net" to update
downloading uploadprogress-1.0.1.tgz ...
Starting to download uploadprogress-1.0.1.tgz (8,536 bytes)
.....done: 8,536 bytes

Warning: strtotime(): It is not safe to rely on the system's timezone settings. You are *required* to use the date.timezone setting or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected 'America/Denver' for 'MST/-7.0/no DST' instead in PEAR/Validate.php on line 489

Warning: strtotime(): It is not safe to rely on the system's timezone settings. You are *required* to use the date.timezone setting or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected 'America/Denver' for 'MST/-7.0/no DST' instead in /usr/share/pear/PEAR/Validate.php on line 489
4 source files, building
running: phpize
Configuring for:
PHP Api Version:         20090626
Zend Module Api No:      20090626
Zend Extension Api No:   220090626
/usr/bin/phpize: /var/tmp/uploadprogress/build/shtool: /bin/sh: bad interpreter: Permission denied
Cannot find autoconf. Please check your autoconf installation and the
$PHP_AUTOCONF environment variable. Then, rerun this script.

ERROR: `phpize' failed
i have yum -y install php-devel installed
Code:
[root@~]# yum -y install php-devel
Loaded plugins: fastestmirror, priorities
Loading mirror speeds from cached hostfile
 * atomic: www4.atomicorp.com
 * rpmforge: fr2.rpmfind.net
702 packages excluded due to repository priority protections
Setting up Install Process
Package php-devel-5.3.6-3.el5.art.x86_64 already installed and latest version
Package php-devel-5.3.6-3.el5.art.i386 already installed and latest version
Nothing to do
And i have yum install autoconf automake gcc-c++ make installed

Code:
[root@~]# yum install autoconf automake gcc-c++ make
Loaded plugins: fastestmirror, priorities
Loading mirror speeds from cached hostfile
 * atomic: www4.atomicorp.com
 * rpmforge: fr2.rpmfind.net
702 packages excluded due to repository priority protections
Setting up Install Process
Package autoconf-2.59-12.noarch already installed and latest version
Package automake-1.9.6-2.3.el5.noarch already installed and latest version
Package gcc-c++-4.1.2-50.el5.x86_64 already installed and latest version
Package 1:make-3.81-3.el5.x86_64 already installed and latest version
Nothing to do
Why am i gettin that error
 
Old 07-19-2011, 03:29 AM   #2
bathory
LQ Guru
 
Registered: Jun 2004
Location: Piraeus
Distribution: Slackware
Posts: 11,641

Rep: Reputation: 1539Reputation: 1539Reputation: 1539Reputation: 1539Reputation: 1539Reputation: 1539Reputation: 1539Reputation: 1539Reputation: 1539Reputation: 1539Reputation: 1539
Hi,
Quote:
/usr/bin/phpize: /var/tmp/uploadprogress/build/shtool: /bin/sh: bad interpreter: Permission denied
Have a look at this post here at LQ for an explanation and a solution

Regards
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Problems installing using PECL littlened Linux - General 2 09-23-2011 11:18 AM
Trying to install http://pecl.php.net/package/uploadprogress on debian lenny ludo33 Linux - Newbie 8 04-14-2010 12:49 PM
Getting a C Compiler error when installing Pear libraries using Pecl Cowgba Linux - Software 2 07-21-2009 10:06 PM
Gentoo not installing pecl-pdo 70mas Linux - Server 1 08-05-2007 10:20 PM
Troble Installing RH! :( Kaiser Linux - Software 1 08-29-2003 09:45 PM


All times are GMT -5. The time now is 09:15 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration