LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 06-01-2004, 08:13 PM   #1
MatthewASmith79
Member
 
Registered: Feb 2004
Location: Pennsylvania
Distribution: SuSE10.1
Posts: 58

Rep: Reputation: 15
Tring to insall XMMS, GLIB problem


Gang:

When I try to install XMMS (latest version) I keep getting this glib problem when I try to ./configure:

checking for GLIB - version >= 1.2.2...
*** 'glib-config --version' returned 1.2.9, but GLIB (1.2.10)
*** was found! If glib-config was correct, then it is best
*** to remove the old version of GLIB. You may also be able to fix the error
*** by modifying your LD_LIBRARY_PATH enviroment variable, or by editing
*** /etc/ld.so.conf. Make sure you have run ldconfig if that is
*** required on your system.
*** If glib-config was wrong, set the environment variable GLIB_CONFIG
*** to point to the correct copy of glib-config, and remove the file config.cache
*** before re-running configure
no
configure: error: *** GLIB >= 1.2.2 not installed - please install first ***
matthewasmith79@linux:~/xmms-1.2.10>

Any suggestions?

Cheers
 
Old 06-01-2004, 10:10 PM   #2
tungaw2001
Member
 
Registered: Aug 2003
Posts: 45

Rep: Reputation: 15
your xmms is not compatible with glibc installed on your system. Try to get a xmms compatible with your glibc or try to get a glibc and install it on your system and run the xmms configuration.
 
Old 06-04-2004, 02:10 AM   #3
anithinks
LQ Newbie
 
Registered: Jun 2004
Distribution: RH 9 (Shrike)
Posts: 4

Rep: Reputation: 0
There was an earlier post regarding the same problem.
But there is another issue involved: the GLIB versions available on gtk.org are all v.1.2.10 (even if you select the earlier versions). I tried to install the new XMMS, and it said that I needed GLIB >= 1.2.2, so I installed glib 1.2.2, but it still said during the XMMS installation (something to the effect of) that GLIB 1.2.2 returned, but 1.2.10 detected!! I tried installing glib 1.2.0, as suggested on the other post, but it still gave the same problem. So I am still without an XMMS player!
Any further suggestions ould be appreciated.
Anir...
 
Old 06-04-2004, 11:01 PM   #4
MatthewASmith79
Member
 
Registered: Feb 2004
Location: Pennsylvania
Distribution: SuSE10.1
Posts: 58

Original Poster
Rep: Reputation: 15
Quote:
Originally posted by anithinks
There was an earlier post regarding the same problem.
But there is another issue involved: the GLIB versions available on gtk.org are all v.1.2.10 (even if you select the earlier versions). I tried to install the new XMMS, and it said that I needed GLIB >= 1.2.2, so I installed glib 1.2.2, but it still said during the XMMS installation (something to the effect of) that GLIB 1.2.2 returned, but 1.2.10 detected!! I tried installing glib 1.2.0, as suggested on the other post, but it still gave the same problem. So I am still without an XMMS player!
Any further suggestions ould be appreciated.
Anir...
What I did was via the SuSE Yast program, I uninstalled the current GLIB (after I downloaded glib 1.2.10 of course ) then I immediately installed glib 1.2.10. This got me past the glib issue, however it it raised GTK+ issues, so I unistalled the current GTK+ version via Yast as I did with glib, then I installed the latest GTK+ version. This eliminated all my problems and now I have my XMMS! Now if I could just get it to install AAC codecs~!

Hope this helps!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
xmms install (needs glib>1.22), just installed glib 2.4.8 and still get error message eskiled Linux - Software 2 12-19-2005 10:12 PM
xmms n GLIB AVD_ZM Linux - Software 1 02-09-2005 11:46 AM
Apollon Insall Problem BlackShadow Linux - Software 1 10-08-2004 05:36 AM
Installing XMMS, Problem with glib Inexactitude Linux - Software 3 10-18-2003 05:01 PM
xmms problem with glib 1.2.10 safrout Linux - Software 9 10-11-2002 04:44 AM


All times are GMT -5. The time now is 04:54 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration