LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 02-09-2015, 10:41 AM   #1
arun natarajan
Member
 
Registered: Jun 2014
Posts: 108

Rep: Reputation: Disabled
tree cmd is not working


Hi All,

Not able to find TREE command in EL6, its working fine in EL5. Need help on this.

Below are the details.



[root@localhost ~]# mkdir -p /college/sports/performer/cricket

[root@localhost ~]# tree /college/
-bash: tree: command not found

[root@localhost ~]# tree college/
-bash: tree: command not found

[root@localhost ~]# which tree
/usr/bin/which: no tree in (/usr/local/sbin:/usr/local/bin:/sbin:/bin:/usr/sbin: /usr/bin:/root/bin)

[root@localhost ~]# uname -a
Linux localhost.localdomain 2.6.32-71.el6.x86_64 #1 SMP Wed Sep 1 01:33:01 EDT 2010 x86_64 x86_64 x86_64 GNU/Linux

[root@localhost ~]# id
uid=0(root) gid=0(root) groups=0(root),1(bin),2(daemon),3(sys),4(adm),6(disk),10(wheel) context=unconfined_u:unconfined_r:unconfined_t:s0-s0:c0.c1023
 
Old 02-09-2015, 10:57 AM   #2
TB0ne
LQ Guru
 
Registered: Jul 2003
Location: Birmingham, Alabama
Distribution: SuSE, RedHat, Slack,CentOS
Posts: 18,785

Rep: Reputation: 4159Reputation: 4159Reputation: 4159Reputation: 4159Reputation: 4159Reputation: 4159Reputation: 4159Reputation: 4159Reputation: 4159Reputation: 4159Reputation: 4159
Quote:
Originally Posted by arun natarajan View Post
Hi All,
Not able to find TREE command in EL6, its working fine in EL5. Need help on this. Below are the details.

[root@localhost ~]# mkdir -p /college/sports/performer/cricket
[root@localhost ~]# tree /college/
-bash: tree: command not found

[root@localhost ~]# tree college/
-bash: tree: command not found

[root@localhost ~]# which tree
/usr/bin/which: no tree in (/usr/local/sbin:/usr/local/bin:/sbin:/bin:/usr/sbin: /usr/bin:/root/bin)
The error is very obviously telling you that the "tree" command isn't in the path specified (type in "echo $PATH" to see what's set), or you don't have it installed. So, INSTALL IT. Type in "yum install tree", or call Red Hat support....you are PAYING FOR RHEL, right?????
 
Old 02-09-2015, 10:59 AM   #3
veerain
Senior Member
 
Registered: Mar 2005
Location: Earth bound to Helios
Distribution: Custom
Posts: 2,524

Rep: Reputation: 319Reputation: 319Reputation: 319Reputation: 319
In my distro tree is a separate package to be installed.
 
Old 02-09-2015, 12:53 PM   #4
TB0ne
LQ Guru
 
Registered: Jul 2003
Location: Birmingham, Alabama
Distribution: SuSE, RedHat, Slack,CentOS
Posts: 18,785

Rep: Reputation: 4159Reputation: 4159Reputation: 4159Reputation: 4159Reputation: 4159Reputation: 4159Reputation: 4159Reputation: 4159Reputation: 4159Reputation: 4159Reputation: 4159
Quote:
Originally Posted by veerain View Post
In my distro tree is a separate package to be installed.
...and what distro are you using?? You don't say, nor do you suggest how to install it. Also, this was said to the OP previously.
 
Old 02-10-2015, 05:30 AM   #5
chrism01
LQ Guru
 
Registered: Aug 2004
Location: Sydney
Distribution: Centos 6.9, Centos 7.3
Posts: 17,356

Rep: Reputation: 2367Reputation: 2367Reputation: 2367Reputation: 2367Reputation: 2367Reputation: 2367Reputation: 2367Reputation: 2367Reputation: 2367Reputation: 2367Reputation: 2367
Code:
yum install tree
should work; its in the base repo in my Centos 6.6 system - should be identical in RHEL6
 
1 members found this post helpful.
Old 02-11-2015, 07:13 AM   #6
arun natarajan
Member
 
Registered: Jun 2014
Posts: 108

Original Poster
Rep: Reputation: Disabled
Hi All,

Thanks for answers. Now i installed TREE using rpm -ivh tree* from the package folder. Since i dint create the repo yet, i used rpm itself.
TREE command is working fine now

Regards,
Arun
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] BASH: $(cmd) not working in script? or What have I missed? PTrenholme Programming 5 08-19-2014 09:23 AM
Issue sg_modes cmd at cmd line, want to see the cmd in binary form NuUser Linux - Newbie 1 03-28-2012 08:08 AM
yum, rpm cmd , ftp , wget ..nothing is working :'( rajashree Other *NIX 1 02-02-2007 03:52 AM
sudo command not working startproc cmd not found Imajica21 Linux - General 2 04-14-2005 01:22 PM
Where is the TREE cmd located on LINUX? icepig Linux - General 2 11-18-2003 03:57 PM


All times are GMT -5. The time now is 10:57 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration