LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 10-03-2013, 03:08 PM   #1
esso82
Member
 
Registered: Aug 2013
Location: Plymouth, UK
Distribution: SolydK
Posts: 45

Rep: Reputation: Disabled
Transmission-daemon doesn't listen on RPC port


note: started a new thread as the old one was confusing and I finaly found the cause of my problem, just need to sort it out

The problem is that transmission-daemon doesn't listen on RPC port set in settings.json

Did a fresh install of Debian Wheezy, graphical install, no desktop, just SSH and system utilities chossen from install menu

After system install, aptitude update and transmission-daemon transmission-common transmission-cli instalation

everything worked fine right after instalation of the daemon, I stopped the daemon, changed the settings.json file, didn't start the daemon, but reboot the system and it all worked fine, but ...

once (ONCE !!!) I type in the console /etc/init.d/transmission-daemon start - the daemon will never more listen on rpc port on system start (boot), I have to restart or stop/start it manualy, then everything works, but I want it to work automaticaly after system power on

anyone knows why???? ... I need to get this fixed, reinstalled system 8 times because of this problem - to find where exactly it gets broken

people please help me

OS: debian wheezy
Config: Gigabyte E350N WIN8, 1 x 4GB Kingston HyperX 1666, 3TB WD Red, headless

EDIT: OK, found how to make it start automaticaly after power on, all I have to do is restart twice in a row without starting the daemon manualy, don't know why, but that's the way it works, once I start/restart the daemon manualy, I have to reboot twice in a row, the second time it start automaticaly
Might be because my system is atm using different NIC driver, I've got realtek 8168b and it's using 8169, so I have to learn how to install the driver from realtek website and that might cure the problem

Last edited by esso82; 10-06-2013 at 12:27 PM.
 
Old 08-23-2014, 04:13 PM   #2
awh
LQ Newbie
 
Registered: Aug 2014
Posts: 1

Rep: Reputation: Disabled
Sorry for necro, but I was having this exact problem (transmission-daemon not binding RPC on wheezy) and this thread was pretty high up in the Google searches I did.

For me, I think disabling exim4 and bind9 did the trick as they were installed by default on my online.net box and I wasn't using them.

# update-rc.d bind9 disable
# update-rc.d exim4 disable

Worked fine for me, then next reboot transmission bound to RPC with no issues.

If you're not going to use them, I'd remove them too:

# apt-get remove bind9{,utils} exim4{,-base,-config,-daemon-light}
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] xbmcbuntu & transmission-daemon jlivin25 Linux - Newbie 5 04-26-2012 02:00 PM
Transmission daemon permissions problem. SUID related??? cbass Linux - Software 2 10-19-2011 04:03 PM
transmission-daemon doesn't download zoran119 Slackware 1 10-19-2011 03:15 PM
[SOLVED] Shorewall rejecting allowed traffic for transmission-daemon RyanRahl Linux - Security 7 05-23-2011 03:05 PM
NFS RPC: Port mapper failure - RPC: Unable to receive KEJP Linux - Networking 6 12-18-2006 03:14 AM


All times are GMT -5. The time now is 12:42 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration