LinuxQuestions.org
Latest LQ Deal: Complete CCNA, CCNP & Red Hat Certification Training Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 11-08-2004, 02:43 AM   #1
ksgill
Senior Member
 
Registered: Apr 2003
Location: Toronto, Canada
Distribution: Ubuntu Jaunty (9.04)
Posts: 1,044

Rep: Reputation: 45
transcode-0.6.10 error


Hi,
I was trying to make transcode from the sourcecode on my comp and it gave me a bunch on lines with these errors:

i386/dsputil_mmx.c:1488: undefined reference to `ff_pw_3'
/home/jatt/transcode-0.6.10/ffmpeg/libavcodec/libtcavcodec.a(dsputil_mmx.o)(.text+0x39ff8):i386/dsputil_mmx.c:1488: undefined reference to `ff_pw_20'


Any ideas?
 
Old 11-08-2004, 03:24 PM   #2
Mara
Moderator
 
Registered: Feb 2002
Location: Grenoble
Distribution: Debian
Posts: 9,568

Rep: Reputation: 164Reputation: 164
Please post the link you got the code from.
 
Old 11-08-2004, 08:53 PM   #3
ksgill
Senior Member
 
Registered: Apr 2003
Location: Toronto, Canada
Distribution: Ubuntu Jaunty (9.04)
Posts: 1,044

Original Poster
Rep: Reputation: 45
Alright, I gave up with the source code and found the rpm for transcode. It gave me about 15 dependency errors, most of which I fulfilled. I dont know where I can find these libraries though:

error: Failed dependencies:
libMagick-5.5.4-Q16.so.0 is needed by transcode-0.6.12-0.pm.2
libaviplayavformat-0.7.so.0 is needed by transcode-0.6.12-0.pm.2
libaviplaydha-0.7.so.0 is needed by transcode-0.6.12-0.pm.2
libaviplayvidix-0.7.so.0 is needed by transcode-0.6.12-0.pm.2

Here's another one: libasound.so.1 is needed by avifile-0.7.38-1

Where can I find the above for Suse 9.1

Thanks

Last edited by ksgill; 11-08-2004 at 09:13 PM.
 
Old 11-10-2004, 01:32 PM   #4
Mara
Moderator
 
Registered: Feb 2002
Location: Grenoble
Distribution: Debian
Posts: 9,568

Rep: Reputation: 164Reputation: 164
Guessing but:
libMagick-5.5.4-Q16.so.0 should be in ImageMagick* (probably ImageMagick-devel)
libavi* probably from libavcodec, which may (not sure) be libav1394 (libav1394 and libav1394-devel packages)

libasound is from alsa* packages

You can get all the packages from SuSE FTP server (or from installation cd, if you have one): ftp://ftp.suse.com/pub/suse/i386/9.1/suse/i586/
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
transcode configure error trawler Linux - Software 3 10-24-2005 05:08 PM
error make transcode-1.0.1 valzor Linux - Software 2 10-09-2005 01:25 PM
transcode error ziggamon Linux - Software 1 01-08-2004 11:32 PM
Transcode compile error asalford Linux - Software 3 12-17-2003 06:34 PM
transcode module error neurotic Linux - Software 3 11-25-2003 05:39 PM


All times are GMT -5. The time now is 04:32 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration