LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 10-09-2009, 11:45 AM   #1
bamtoy
Member
 
Registered: Jul 2009
Posts: 46

Rep: Reputation: 15
Touchpad problems


Hello,

I have problems typing . The cursor just moves around and sometimes deletes what I have just typed.
I have checked that the file below has Option "SHMConfig"
Code:
cat /etc/X11/xorg.conf
I dont know if this code will help
Code:
syndaemon -t -d
And secondly, how do I add 'syndaemon -t -d' in the START menu

Bamtoy
 
Old 10-09-2009, 12:06 PM   #2
repo
LQ 5k Club
 
Registered: May 2001
Location: Belgium
Distribution: Arch
Posts: 8,527

Rep: Reputation: 898Reputation: 898Reputation: 898Reputation: 898Reputation: 898Reputation: 898Reputation: 898
Quote:
I have problems typing . The cursor just moves around and sometimes deletes what I have just typed.
You can disale the touchpad using fn while you type
Quote:
And secondly, how do I add 'syndaemon -t -d' in the START menu
you can add the line to
/etc/rc.local
or the equivalent in suse
 
Old 10-10-2009, 03:53 AM   #3
bamtoy
Member
 
Registered: Jul 2009
Posts: 46

Original Poster
Rep: Reputation: 15
Quote:
repo;3713599 You can disale the touchpad using fn while you type
How do I disable it while typing. Any code ?
Quote:
you can add the line to /etc/rc.local or the equivalent in suse
To what should I add this line?

Sorry I am new to suse.


bamtoy
 
Old 10-10-2009, 04:27 AM   #4
repo
LQ 5k Club
 
Registered: May 2001
Location: Belgium
Distribution: Arch
Posts: 8,527

Rep: Reputation: 898Reputation: 898Reputation: 898Reputation: 898Reputation: 898Reputation: 898Reputation: 898
Quote:
And secondly, how do I add 'syndaemon -t -d' in the START menu
What do you mean by start menu?
If you want
Quote:
syndaemon -t -d
To start at boot, edit /etc/rc.local and add the line.
If you want it to start when gnome starts, make a script, and add the script to startup applications.
 
Old 10-11-2009, 02:36 PM   #5
bamtoy
Member
 
Registered: Jul 2009
Posts: 46

Original Poster
Rep: Reputation: 15
Quote:
repo;3714352]What do you mean by start menu?
If you want to start at boot, edit /etc/rc.local and add the line.
Yes I want it at boot,
I have KDE3. I did kdesu kwrite on the file and I saw no lines in that file. There is nothing in it.

Quote:
If you want it to start when gnome starts, make a script, and add the script to startup applications.
For KDE do I need to write a script. I have to study the basics of shell script then
 
Old 10-11-2009, 03:09 PM   #6
repo
LQ 5k Club
 
Registered: May 2001
Location: Belgium
Distribution: Arch
Posts: 8,527

Rep: Reputation: 898Reputation: 898Reputation: 898Reputation: 898Reputation: 898Reputation: 898Reputation: 898
Quote:
Yes I want it at boot,
If you want to start at boot, edit /etc/rc.local and add the line.
 
Old 10-11-2009, 03:50 PM   #7
AwesomeMachine
Senior Member
 
Registered: Jan 2005
Location: USA and Italy
Distribution: Debian testing/sid; OpenSuSE; Fedora
Posts: 1,828

Rep: Reputation: 256Reputation: 256Reputation: 256
If /etc/rc.local is not there, or is totally empty, just create the file and add the line repo is talking about.
 
Old 10-12-2009, 02:43 PM   #8
bamtoy
Member
 
Registered: Jul 2009
Posts: 46

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by AwesomeMachine View Post
If /etc/rc.local is not there, or is totally empty, just create the file and add the line repo is talking about.
I have done it, though I still see the cursor moving around. I have to check the efficacy of the syndaemon code.
 
Old 10-12-2009, 02:49 PM   #9
repo
LQ 5k Club
 
Registered: May 2001
Location: Belgium
Distribution: Arch
Posts: 8,527

Rep: Reputation: 898Reputation: 898Reputation: 898Reputation: 898Reputation: 898Reputation: 898Reputation: 898
Did you created /etc/rc.local as a script?
Is /etc/rc.local executable?
What happens if you type as root
Code:
/etc/rc.local
Here is the original file
Quote:
#!/bin/sh -e
#
# rc.local
#
# This script is executed at the end of each multiuser runlevel.
# Make sure that the script will "exit 0" on success or any other
# value on error.
#
# In order to enable or disable this script just change the execution
# bits.
#
# By default this script does nothing.

exit 0
Add the line you need before the exit 0
as root type
Code:
chmod +x /etc/rc.local
 
Old 10-14-2009, 01:55 PM   #10
bamtoy
Member
 
Registered: Jul 2009
Posts: 46

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by repo View Post
Did you created /etc/rc.local as a script?
Is /etc/rc.local executable?
What happens if you type as root
Code:
/etc/rc.local
Here is the original file


Add the line you need before the exit 0
as root type
Code:
chmod +x /etc/rc.local
No , I just edited the file

When I type the code I get permission denied.
PHP Code:
bamtoy@linux-8aqf:~> su
Password
:
linux-8aqf:/home/bamtoy # /etc/rc.local
bash: /etc/rc.localPermission denied 
I dont know if it is executable.
 
Old 10-14-2009, 01:56 PM   #11
repo
LQ 5k Club
 
Registered: May 2001
Location: Belgium
Distribution: Arch
Posts: 8,527

Rep: Reputation: 898Reputation: 898Reputation: 898Reputation: 898Reputation: 898Reputation: 898Reputation: 898
did you do
Code:
chmod +x /etc/rc.local
as root ?

Last edited by repo; 10-14-2009 at 03:09 PM.
 
Old 10-17-2009, 06:31 AM   #12
bamtoy
Member
 
Registered: Jul 2009
Posts: 46

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by repo View Post
did you do
Code:
chmod +x /etc/rc.local
as root ?
I was also checking synclient
Code:
#!/bin/sh
synclient MaxTapTime=0
and put it in ~/.kde4/Autostart/touchpad.sh
 
Old 10-17-2009, 07:13 AM   #13
repo
LQ 5k Club
 
Registered: May 2001
Location: Belgium
Distribution: Arch
Posts: 8,527

Rep: Reputation: 898Reputation: 898Reputation: 898Reputation: 898Reputation: 898Reputation: 898Reputation: 898
Quote:
Originally Posted by bamtoy View Post
I was also checking synclient
Code:
#!/bin/sh
synclient MaxTapTime=0
and put it in ~/.kde4/Autostart/touchpad.sh
And does it work ?
 
Old 10-18-2009, 11:14 AM   #14
bamtoy
Member
 
Registered: Jul 2009
Posts: 46

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by repo View Post
And does it work ?
I am giving it a few days . It does not bounce or move around when I am typing this.
 
Old 10-24-2009, 07:42 AM   #15
bamtoy
Member
 
Registered: Jul 2009
Posts: 46

Original Poster
Rep: Reputation: 15
Hi All,
I am closing this thread. The cursor is slighty better behaved now.


Bamtoy
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Touchpad problems makaai Linux - Laptop and Netbook 2 01-07-2009 11:02 AM
Touchpad problems DaBlade Linux - Hardware 1 03-29-2008 04:41 PM
Touchpad Problems Ryuga Akikawa Slackware 3 09-01-2006 07:49 PM
Synaptics Touchpad problems on 2.6.10 freax Linux - Laptop and Netbook 0 02-20-2005 09:10 AM
Keyboard and touchpad problems! Chamelinux Linux - Laptop and Netbook 1 05-24-2004 01:31 PM


All times are GMT -5. The time now is 06:48 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration