LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 01-24-2007, 03:18 PM   #1
a_vri
LQ Newbie
 
Registered: Jan 2007
Distribution: Fedora
Posts: 3

Rep: Reputation: 0
totem/xine/rythmbox etc. "can't create mcop directory"


hi all.

I'm using Debian etch. (full sys below)
recently all of my music players stopped working.

Totem, for example displays this message when it runs from the terminal as user lxmonk:

Quote:
lxmonk@debian:~$ totem
Creating link /home/lxmonk/.kde/socket-debian.
can't create mcop directory
or when run as root:
Quote:
debian:/home/lxmonk# totem

(totem:18103): GnomeUI-WARNING **: While connecting to session manager:
Authentication Rejected, reason : None of the authentication protocols specified are supported and host-based authentication failed.

** (totem:18103): WARNING **: Failed to connect to the session bus: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.
Creating link /root/.kde/socket-debian.
can't create mcop directory
i tried #mkdir -p /home/lxmonk/.kde/socket-debian.
to no avail.. (the dir exists, but i keep getting the same error).

my system:
Debian etch, Gnome 2.14.3
AMD ATHLON64 3500+
MSI K9NGM2 (C51PV CHIPSET based)

i also tried reinstalling totem and xine using Synpatic - no change.

any help?

cheers,
Avri.

Last edited by a_vri; 01-24-2007 at 03:39 PM.
 
Old 02-03-2007, 09:52 PM   #2
Pollyanna
Member
 
Registered: Oct 2003
Location: Germany
Distribution: Slackware 10.2, SuSE 10.0, Solaris(SPARC) 9+Solaris(x86) 9, NetBSD(sparc) 2.0.2
Posts: 43

Rep: Reputation: 15
Hi,

I had this problem five minutes ago and solved it by manually creating
Code:
~/.kde/socket-ophelia
It works for me, but You seem to have created the directory as root and now only root can write to this directory in your $HOME.

One suggestion: no file in your $HOME should be owned by root.

Hope this helped.
 
Old 03-06-2007, 04:32 PM   #3
pitchum
LQ Newbie
 
Registered: Mar 2007
Posts: 1

Rep: Reputation: 0
Quote:
Originally Posted by a_vri
Totem, for example displays this message when it runs from the terminal as user lxmonk:
Quote:
can't create mcop directory
Maybe you recently enabled ESD sounds in Gnome and it makes an exclusive usage of your sound card.
Simply disable it like this:
go to "Desktop -> Preferences -> Sound" and uncheck the checkbox "Enable software sound mixing (ESD)".

Then try to restart totem.

I had a similar problem and this resolved it.
 
Old 03-07-2007, 02:17 PM   #4
a_vri
LQ Newbie
 
Registered: Jan 2007
Distribution: Fedora
Posts: 3

Original Poster
Rep: Reputation: 0
hi guys.

i'm glad to report that one of the last system updates did the trick!!

thank you all!

avri.
 
  


Reply

Tags
debian, esd, etch, gnome, sound


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
can't create mcop directory garbo73 Linux - General 15 02-11-2008 01:55 PM
Installed kernel-devel and source for i686; didn't create directory "build" itsonlyme Linux - Kernel 3 04-05-2007 09:08 AM
can't create mcop directory garbo73 Linux - Newbie 5 12-21-2005 10:34 AM
"Cannot create directory: No space left on device" but I have 7.1G available !!!! fr_laz Linux - General 3 12-09-2005 04:44 PM
"mkdir: cannot create directory `foo': Read-only file system" on FAT32 maddes Linux - Hardware 1 11-26-2003 06:19 PM


All times are GMT -5. The time now is 07:01 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration