LinuxQuestions.org
Latest LQ Deal: Complete CCNA, CCNP & Red Hat Certification Training Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 06-19-2011, 02:28 AM   #1
ajayan
Member
 
Registered: Dec 2007
Posts: 89

Rep: Reputation: 16
Top showing 9999% CPU usage on Ubuntu Lucid 10.04


Hi,

On My Ubuntu 10.04 Lucid 64 Bit Server, top command showing CPU usage 9999% for java process.But htop command or ps -aux is showing accurate usage.After googling, i found that its bug related to "sum_exec_runtime', but the Patch given is not working.

http://kerneltrap.org/mailarchive/li.../328379/thread

Can any one help?

Advanced Thanks
Ajayan
 
Old 06-19-2011, 01:57 PM   #2
Tinkster
Moderator
 
Registered: Apr 2002
Location: in a fallen world
Distribution: slackware by choice, others too :} ... android.
Posts: 23,067
Blog Entries: 11

Rep: Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910
I have my doubts whether these issues are related. The post
you pointed at is 4 years old, I can't imagine the issue
being carried forth in current kernels of a recent Linux
release. Which kernel version does your machine run, what's
your ubuntu release?


Cheers,
Tink
 
Old 06-19-2011, 03:45 PM   #3
ajayan
Member
 
Registered: Dec 2007
Posts: 89

Original Poster
Rep: Reputation: 16
Hi Tink,

Thanks for the reply.
Ubuntu server is running on Amazon platform.Kernel Version is 2.6.32-308-ec2 and OS is Ubuntu 10.04 Lucid 64 bit.
 
Old 06-19-2011, 08:27 PM   #4
syg00
LQ Veteran
 
Registered: Aug 2003
Location: Australia
Distribution: Lots ...
Posts: 15,158

Rep: Reputation: 1943Reputation: 1943Reputation: 1943Reputation: 1943Reputation: 1943Reputation: 1943Reputation: 1943Reputation: 1943Reputation: 1943Reputation: 1943Reputation: 1943
I'm with Tink. That patch was for 2.6.23; no surprise it won't fit on 2.6.32. And that would probably be an Amazon modified kernel anyway.

I'm not saying it ain't possible it's the same/similar regression - maybe push a problem ticket up to Amazon and see if they have an answer.
 
0 members found this post helpful.
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
CPU usage from top jr8rdt Linux - Newbie 10 08-17-2011 06:46 AM
Load is very high but CPU usage is almost zero in top! mam2 Linux - Server 3 12-18-2009 03:53 PM
Top CPU usage explanation penguinco Fedora 3 11-30-2004 01:01 PM
need top clone- to measure CPU usage pao Linux - Software 4 10-07-2004 09:46 AM
Individual CPU usage not showing in ps/top hulli Linux - General 2 08-24-2004 02:44 AM


All times are GMT -5. The time now is 02:07 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration