LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (http://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   Tomcat 5.0.27 connecting to Apache 2 with jdk 1.2.6 (http://www.linuxquestions.org/questions/linux-newbie-8/tomcat-5-0-27-connecting-to-apache-2-with-jdk-1-2-6-a-217330/)

yea420 08-13-2004 08:21 PM

Tomcat 5.0.27 connecting to Apache 2 with jdk 1.2.6
 
Ok here we go,

I'm still relatively new to Linux so hopefully this will be a snap for you all. I have set up apache and tomcat and have read that it is good practice to connect them. From searching around the internet I downloaded jakarta-tomcat-connectors-jk-1.2-src-current.tar.gz.

After tar -xvzf'ing it I navigated to the CONNECTOR_HOME/jk/native and went on to use the command:

./configure --with-apxs=/usr/local/apache2/bin/apxs

I have checked the directory to make sure that there is in fact an apxs file there and there is. However as it compiles I get:

configure: error: You must specify a valid --with-apxs path

I have checked to make sure I have Pearl, which I do, and am right out of ideas.. Please help if you can. Below is the last few lines it spits out at me when I issue the configure command:

need to check for Perl first, apxs depends on it...
checking for perl... /usr/bin/perl
could not find /usr/local/apache2/bin/apxs
configure: error: You must specify a valid --with-apxs path

Thank you all in advance.


All times are GMT -5. The time now is 11:17 AM.