LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 02-01-2013, 07:29 AM   #1
venu147
LQ Newbie
 
Registered: Feb 2013
Posts: 12

Rep: Reputation: Disabled
To set specific version of firefox as default


Hi,
I am working on vm setup which has firefox 3.0 set. As I need Selenium IDE, I installed firefox 14.0.

FYI: Selenium is a suite of tools specifically for automating web browsers.

firefox 3.0 installed in /usr/bin/firefox
firefox 14.0 installed (by me) in $HOMEDIR/firefox/firefox

I dont have root permissions to upgrade existing firefox.


Problem:
My code invokes firefox 3.0, I didnt mention about version in my code. How can i set firefox 14 as default firefox version.


I tried setting $HOMEDIR/firefox/firefox in PATH and tried "which firefox" but it still show path of firefox3.0

Last edited by venu147; 02-01-2013 at 07:37 AM.
 
Old 02-01-2013, 08:22 AM   #2
Snark1994
Senior Member
 
Registered: Sep 2010
Location: Wales, UK
Distribution: Arch
Posts: 1,632
Blog Entries: 3

Rep: Reputation: 345Reputation: 345Reputation: 345Reputation: 345
You'd need to put "$HOMEDIR/firefox/firefox" at the start of your path (or at least, before /usr/bin)

Alternatively, you can just run firefox using the full path in your code (i.e. "$HOMEDIR/firefox/firefox", rather than just "firefox")

Regards,
 
Old 02-01-2013, 08:28 AM   #3
venu147
LQ Newbie
 
Registered: Feb 2013
Posts: 12

Original Poster
Rep: Reputation: Disabled
Yes, I tried that way putting my firefox path first. But it didnt work.
export PATH=/$HOMDIR/firefox/firefox:$PATH
 
Old 02-01-2013, 04:34 PM   #4
John VV
LQ Muse
 
Registered: Aug 2005
Location: A2 area Mi.
Posts: 16,981

Rep: Reputation: 2447Reputation: 2447Reputation: 2447Reputation: 2447Reputation: 2447Reputation: 2447Reputation: 2447Reputation: 2447Reputation: 2447Reputation: 2447Reputation: 2447
venu147
FF14 ?

you are aware that the very first time you launch ff14 it will auto update and auto install ff 18.0.1
 
Old 02-02-2013, 12:34 AM   #5
venu147
LQ Newbie
 
Registered: Feb 2013
Posts: 12

Original Poster
Rep: Reputation: Disabled
Hi,
I need to stay on ff less than ff18 as there are some error regarding "xre".

My problem is how to set my ff14 as default. Please share your suggestions if any.
 
Old 02-02-2013, 04:31 AM   #6
Snark1994
Senior Member
 
Registered: Sep 2010
Location: Wales, UK
Distribution: Arch
Posts: 1,632
Blog Entries: 3

Rep: Reputation: 345Reputation: 345Reputation: 345Reputation: 345
Quote:
Originally Posted by venu147 View Post
Yes, I tried that way putting my firefox path first. But it didnt work.
export PATH=/$HOMDIR/firefox/firefox:$PATH
That should be

Code:
export PATH=/$HOMEDIR/firefox:$PATH
AFAIK PATH contains directories, not files, and you typo'd on "HOMEDIR".

Regards,
 
Old 02-02-2013, 05:46 AM   #7
John VV
LQ Muse
 
Registered: Aug 2005
Location: A2 area Mi.
Posts: 16,981

Rep: Reputation: 2447Reputation: 2447Reputation: 2447Reputation: 2447Reputation: 2447Reputation: 2447Reputation: 2447Reputation: 2447Reputation: 2447Reputation: 2447Reputation: 2447
Quote:
I need to stay on ff less than ff18 as there are some error regarding "xre".
check "about firefox under "help"

if you did not turn off auto update it is 18.0.1 now

in Firefox
edit / preferences / advanced
then the update tab , and turn it off
but if you are already 18 ......
 
Old 02-06-2013, 02:33 AM   #8
venu147
LQ Newbie
 
Registered: Feb 2013
Posts: 12

Original Poster
Rep: Reputation: Disabled
Hi Snark1994,
Thanks for the response. I tried your solution but it didnt work.
 
Old 02-07-2013, 04:36 AM   #9
Snark1994
Senior Member
 
Registered: Sep 2010
Location: Wales, UK
Distribution: Arch
Posts: 1,632
Blog Entries: 3

Rep: Reputation: 345Reputation: 345Reputation: 345Reputation: 345
Can you post the output of

Code:
echo $PATH
and

Code:
whereis firefox
please?

Thanks,
 
Old 02-07-2013, 04:14 PM   #10
John VV
LQ Muse
 
Registered: Aug 2005
Location: A2 area Mi.
Posts: 16,981

Rep: Reputation: 2447Reputation: 2447Reputation: 2447Reputation: 2447Reputation: 2447Reputation: 2447Reputation: 2447Reputation: 2447Reputation: 2447Reputation: 2447Reputation: 2447
Quote:
Thanks for the response. I tried your solution but it didnt work.
what did not work

exporting the $PATH variable to the ff in your HOME folder will work

but you will need to do0 that EVERY time you want ff14 ( and turn off the auto update )
or the second time you launch ff14 it will be ff18.0.2
put the path to the ff14 ( insecure) in your ~/.bash_profile file
and it is not "HOMEDIR" it is "HOME"

PATH=$PATH:$HOME/bin
the /bin folder in your HOME folder should be already listed
place FF14 in there
~/bin/firefox ( "~/" IS "/home/YourUserName"
---- you need the full path---
Code:
PATH=$PATH:$HOME/bin:/home/YourUserName/bin/firefox

add "/home/YourUserName/bin/firefox"
to the path in ~/.bash_profile

then add LD_LIBRARY_PATH to the firfox folder and export that in the "~/.bash_profile"
and also add the "plugins" folder you MUST add by hand
or
use the very nice and handy "run-mozilla.sh" script to launch ff14
it is in the ff folder

Last edited by John VV; 02-07-2013 at 04:16 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
How to set the default version of wxPython in Ubuntu? msbstar Linux - Newbie 3 01-26-2011 12:14 PM
How to set the default version of wxPython in Ubuntu? msbstar Linux - Newbie 1 01-26-2011 12:14 PM
How Can I Set A Specific Default Wireless Network? davidx Linux - Software 1 10-27-2008 01:31 PM
How to set the default Java version robbbert Linux - Software 4 03-20-2006 03:44 PM
Set-up Firefox for default e-mail raysr Linux - Software 4 05-05-2005 08:28 PM


All times are GMT -5. The time now is 01:11 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration