LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 11-20-2013, 01:17 PM   #1
casperdaghost
Member
 
Registered: Aug 2009
Posts: 349

Rep: Reputation: 16
tmux vi "I don't know what kind of terminal you are on"


i am using the bash prompt and I want to change the term from screen to xterm.

Code:
bash-3.00$ echo $TERM
screen
bash-3.00$
i want to do this because when i try to open up something in vi while in tmux console i get this error;

Code:
bash-3.00$ vi back_checks
screen: Unknown terminal type
I don't know what kind of terminal you are on - all I have is 'screen'.
[Using open mode]
"back_checks" [New file]
:q!
bash-3.00$ /tmp/check-syncUsers_trialrun.2013Nov20
bash-3.00$ setenv TERM xterm
bash: setenv: command not found
bash-3.00$
When i am in the tcsh shell i just have to type in
Code:
 
setenv TERM xterm
and that fixes vi in tmux

how do i do the same in /bin/bash from the command line (with out using the /.bash_profile or /.bash_rc) I log into alot of machines with a the same user name so i need to make these changes locally to my tty not globally via the startupfiles.

is there a way to change the TERM setting to xterm from the commans line in bash?
 
Old 11-20-2013, 01:23 PM   #2
casperdaghost
Member
 
Registered: Aug 2009
Posts: 349

Original Poster
Rep: Reputation: 16
nevermind

export TERM=xterm seems to work


Code:
bash-3.00$ setenv TERM xterm
bash: setenv: command not found
bash-3.00$ echo $TERM
screen
bash-3.00$ export TERM=xterm
bash-3.00$ echo $TERM
xterm
bash-3.00$
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
How to set the font-size for "xterm" terminal-emulator (running "bash" shell) ajaygarg Linux - Desktop 1 03-09-2012 01:38 PM
[SOLVED] "Insert" & "Delete" key returns "~" in a terminal. sharky Linux - General 15 04-26-2011 09:36 AM
tmux equivalent of "screen -d -m command" AlucardZero Linux - Software 0 02-21-2010 10:29 PM
chrooted user: "write" and "talk" don't work. ldp Linux - Software 2 04-12-2005 03:05 AM
"segmentation error" when issuing "useradd" command through terminal with RH 9.0 kaihuang Linux - General 0 10-22-2003 12:47 AM


All times are GMT -5. The time now is 12:44 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration