LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 03-11-2008, 08:48 AM   #1
sray_ju
LQ Newbie
 
Registered: Mar 2008
Posts: 3

Rep: Reputation: 0
Time wrongly reset by system on reboot, opensuse 10.2


Each time on reboot the time is being wrongly reset automatically.
BIOS shows correct time, boots to other OS are okay.
Even after resetting to correct time by YAST2, the problem
reappears on reboot.

OS : Opensuse 10.2
AMD Athlon 3200 ASUS A8NE M/B with 3 GB RAM.

Thanks for any valuable feedback.
 
Old 03-11-2008, 09:05 AM   #2
ronlau9
Senior Member
 
Registered: Dec 2007
Location: In front of my LINUX OR MAC BOX
Distribution: Mandriva 2009 X86_64 suse 11.3 X86_64 Centos X86_64 Debian X86_64 Linux MInt 86_64 OS X
Posts: 2,369

Rep: Reputation: Disabled
Is the Timezone set correctly ?


all the best
 
Old 03-11-2008, 09:09 AM   #3
bathory
Guru
 
Registered: Jun 2004
Location: Piraeus
Distribution: Slackware
Posts: 10,898

Rep: Reputation: 1322Reputation: 1322Reputation: 1322Reputation: 1322Reputation: 1322Reputation: 1322Reputation: 1322Reputation: 1322Reputation: 1322Reputation: 1322
Remove /etc/adjtime and see if that helps

Regards
 
Old 03-11-2008, 09:24 AM   #4
felixc
Member
 
Registered: Jul 2005
Location: Canada
Distribution: Ubuntu, Debian
Posts: 94

Rep: Reputation: 15
Hi,

This could be caused by Linux expecting the BIOS to store the time in UTC. If your BIOS is set to the correct time in your timezone, check to see by how much the time changes on every reboot. I suspect you'll find it changes by however many hours off from UTC your local timezone is. If that's the case, the simplest fix is just to set the BIOS time to UTC. Cheers,

Felix
 
Old 03-11-2008, 09:52 AM   #5
wraithe
Member
 
Registered: Feb 2006
Location: australia
Distribution: Linux... :-)
Posts: 216
Blog Entries: 1

Rep: Reputation: 30
i had the same problem with sled 10, this was also a problem a few years back and i tried the methods i used then, but to no avail...
how i fixed the problem was to set ntp to a server and have had no problems since....
 
Old 03-11-2008, 09:55 AM   #6
sray_ju
LQ Newbie
 
Registered: Mar 2008
Posts: 3

Original Poster
Rep: Reputation: 0
Thanks for suggestions

Thanks to all who have given suggestions.

After removing the /etc/adjtime, reboot did maintain the correctly reset time. Thanks very much.

In reference to other queries/ suggestions : The timezone was already set right. And the difference in time did not correspond to the difference of local time with UTC. (it was not maintaining a constant difference either).

However one thing surprizes me. Why shouldn't the adjusted time keep track of time change done via YAST2 or shell command "date". If the superuser is
changing the date or time, it should reflect on subsequent reboot.

Thanking again.
 
  


Reply

Tags
opensuse102, timezone


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Command or grep to know system reboot time rockcharles1 Linux - General 2 10-05-2007 03:49 PM
Why does my system reboot every time i try.... Hdstdlxe Linux - Newbie 9 10-22-2005 04:31 AM
permissions reset on reboot trempel Fedora 11 08-18-2005 02:24 AM
won't boot or reboot without reset dcfnef Linux - General 4 04-04-2005 05:33 AM
Settings get reset on reboot xymian Debian 3 02-23-2005 04:53 AM


All times are GMT -5. The time now is 04:20 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration