LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 02-24-2006, 04:41 AM   #1
baddah
Member
 
Registered: Feb 2006
Location: Cape Town,South Africa
Distribution: Fedora Core 8
Posts: 183

Rep: Reputation: 30
time wrong after power failure


Hi

I have the following problem,After a power failure my machines time is off by 2 hours.I am not using UTC so according to me it should not adjust time according to daylight savings,etc.What could cause this,I am sure the time is correct before the power failure.Thanks for any help...

Last edited by baddah; 03-17-2006 at 12:24 AM.
 
Old 02-24-2006, 04:43 AM   #2
satinet
Senior Member
 
Registered: Feb 2004
Location: England
Distribution: Slackware 14.1
Posts: 1,469

Rep: Reputation: 46
which ditro are you using? mepis?

you can use the 'ntpdate' command to update the time to an appropriate time server. also check you regional settings...
 
Old 02-24-2006, 04:50 AM   #3
baddah
Member
 
Registered: Feb 2006
Location: Cape Town,South Africa
Distribution: Fedora Core 8
Posts: 183

Original Poster
Rep: Reputation: 30
I'm using FC3 kernel 2.6.12-1.1381_FC3 on that machine.I am updating time through ntpdate at 2:30 am through a cron job,but if the power fails before that the time will be wrong until then.It only happens on the one machine,the other machines time is still correct after power failure.My timezone is southfrica/Johannesburg so why will it change after the power failure?
 
Old 02-24-2006, 04:59 AM   #4
satinet
Senior Member
 
Registered: Feb 2004
Location: England
Distribution: Slackware 14.1
Posts: 1,469

Rep: Reputation: 46
it sounds like your CMOS battery has failed - your time is being forgetting by the hardware when you power off.

it looks like a large watch battery. try making some change to your bios and see if it's remembered.
 
Old 02-24-2006, 05:50 AM   #5
baddah
Member
 
Registered: Feb 2006
Location: Cape Town,South Africa
Distribution: Fedora Core 8
Posts: 183

Original Poster
Rep: Reputation: 30
Its a remote machine,so I'll check the battery later,but i'm pretty sure that's not the problem,because the machine is still pretty new,so thae battery should be fine.but thanks for your help.
 
Old 02-24-2006, 06:01 AM   #6
satinet
Senior Member
 
Registered: Feb 2004
Location: England
Distribution: Slackware 14.1
Posts: 1,469

Rep: Reputation: 46
so it keeps reseting to UTC?
 
Old 02-24-2006, 06:09 AM   #7
baddah
Member
 
Registered: Feb 2006
Location: Cape Town,South Africa
Distribution: Fedora Core 8
Posts: 183

Original Poster
Rep: Reputation: 30
It seems so yes,is there anything else that would cause the time to be set back by 2 hours?except a faulty battery.As i said i'm not using UTC,but still it seems to reset to it.very weird...
 
Old 02-24-2006, 06:11 AM   #8
corbintechboy
Member
 
Registered: Sep 2003
Location: Kentucky
Posts: 480
Blog Entries: 1

Rep: Reputation: 51
Could be updating with a time server over the net and have the wrong zone maybe?
 
Old 02-24-2006, 06:11 AM   #9
satinet
Senior Member
 
Registered: Feb 2004
Location: England
Distribution: Slackware 14.1
Posts: 1,469

Rep: Reputation: 46
yeah, it's not battery.

i don't know fedora and it's regional settings. but that seems to be the problem.

is there an /etc/timezone

???
 
Old 02-24-2006, 06:13 AM   #10
satinet
Senior Member
 
Registered: Feb 2004
Location: England
Distribution: Slackware 14.1
Posts: 1,469

Rep: Reputation: 46
anti - not if you have your time zone set correctly - it should adjust your time accordingly. try changing your timezone and doing an ntpdate.....
 
Old 02-24-2006, 06:20 AM   #11
baddah
Member
 
Registered: Feb 2006
Location: Cape Town,South Africa
Distribution: Fedora Core 8
Posts: 183

Original Poster
Rep: Reputation: 30
There's no /etc/timezone but there's a /etc/sysconfig/clock where you can change the timezone ,mine="Africa/Johannesburg", which is right,the UTC,mine is set to false,and ARC ,which i'm not to sure what it does but mine is false.

I am not updating time to any ntp server other than the ntpdate i run through a cron,so that shoul not be the problem as well...
 
Old 02-24-2006, 06:22 AM   #12
satinet
Senior Member
 
Registered: Feb 2004
Location: England
Distribution: Slackware 14.1
Posts: 1,469

Rep: Reputation: 46
Quote:
There's no /etc/timezone but there's a /etc/sysconfig/clock
cool. i've never used fedora so i dont know.

i thiunk that problem must lie in this area.

i live in UTC land though... :-D
 
Old 02-28-2006, 03:57 AM   #13
baddah
Member
 
Registered: Feb 2006
Location: Cape Town,South Africa
Distribution: Fedora Core 8
Posts: 183

Original Poster
Rep: Reputation: 30
Hallo again.I've "fixed" it by just running a ntpdate command when the system boots up again after a power failure,but in the background the time is still getting set back by two hours for some reason,i'm just setting it right again every time,so if someone knows what it might be please let me know,but i guess its fine as it is now...
 
Old 02-28-2006, 08:33 AM   #14
Dtsazza
Member
 
Registered: Oct 2005
Location: Oxford, UK
Distribution: Debian Etch (w/ dual-boot XP for gaming)
Posts: 282

Rep: Reputation: 30
Sounds a bit unlikely, but is the machine dual-boot by any chance? Windows handles daylight-savings differently to Linux, with the result that my Linux(/system) clock was put back (or forward, I forget which) an hour when I booted into Windows. The 'solution' was to disable Windows' "Automatically update the clock for daylight savings" thing, which I still think does it the wrong way. It did mean the time was an hour out in Windows though, which may or may not be appropriate for you (if it's even relevant).
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Various clock issues: Clock shows wrong time only in Knoppmyth, & CMOS time change ? davidbix General 1 04-05-2006 10:58 PM
fsck failure at boot time - hda mounted twice Steve2001 Linux - General 1 07-30-2005 11:45 AM
my time is wrong and calender is also wrong Paxmaster Linux - General 6 12-16-2004 01:46 AM
Setting System Time: kernel in wrong time zone warrenweiss Linux - General 7 05-15-2004 04:25 PM
Wrong Time RefriedBean LQ Suggestions & Feedback 14 08-16-2002 04:12 AM


All times are GMT -5. The time now is 02:31 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration