LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 12-15-2002, 06:44 AM   #1
MatchStick
LQ Newbie
 
Registered: Dec 2002
Distribution: RedHat 8.0
Posts: 12

Rep: Reputation: 0
Unhappy This is Unfair !


I have been reading about dual linux systems for about 2 days now, and I today I have started.

I have a 40gb Hard Drive, and I have a partition of 10GB that holds windows ME(primary). And an extended partition that is used to my programs.

1. I have made a partion out of the primary partion to hold Linux Redhat(3GB). I have Formatted it in windows.

2. I have ran the installation program, and Tried using the Automatic partitioning. I want to just use the 3GB to hold Linux. When I try to keep the existing partition is says, partion failed; could not allocate partitions as primary partitons.
and when I try to use manual partition using disk driud, it says you have not defined a root partition which is requied for installation of Red Hat.....

I havent got a clue what it is taking about ?!

What am I supposed to do to make a dual boot with WinME, and Red hat(in the 3GB partition)



Please help me, I have spent 5 hours trying to figure it out
 
Old 12-15-2002, 07:21 AM   #2
Bert
Senior Member
 
Registered: Jul 2001
Location: 406292E 290755N
Distribution: GNU/Linux Slackware 8.1, Redhat 8.0, LFS 4.0
Posts: 1,004

Rep: Reputation: 46
Hang on.

Delete the 3GB partition you formatted in Windows. Linux has it's own file partition system called ext2. Automatic partitioning is looking at the Windows formatted partition and thinking that Windows is on it.

BTW, you can read and write the WinMe partition from Linux, so I'd try and give it a little more room than 3GB - but that choice is yours. Ext2 is usually far more disk efficient than FAT32 and certainly more reliable.

I dual boot Redhat 8 and WinMe, and it works very smoothly.

Also - this is really important - buy a good book on Linux because it pays off in the long run

Bert
 
Old 12-15-2002, 07:31 AM   #3
pilot1
Member
 
Registered: Jun 2002
Location: USA
Distribution: Gentoo, Fedora Core
Posts: 408

Rep: Reputation: 30
Try deleting the 3gb partition and then under the automatic partitioning thing choosing to use unallocated space, which will make Linux partitions out of the 3gb that isn't made into a partition.
I would reccommend atleast 5gb space, and that's minimal, but again, it's you choice.
For a book I recommend the Red Hat Linux Bible if your running RH, it's very helpful, and I believe it's $35 off of amazon.com.
 
Old 12-15-2002, 08:32 AM   #4
MatchStick
LQ Newbie
 
Registered: Dec 2002
Distribution: RedHat 8.0
Posts: 12

Original Poster
Rep: Reputation: 0
Thanks for the replies, now how do I delete that 3 gb partition ?
 
Old 12-15-2002, 09:03 AM   #5
XavierP
Moderator
 
Registered: Nov 2002
Location: Kent, England
Distribution: Debian Testing
Posts: 19,192
Blog Entries: 4

Rep: Reputation: 470Reputation: 470Reputation: 470Reputation: 470Reputation: 470
use fdisk - if you haven't already, create a Windows startup disk and boot from that. Run FDisk and delete the partition. Reboot to check that you are now 3GB (or whatever) down and then boot from the RH disks.
 
Old 12-15-2002, 10:28 AM   #6
MatchStick
LQ Newbie
 
Registered: Dec 2002
Distribution: RedHat 8.0
Posts: 12

Original Poster
Rep: Reputation: 0
I tried what Xavier suggested. It still couldnt find any space in automatic partitioning. And in the Disk druid it has 3GB allocated that says "FREE SPACE" .

what should I do, It is still asking for the \root (what ever that is!)
 
Old 12-15-2002, 10:30 AM   #7
XavierP
Moderator
 
Registered: Nov 2002
Location: Kent, England
Distribution: Debian Testing
Posts: 19,192
Blog Entries: 4

Rep: Reputation: 470Reputation: 470Reputation: 470Reputation: 470Reputation: 470
Isn't there an option to select the partition (whether by clicking the partition's colour or by pointing to it)?
 
Old 12-15-2002, 11:42 AM   #8
MatchStick
LQ Newbie
 
Registered: Dec 2002
Distribution: RedHat 8.0
Posts: 12

Original Poster
Rep: Reputation: 0
I DID IT !!

I GOT IT WORKING, IT IS WORKING PERFECTLY ON DUAL BOOT.


the only problem is that When i have the options, WindowsME is called DOS ?!

how do I rename it ?
 
Old 12-15-2002, 11:52 AM   #9
XavierP
Moderator
 
Registered: Nov 2002
Location: Kent, England
Distribution: Debian Testing
Posts: 19,192
Blog Entries: 4

Rep: Reputation: 470Reputation: 470Reputation: 470Reputation: 470Reputation: 470
When you come to the 'install LILO or GRUB' as the bootloader, there should be an edit or customise portion - at that point you can change the names of the OS's to load.
 
Old 12-15-2002, 02:01 PM   #10
granny
Member
 
Registered: Nov 2002
Distribution: RH
Posts: 141

Rep: Reputation: 15
Do as Xavier says. If it doesn't give you the option to edit or customize portion to change the name of the OS, just edit, depending on which you install, lilo.conf or grub.conf. I would personally recommend using lilo. I have had problems dual booting with grub, but again, that's MY personal preference, even though grub is more powerful.
 
Old 12-15-2002, 02:10 PM   #11
MatchStick
LQ Newbie
 
Registered: Dec 2002
Distribution: RedHat 8.0
Posts: 12

Original Poster
Rep: Reputation: 0
I am using Grub, and At the time of installation, I didnt think you could do anything about it.

is there any way of changing it now ?



And, by the way,

First impressions of linux, im using KEMD interface.

It is alot slower than Windows ME.




BTW, im having problems trying to update,
When i try to use up2date thingy it says

Error Message:
Service not enabled for server profile: "AMD"
Error Class Code: 31
Error Class Info:
This server does not have a valid entitlement for Red Hat Network.
Please login at https://rhn.redhat.com/, and from the "Your RHN"
section, select "Entitlements" to enable RHN service for this server.
Explanation:
An error has occurred while processing your request. If this problem
persists please submit a bug report to rhn-help@redhat.com.
If you choose to submit the bug report, please be sure to include
details of what you were trying to do when this error occurred and
details on how to reproduce this problem.


whats it talking about ?
 
Old 12-15-2002, 02:17 PM   #12
Edward78
Member
 
Registered: Jul 2002
Distribution: OpenSuSE 11
Posts: 441

Rep: Reputation: 30
Ext3 is go Partiton Magick 8 can do EXT3 partitions. Linux can do its own patitions though. SuSE does good you can choose how you want them done or leave it alone it will do fine., only distro I use so I can't tell you how other distros do it.
 
Old 12-15-2002, 02:23 PM   #13
pilot1
Member
 
Registered: Jun 2002
Location: USA
Distribution: Gentoo, Fedora Core
Posts: 408

Rep: Reputation: 30
It's just saying your not signed up for Red Hat Network, which is basically RH's version of Windows Update.
You could try Gnome, I like it much better than KDE, but that's just my preference.
 
Old 12-15-2002, 02:40 PM   #14
MatchStick
LQ Newbie
 
Registered: Dec 2002
Distribution: RedHat 8.0
Posts: 12

Original Poster
Rep: Reputation: 0
Ive signed up, no luck yet.

I cant rename "dos" to windows after an install then ?



What is accualy good about Linux ?
I cant update my Graphic card drivers, or Enable 3d accelaration,
Its slower than windows, and it has a crap internet explorer !?!?

I havent tried in a home network server yet. Maybe 2moro...
 
Old 12-16-2002, 08:46 AM   #15
pilot1
Member
 
Registered: Jun 2002
Location: USA
Distribution: Gentoo, Fedora Core
Posts: 408

Rep: Reputation: 30
Internet Explorer is for Windows, and of course thats crap.
How much memmory are you using? Memmory tends to help speed up Linux more than proccessor speed, I run a P3 550mhz with 256mb RAM and it's much faster than Windows.
You can rename Dos to Windows, if your using grub simply type this on a command prompt "pico /boot/grub/grub.conf" and it should says something like "title dos" rename that to something like "title Windows".
There are a few web browsers to choose from in Linux, and your probably using Mozilla. If you don't like Mozilla try starting another one, like Galeon.
You really need to get a good book, that would explain most everything.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Unfair discrimination 10.1 Official > 10.1 Community???? ron_hickson Mandriva 3 06-05-2005 12:41 PM


All times are GMT -5. The time now is 11:33 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration