LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 03-09-2003, 01:30 PM   #1
Z28kid
Member
 
Registered: Jan 2003
Location: Long Island
Posts: 72

Rep: Reputation: 15
This is so annoying please help...


If i start up linux without cable moderm connected. Everything starts up fine with localhost@localdomain or whatever it is.

But once i start it with the internet connected it changes to
"dhcp-32-5614" what is this?

It does not allow my webserver to start or to use the internet.

I looked in error for httpd and it said something about can't find ip address..

im stumped any help..
 
Old 03-09-2003, 02:23 PM   #2
case1984
Member
 
Registered: Feb 2003
Location: Baton Rouge, LA
Distribution: ubuntu
Posts: 137

Rep: Reputation: 15
Ok, I'm a complete newbie, but I'll try and help...
dhcp stands for dynamic host configuration protocol, or something like that. Look in your network settings and make sure you have dhcp turned on (since you have a cable modem, I'm assuming your isp uses dhcp - most cable isp co. do).
Next, write back and tell us what distro you are using, and what exactly changes from "localhost" to "dhcp-32-5614,"
 
Old 03-09-2003, 02:59 PM   #3
Z28kid
Member
 
Registered: Jan 2003
Location: Long Island
Posts: 72

Original Poster
Rep: Reputation: 15
when i log in as a user. after i am in i get prompted with:

"could not look up internet address for dhcp-32-5614. This will prevent gnome from operating correctly. it may be possible to correct the problem by adding dhcp-31-5614 to hosts.

Then i get 2 options to 1. log in anyway and try again.

try again never works so i just always log in anyway.

Im sure dhcp is turned on. I run redhat 8.0 and i honstley have no clue what changes. from local host to dhcp-32-5614
 
Old 03-09-2003, 04:04 PM   #4
Dark_Helmet
Senior Member
 
Registered: Jan 2003
Posts: 2,786

Rep: Reputation: 369Reputation: 369Reputation: 369Reputation: 369
Continue to boot when Gnome comes up with that message. Then, from the Red Hat menu, select System tools -> Network device control

It will ask for root's password, and then show a new window (Network Device Control). Highlight the line of the network card you want to mess with. If you only have one, it should already be highlighted. Click the Configure button on the right. Another window pops up (Network Configuration). Click the DNS tab. In the Hostname box, type in what you want your computer to be named (something like Neo, Frodo, Z28kid, or whatever you want). Now, go back to the devices tab. Click the Edit button on the right. Again, a new window pops up (Ethernet Device). Make sure "Activate device when computer starts" is checked. Also, verify that you have "Automatically obtain IP address settings with" selected, and that "dhcp" is listed in the box on the right.

Now go through each window and hit Apply (if there is an apply button, of course), and then the Close button. Now, you need to edit a file. Open up your /etc/hosts file. Look for a line like this:
127.0.0.1 localhost.localdomain localhost

It may have other stuff on it. Add the name you chose earlier for the Hostname to this file. In other words, the line should change to look like so:
127.0.1 Z28kid localhost.localdomain localhost

Then try rebooting your computer.
 
Old 03-09-2003, 10:28 PM   #5
Z28kid
Member
 
Registered: Jan 2003
Location: Long Island
Posts: 72

Original Poster
Rep: Reputation: 15
i did all the stuff.

But when i try to look at /etc/hosts

it says permission denied even when i am root.

what do i do?
 
Old 03-09-2003, 11:25 PM   #6
Dark_Helmet
Senior Member
 
Registered: Jan 2003
Posts: 2,786

Rep: Reputation: 369Reputation: 369Reputation: 369Reputation: 369
Here's a walk-through using emacs from a terminal to edit the file:

1) su -
2) <enter root's password>
3) emacs /etc/hosts
4) Use the arrow keys, backspace, and the other keys should all work basically like they would in windows notepad, word, etc.
5) when the file is how you like it, hold down the control button
6) with control held down type the letter "s" (saves the file)
7) then, again with control held down, type these two letters "xc" (closes emacs)
8) type "exit" to give up root access

As a side note, typing su at the prompt only makes you root in that terminal; it doesn't change the gnome environment. Similarly, when you are asked for authorization and get the keys on the panel, you still are not root; you have temporary access as root. It's a little difficult to explain, and I don't think I'm doing a very good job of it. Give that walk-through a try and let us know how it goes.
 
Old 03-10-2003, 02:05 PM   #7
Z28kid
Member
 
Registered: Jan 2003
Location: Long Island
Posts: 72

Original Poster
Rep: Reputation: 15
well it didn't work. I even reinstalled redhat and it does the same thing. Only when it is connected to the internet it doesn't let me on the net and on start up the httpd fails.


any ideas why?
 
Old 03-10-2003, 03:23 PM   #8
Z28kid
Member
 
Registered: Jan 2003
Location: Long Island
Posts: 72

Original Poster
Rep: Reputation: 15
i just found this out. With the ethernet cable in the computer but no connected to the cable modem it still makes httpd fail and it says cannot look up interent address. But if I unplug the cable it starts up find on local host.
 
Old 03-10-2003, 03:54 PM   #9
Z28kid
Member
 
Registered: Jan 2003
Location: Long Island
Posts: 72

Original Poster
Rep: Reputation: 15
did a search and found the answers.

Thanks to all those that helped!!!!!!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
how annoying php Linux - Distributions 9 01-05-2007 09:42 PM
Very annoying: ^M King4lex Linux - General 4 08-25-2005 08:39 PM
fortunes getting annoying nny0000 Slackware 4 02-25-2004 01:55 PM
very annoying/browser wr3ck3d Linux - Software 7 04-16-2003 05:57 PM
Really annoying Bigun Linux - General 6 09-15-2002 05:31 PM


All times are GMT -5. The time now is 05:19 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration