LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 05-13-2016, 01:01 AM   #1
Lanex
LQ Newbie
 
Registered: Oct 2015
Posts: 8

Rep: Reputation: Disabled
There no public key available for the following key IDs: 1397BC53640DB551


I have received multiple error messages:

[refresh update manager] message:
W: There no public key available for the following key IDs:
1397BC53640DB551
same message from Synaptic Package Manager

also:
QuadCore ~ $ gksudo nemo
Initializing folder-color-switcher extension...

(nemo:13122): Gtk-CRITICAL **: gtk_tree_model_filter_convert_iter_to_child_iter: assertion 'filter_iter->stamp == filter->priv->stamp' failed

(nemo:13122): Gtk-CRITICAL **: gtk_tree_store_set_valist: assertion 'VALID_ITER (iter, tree_store)' failed

and

QuadCore ~ $ exo-preferred-applications
(exo-helper-1:1977): Gdk-CRITICAL **: IA__gdk_window_get_window_type: assertion 'GDK_IS_WINDOW (window)' failed
(exo-helper-1:1977): Gdk-CRITICAL **: IA__gdk_window_get_window_type: assertion 'GDK_IS_WINDOW (window)' failed

[I'm sure the above is either Greek or Martian]

My computer info:

Linux Mint 17.2 Cinnamon 64-bit
Cinnamon Version 2.6.13
Linux Kernel 3.16.0-38 generic
Processor Intel Core 2 Quad CPU Q9550 @ 2.83 GHz X4
Memory 5.8 GB
Hard Drive 1047.3 GB
Graphics Card Intel 82G33/G31 Express Integrated Graphics Controller

Is this the Linux way of telling me I should do a fresh install?
 
Old 05-13-2016, 01:37 AM   #2
Ztcoracat
LQ Guru
 
Registered: Dec 2011
Distribution: Slackware
Posts: 6,830
Blog Entries: 7

Rep: Reputation: Disabled
Hi:

Looks like you might need a keyring:- Instead of the word debian type in the work ubuntu.
http://devget.net/linux/how-to-fix-n...ids-in-debian/

Code:
sudo apt-get install ubuntu-keyring
Quote:
I'm sure the above is either Greek or Martian
LOL-

Quote:
Is this the Linux way of telling me I should do a fresh install?
In some cases yes.
Can you update your Mint?
 
2 members found this post helpful.
Old 05-13-2016, 05:54 PM   #3
sgosnell
Senior Member
 
Registered: Jan 2008
Location: Baja Oklahoma
Distribution: Debian
Posts: 1,054

Rep: Reputation: 276Reputation: 276Reputation: 276
Those errors are not uncommon when running a GUI program from the terminal. As long as the program runs, you can just ignore it. It's all plain English, just with rather cryptic program names. It's Linux's way of telling you what is happening, and there is no need for a fresh install.
 
Old 05-13-2016, 06:18 PM   #4
Habitual
LQ Addict
 
Registered: Jan 2011
Location: Youngstown, Ohio
Distribution: LM17.1/Xfce4.11.8
Posts: 7,668
Blog Entries: 10

Rep: Reputation: 2077Reputation: 2077Reputation: 2077Reputation: 2077Reputation: 2077Reputation: 2077Reputation: 2077Reputation: 2077Reputation: 2077Reputation: 2077Reputation: 2077
Close Synaptic if it's open.
Close Software Manager if it's open.
Close Aptitude if it's open.
Open a terminal and issue:
Code:
sudo apt-key adv --keyserver keys.gnupg.net --recv-keys 1397BC53640DB551
You have to accept the apt-key import!
Then run
Code:
sudo apt-get update
and all the GUI scary messages should be gone.

Last edited by Habitual; 05-13-2016 at 06:24 PM.
 
1 members found this post helpful.
Old 05-13-2016, 07:28 PM   #5
Ztcoracat
LQ Guru
 
Registered: Dec 2011
Distribution: Slackware
Posts: 6,830
Blog Entries: 7

Rep: Reputation: Disabled
What did you launch from the konsole?
 
Old 05-13-2016, 07:34 PM   #6
Ztcoracat
LQ Guru
 
Registered: Dec 2011
Distribution: Slackware
Posts: 6,830
Blog Entries: 7

Rep: Reputation: Disabled
Quote:
and all the GUI scary messages should be gone.
LOL; it's Friday the 13th.
 
Old 05-14-2016, 09:34 PM   #7
Lanex
LQ Newbie
 
Registered: Oct 2015
Posts: 8

Original Poster
Rep: Reputation: Disabled
Talking

Quote:
Originally Posted by Ztcoracat View Post
Hi:

Looks like you might need a keyring:- Instead of the word debian type in the work ubuntu.
http://devget.net/linux/how-to-fix-n...ids-in-debian/

Code:
sudo apt-get install ubuntu-keyring

LOL-


In some cases yes.
Can you update your Mint?











well, I couldn't 3 days ago and yesterday I did; except for the pubic key XXX I mean the public key thing.
 
1 members found this post helpful.
Old 05-14-2016, 09:44 PM   #8
Ztcoracat
LQ Guru
 
Registered: Dec 2011
Distribution: Slackware
Posts: 6,830
Blog Entries: 7

Rep: Reputation: Disabled
Quote:
Originally Posted by Lanex View Post
well, I couldn't 3 days ago and yesterday I did; except for the pubic key XXX I mean the public key thing.
Glad to hear you can update your system. That's a good sign.

Run the commands Habitual posted for you. That should put a stop to the greek and martian stuff.
 
Old 05-14-2016, 10:27 PM   #9
PedroNavarro
LQ Newbie
 
Registered: May 2016
Posts: 1

Rep: Reputation: Disabled
Hi, im new here.
 
Old 05-14-2016, 10:55 PM   #10
Ztcoracat
LQ Guru
 
Registered: Dec 2011
Distribution: Slackware
Posts: 6,830
Blog Entries: 7

Rep: Reputation: Disabled
Quote:
Originally Posted by PedroNavarro View Post
Hi, im new here.
Hi & Welcome to the LQ Forums-

If you have questions you should start a fresh thread.
 
Old 05-15-2016, 02:27 PM   #11
ondoho
Senior Member
 
Registered: Dec 2013
Posts: 4,620

Rep: Reputation: 984Reputation: 984Reputation: 984Reputation: 984Reputation: 984Reputation: 984Reputation: 984Reputation: 984
Quote:
Originally Posted by Ztcoracat View Post
Run the commands Habitual posted for you. That should put a stop to the greek and martian stuff.
it certainly won't put an end to gtk and gdk critical warnings/errors.
those just seem to be part of the experience.
 
Old 05-16-2016, 10:38 AM   #12
Ztcoracat
LQ Guru
 
Registered: Dec 2011
Distribution: Slackware
Posts: 6,830
Blog Entries: 7

Rep: Reputation: Disabled
Quote:
Originally Posted by ondoho View Post
it certainly won't put an end to gtk and gdk critical warnings/errors.
those just seem to be part of the experience.
How come it won't put an end to the gtk and gdk warnings?

I'm wondering because when I checked on FF it's gave me the the CRITICAl warning/error as well.
Code:
bash-4.2$ firefox --version

(process:6882): GLib-CRITICAL **: g_slice_set_config: assertion `sys_page_size == 0' failed
 
Old 05-18-2016, 03:23 PM   #13
ondoho
Senior Member
 
Registered: Dec 2013
Posts: 4,620

Rep: Reputation: 984Reputation: 984Reputation: 984Reputation: 984Reputation: 984Reputation: 984Reputation: 984Reputation: 984
Quote:
Originally Posted by Ztcoracat View Post
How come it won't put an end to the gtk and gdk warnings?
I'm wondering because when I checked on FF it's gave me the the CRITICAl warning/error as well.
honestly i don't know, but i've been seeing these error messages ever since i started using linux and it never had any consequence whatsoever on the functionality of the program.
i think using certain (outdated) gtk themes creates a whole lot more of these messages.

btw,
your error message looks a little different, it's glib. OP posted gtk and gdk errors, and those are definitely UI/graphics related.

Last edited by ondoho; 05-18-2016 at 03:25 PM.
 
Old 05-18-2016, 09:31 PM   #14
Ztcoracat
LQ Guru
 
Registered: Dec 2011
Distribution: Slackware
Posts: 6,830
Blog Entries: 7

Rep: Reputation: Disabled
Might be old libraries too along with outdated gtk themes:-

Code:
 OP posted gtk and gdk errors, and those are definitely UI/graphics related.
Agreed-

I still would like to know what OP launched from the konsole that generated the error.
In a previous post I asked what he launched but he hasn't answered yet.
 
Old 05-19-2016, 02:08 AM   #15
Lanex
LQ Newbie
 
Registered: Oct 2015
Posts: 8

Original Poster
Rep: Reputation: Disabled
Unhappy No public key

Quote:
Originally Posted by Habitual View Post
Close Synaptic if it's open.
Close Software Manager if it's open.
Close Aptitude if it's open.
Open a terminal and issue:
Code:
sudo apt-key adv --keyserver keys.gnupg.net --recv-keys 1397BC53640DB551
You have to accept the apt-key import!
Then run
Code:
sudo apt-get update
and all the GUI scary messages should be gone.
"Windows assumes you're a dumb-ass.
Linux demands you prove it. I think I'm over half way there

QuadCore ~ $ sudo apt-key adv --keyserver keyserver.ubuntu.com --recv-keys 1397BC53640DB551
[sudo] password for lanex:
Executing: gpg --ignore-time-conflict --no-options --no-default-keyring --homedir /tmp/tmp.tr4p9N4fiV --no-auto-check-trustdb --trust-model always --keyring /etc/apt/trusted.gpg --primary-keyring /etc/apt/trusted.gpg --keyring /etc/apt/trusted.gpg.d/debian-archive-squeeze-automatic.gpg --keyring /etc/apt/trusted.gpg.d/debian-archive-squeeze-stable.gpg --keyring /etc/apt/trusted.gpg.d/debian-archive-wheezy-automatic.gpg --keyring /etc/apt/trusted.gpg.d/debian-archive-wheezy-stable.gpg --keyserver keyserver.ubuntu.com --recv-keys 1397BC53640DB551
gpg: requesting key 640DB551 from hkp server keyserver.ubuntu.com
gpg: key D38B4796: "Google Inc. (Linux Packages Signing Authority) <linux-packages-keymaster@google.com>" not changed
gpg: Total number processed: 1
gpg: unchanged: 1
lanex@QuadCore ~ $ sudo apt-key adv --keyserver keys.gnupg.net --recv-keys 1397BC53640DB551
Executing: gpg --ignore-time-conflict --no-options --no-default-keyring --homedir /tmp/tmp.TbVRmjAYBl --no-auto-check-trustdb --trust-model always --keyring /etc/apt/trusted.gpg --primary-keyring /etc/apt/trusted.gpg --keyring /etc/apt/trusted.gpg.d/debian-archive-squeeze-automatic.gpg --keyring /etc/apt/trusted.gpg.d/debian-archive-squeeze-stable.gpg --keyring /etc/apt/trusted.gpg.d/debian-archive-wheezy-automatic.gpg --keyring /etc/apt/trusted.gpg.d/debian-archive-wheezy-stable.gpg --keyserver keys.gnupg.net --recv-keys 1397BC53640DB551
gpg: requesting key 640DB551 from hkp server keys.gnupg.net
gpg: key D38B4796: "Google Inc. (Linux Packages Signing Authority) <linux-packages-keymaster@google.com>" not changed
gpg: Total number processed: 1
gpg: unchanged: 1

After reading the above I still didn't have a key. I cringed at the thought of asking you how again so I googled "how to accept the apt-key import mint 17.2" and that took me to https://mintguide.org/other/440-how-...inux-mint.html

I tried the first two suggestions:

QuadCore ~ $ sudo apt-key adv --keyserver keyserver.ubuntu.com --recv-keys 1397BC53640DB551
[sudo] password for lanex:
Executing: gpg --ignore-time-conflict --no-options --no-default-keyring --homedir /tmp/tmp.09H8jdIfPp --no-auto-check-trustdb --trust-model always --keyring /etc/apt/trusted.gpg --primary-keyring /etc/apt/trusted.gpg --keyring /etc/apt/trusted.gpg.d/debian-archive-squeeze-automatic.gpg --keyring /etc/apt/trusted.gpg.d/debian-archive-squeeze-stable.gpg --keyring /etc/apt/trusted.gpg.d/debian-archive-wheezy-automatic.gpg --keyring /etc/apt/trusted.gpg.d/debian-archive-wheezy-stable.gpg --keyserver keyserver.ubuntu.com --recv-keys 1397BC53640DB551
gpg: requesting key 640DB551 from hkp server keyserver.ubuntu.com
gpg: key D38B4796: "Google Inc. (Linux Packages Signing Authority) <linux-packages-keymaster@google.com>" not changed
gpg: Total number processed: 1
gpg: unchanged: 1
lanex@QuadCore ~ $ sudo apt-key adv --recv-keys --keyserver keyserver.ubuntu.com `sudo apt-get update 2>&1 | grep -o '[0-9A-Z]\{16\}$' | xargs`

Executing: gpg --ignore-time-conflict --no-options --no-default-keyring --homedir /tmp/tmp.hEzN0wr81d --no-auto-check-trustdb --trust-model always --keyring /etc/apt/trusted.gpg --primary-keyring /etc/apt/trusted.gpg --keyring /etc/apt/trusted.gpg.d/debian-archive-squeeze-automatic.gpg --keyring /etc/apt/trusted.gpg.d/debian-archive-squeeze-stable.gpg --keyring /etc/apt/trusted.gpg.d/debian-archive-wheezy-automatic.gpg --keyring /etc/apt/trusted.gpg.d/debian-archive-wheezy-stable.gpg --recv-keys --keyserver keyserver.ubuntu.com

The next time I booted up I found the window asking for my key ring p/w. I am beginning to think it would have been quicker to do a fresh install; IF it would eliminate the problem.

Last edited by Lanex; 05-19-2016 at 02:11 AM. Reason: I have to get up in the morning, I'm going to bed.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
SSH skips public key authentication for a key, but works with another key simopal6 Linux - General 1 07-06-2011 09:33 AM
Putty/SSH login failed when using RSA public key: 'Server refused our key' itsecx@gmail.com Linux - Server 10 10-04-2010 02:19 PM
Revoking GPG key with only passphrase and public key djib Linux - Security 2 03-13-2007 04:20 AM
GPG Data, Secret Key but no Public Key? Aeiri Linux - Software 5 07-20-2004 07:00 PM
RSA public key encryption/private key decription koningshoed Linux - Security 1 08-08-2002 08:25 AM


All times are GMT -5. The time now is 08:23 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration