LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (http://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   There is not enough room on the disk to save to /tmp ????? (http://www.linuxquestions.org/questions/linux-newbie-8/there-is-not-enough-room-on-the-disk-to-save-to-tmp-619980/)

449 02-09-2008 05:21 PM

There is not enough room on the disk to save to /tmp ?????
 
I'm getting this message when I try to save a download. I tried deleting files from there ,but that didn't help.

Earlier I tried things like deleting all the trash items(There was a lot of files there, but that still didn't free anything up.

I have my /home partition on a separate.

I'm running Debian testing.

http://i27.tinypic.com/9qfuix.png

lazlow 02-09-2008 05:31 PM

If your /home is on a separate partition, deleting stuff from it (emptying trash) is not going to help. You probably made your / partition to small. Most of the stuff you install will be stored in / or one of its subs. You might want to look at your logs. If you have a log message that is repeated every couple of minutes you can eat up a couple if gigs pretty fast.

449 02-09-2008 05:32 PM

Quote:

Originally Posted by lazlow (Post 3051840)
If your /home is on a separate partition, deleting stuff from it (emptying trash) is not going to help. You probably made your / partition to small. Most of the stuff you install will be stored in / or one of its subs. You might want to look at your logs. If you have a log message that is repeated every couple of minutes you can eat up a couple if gigs pretty fast.

Where are log files kept? What do you recommend I do?

449 02-09-2008 05:35 PM

Also when I try to gksu konqueror, it gives me this mess:
Code:

GConf Error: Failed to contact configuration server; some possible causes are that you need to enable TCP/IP networking for ORBit, or you have stale NFS locks due to a system crash. See http://www.gnome.org/projects/gconf/ for information. (Details -  1: IOR file '/tmp/gconfd-erik/lock/ior' not opened successfully, no gconfd located: No such file or directory 2: IOR file '/tmp/gconfd-erik/lock/ior' not opened successfully, no gconfd located: No such file or directory)
GConf Error: Failed to contact configuration server; some possible causes are that you need to enable TCP/IP networking for ORBit, or you have stale NFS locks due to a system crash. See http://www.gnome.org/projects/gconf/ for information. (Details -  1: IOR file '/tmp/gconfd-erik/lock/ior' not opened successfully, no gconfd located: No such file or directory 2: IOR file '/tmp/gconfd-erik/lock/ior' not opened successfully, no gconfd located: No such file or directory)
GConf Error: Failed to contact configuration server; some possible causes are that you need to enable TCP/IP networking for ORBit, or you have stale NFS locks due to a system crash. See http://www.gnome.org/projects/gconf/ for information. (Details -  1: IOR file '/tmp/gconfd-erik/lock/ior' not opened successfully, no gconfd located: No such file or directory 2: IOR file '/tmp/gconfd-erik/lock/ior' not opened successfully, no gconfd located: No such file or directory)
GConf Error: Failed to contact configuration server; some possible causes are that you need to enable TCP/IP networking for ORBit, or you have stale NFS locks due to a system crash. See http://www.gnome.org/projects/gconf/ for information. (Details -  1: IOR file '/tmp/gconfd-erik/lock/ior' not opened successfully, no gconfd located: No such file or directory 2: IOR file '/tmp/gconfd-erik/lock/ior' not opened successfully, no gconfd located: No such file or directory)
GConf Error: Failed to contact configuration server; some possible causes are that you need to enable TCP/IP networking for ORBit, or you have stale NFS locks due to a system crash. See http://www.gnome.org/projects/gconf/ for information. (Details -  1: IOR file '/tmp/gconfd-erik/lock/ior' not opened successfully, no gconfd located: No such file or directory 2: IOR file '/tmp/gconfd-erik/lock/ior' not opened successfully, no gconfd located: No such file or directory)
GConf Error: Failed to contact configuration server; some possible causes are that you need to enable TCP/IP networking for ORBit, or you have stale NFS locks due to a system crash. See http://www.gnome.org/projects/gconf/ for information. (Details -  1: IOR file '/tmp/gconfd-erik/lock/ior' not opened successfully, no gconfd located: No such file or directory 2: IOR file '/tmp/gconfd-erik/lock/ior' not opened successfully, no gconfd located: No such file or directory)
GConf Error: Failed to contact configuration server; some possible causes are that you need to enable TCP/IP networking for ORBit, or you have stale NFS locks due to a system crash. See http://www.gnome.org/projects/gconf/ for information. (Details -  1: IOR file '/tmp/gconfd-erik/lock/ior' not opened successfully, no gconfd located: No such file or directory 2: IOR file '/tmp/gconfd-erik/lock/ior' not opened successfully, no gconfd located: No such file or directory)
Xlib: connection to ":0.0" refused by server
Xlib: No protocol specified




Also Synaptic won't open...

lazlow 02-09-2008 05:35 PM

I do not run Debian but you could start with "locate log |less". There are a lot of logs on a system.

AwesomeMachine 02-09-2008 06:45 PM

Run 'df -h' and check available drive space. Then you'll know where to start looking.

kernc 05-25-2012 08:30 PM

raising this old thread is very relevant, since it's a high-SERP result and yet unsolved.

the problem is, tmpfs mounted on /tmp runs out of space
Code:

$ df -H
Filesystem                                              Size  Used Avail Use% Mounted on
rootfs                                                  25G  12G  13G  49% /
udev                                                    2.2G    0  2.2G  0% /dev
/dev/disk/by-uuid/6d234972-d4bf-4b21-ac08-0882e7f20827  25G  12G  13G  49% /
tmpfs                                                  424M  1.1M  423M  1% /var/run
tmpfs                                                  5.3M    0  5.3M  0% /var/run/lock
tmpfs                                                  848M  848M    0M 100% /tmp
tmpfs                                                  848M  1.3M  847M  1% /var/run/shm
/dev/sda2                                                30G  19G  9.5G  67% /home
/dev/sda3                                                99G  75G  20G  80% /mount/point

after running the recommended /tmp tmpfs increase command, df shows
Code:

$ df -H
Filesystem                                              Size  Used Avail Use% Mounted on
rootfs                                                  25G  12G  13G  49% /
udev                                                    2.2G    0  2.2G  0% /dev
/dev/disk/by-uuid/6d234972-d4bf-4b21-ac08-0882e7f20827  25G  12G  13G  49% /
tmpfs                                                  424M  1.1M  423M  1% /var/run
tmpfs                                                  5.3M    0  5.3M  0% /var/run/lock
tmpfs                                                  2.1G  850M  1.3G  39% /tmp
tmpfs                                                  848M  1.3M  847M  1% /var/run/shm
/dev/sda2                                                30G  19G  9.5G  67% /home
/dev/sda3                                                99G  75G  20G  80% /mount/point

and whatever wasn't before now works again.

now, that is only part of the solution. :)

what if one wants to permanently increase the size of /tmp's tmpfs?
where is /tmp mountpoint with tmpfs configured?
it is present in /etc/mtab
Code:

$ grep '/tmp' /etc/mtab
tmpfs /tmp tmpfs rw,relatime,size=827724k 0 0

but I checked my /etc/fstab, and it ain't there, so where is it?

in short, my question is, how, besides using a rc.local or similar script to issue above-linked command, do I permanently (sustaining reboot) increase /tmp's allocated size?

gnunandakumar 05-26-2012 07:45 AM

* There may be hidden files in /tmp. Try deleting them after Ctrl+H or View -> Show Hidden Files.
* There are many unwanted files in /var (mainly, /var/cache)
* log files are kept in /var/log

Hope these are useful.

kernc 05-27-2012 08:37 AM

your missing my question made me search a little more. :)
supposedly, this is the solution:

on Debian-based systems, one ensures he has RAMTMP=yes in /etc/default/rcS and sets TMP_SIZE=2G in /etc/default/tmpfs. however, since /etc/default/tmpfs is deprecated, a new /etc/fstab line is preferred instead.
Code:

tmpfs  /tmp  tmpfs  nodev,nosuid,size=20%,mode=1777  0  0


All times are GMT -5. The time now is 11:12 PM.