LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 01-03-2009, 04:22 PM   #1
MooseMagnet
Member
 
Registered: Oct 2007
Location: U.S.
Distribution: Ubuntu 14.04
Posts: 183
Blog Entries: 1

Rep: Reputation: 15
There is no "Input Device" section in xorg.conf


I'm trying to set SHMConfig to 'true' in /etc/X11/xorg.conf

I have done this before to enable the gsynaptics touchpad tool.

This morning I did a clean Ubuntu Intrepid install, was previously using Ubuntu Feisty.

But there is no "input device" section in my xorg.conf

Here is the contents of xorg.conf

----------------------------------
Section "Device"
Identifier "Configured Video Device"
EndSection

Section "Monitor"
Identifier "Configured Monitor"
EndSection

Section "Screen"
Identifier "Default Screen"
Monitor "Configured Monitor"
Device "Configured Video Device"
EndSection

----------------------------------
I followed these instructions,
https://help.ubuntu.com/community/Sy...hpad#shmconfig
but all it did was make my screen display more detailed and fancy.

How can I set SHMConfig to 'true' so that I can use gsynaptics?

I'm using a Dell Inspiron laptop, and I've used gsynaptics with Dapper and Feisty.

thanks
 
Old 01-03-2009, 04:49 PM   #2
MoonMind
Member
 
Registered: May 2005
Location: Switzerland
Distribution: Ubuntu
Posts: 448

Rep: Reputation: 38
That's because most of hardware recognition is handled by other tools now. It's a bit of a nuisance sometimes - I like the old configuration files better, too. But you may want to try sudo dpkg-reconfigure xserver-xorg - you'll get a little further that way. And of course, you can always try and add the relevant section to /etc/X11/xorg.conf by hand.

M.
 
Old 01-03-2009, 04:56 PM   #3
MooseMagnet
Member
 
Registered: Oct 2007
Location: U.S.
Distribution: Ubuntu 14.04
Posts: 183
Blog Entries: 1

Original Poster
Rep: Reputation: 15
Yup. I got it now. Thank you.

What I needed to do was issue this:

sudo /etc/init.d/hal restart

When the /hal instructions told me to restart, I thought they meant 'just' restart the machine. LOL

Thank you.
 
Old 01-03-2009, 05:35 PM   #4
MoonMind
Member
 
Registered: May 2005
Location: Switzerland
Distribution: Ubuntu
Posts: 448

Rep: Reputation: 38
No big deal - you found the solution yourself

In fact, I should've been more precise; the information is here: https://wiki.ubuntu.com/X/Config/Input - but that's only part of the story. At least it's documented to the fullest - but compared to former procedures, it's pretty complicated. There's got to be a reason for that (probably better overall performance), but if things don't work, it can be tedious to say the least.

M.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
A little help with getting Option "Rotate" to work in xorg.conf phagocytosis Linux - General 1 12-29-2008 01:56 PM
Problems configuring "xorg.conf" with "ATI FGLRX" BlueSpirit Slackware 3 09-16-2006 02:01 PM
Permission Denied when trying as "root" to edit xorg.conf d3g@ Linux - Newbie 4 09-07-2006 05:19 PM
"nv" to "nvidia" in xorg.conf causes X not to start jon2kx Ubuntu 10 09-05-2006 08:36 PM
How do you run "xorg.conf.back" file? in Toshiba laptop hajime_saitou0 Linux - Laptop and Netbook 1 09-14-2005 09:03 PM


All times are GMT -5. The time now is 05:23 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration