LinuxQuestions.org
Latest LQ Deal: Complete CCNA, CCNP & Red Hat Certification Training Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 01-31-2013, 01:10 AM   #1
rabiticide
Member
 
Registered: Dec 2008
Posts: 42

Rep: Reputation: 15
there is no "d" in VNC


this is a weird issue I'm having: I sit on my windows 8 laptop and I VNC into my Mint/Cinnamon desktop with tigervnc viewer and tightvnc server. Everything kinda work except whenever I type the letter "d" it doesn't come up in whatever I'm typing but instead shows me the desktop and typing "d" again toggles back to whatever I was doing. I basically don't even know where to look for the problem. Is it in the Cinnamon? or the vncserver?


thanks
 
Old 01-31-2013, 09:09 AM   #2
rtmistler
Moderator
 
Registered: Mar 2011
Location: Sutton, MA. USA
Distribution: MINT Debian, Angstrom, SUSE, Ubuntu
Posts: 4,087
Blog Entries: 10

Rep: Reputation: 1521Reputation: 1521Reputation: 1521Reputation: 1521Reputation: 1521Reputation: 1521Reputation: 1521Reputation: 1521Reputation: 1521Reputation: 1521Reputation: 1521
Sounds like there's something wrong with a hotkey mapping and "d" is mapped to an action. I'd look in vnc client for that.

Or try an alternate VNC viewer.

http://<br /> http://www.realvnc.co...839.html<br />
 
Old 01-31-2013, 10:22 AM   #3
shivaa
Senior Member
 
Registered: Jul 2012
Location: Grenoble, Fr.
Distribution: Sun Solaris, RHEL, Ubuntu, Debian 6.0
Posts: 1,800
Blog Entries: 4

Rep: Reputation: 286Reputation: 286Reputation: 286
I had been faced similar issues with VNC a long time ago, so as far as I remember, it might be because of a currupt profile.
For a trial, you can move config file (either .bashrc or .cshrc) and generate a new one.
Code:
~$ move .bashrc .bashrc.bck
~$ cp /path/to/newfile ~/
~$ source .bashrc
And try typing d. In case if it do not help, restore the file,
Code:
~$ mv .bashrc.bck .bashrc

Last edited by shivaa; 01-31-2013 at 10:23 AM.
 
Old 01-31-2013, 12:10 PM   #4
lykwydchykyn
Member
 
Registered: Mar 2006
Location: Tennessee, USA
Distribution: Debian, Ubuntu
Posts: 135

Rep: Reputation: 36
I get problems like this when keys like ctrl, alt, or the "windows key" get virtually "stuck"; for some reason the remote host thinks these keys are down, and the result is that you start triggering hotkey combos in the remote system.

Try hitting the modifier keys when this problem happens and see if it goes away.
 
Old 01-31-2013, 11:05 PM   #5
Kallaste
Member
 
Registered: Nov 2011
Distribution: Slackware
Posts: 347

Rep: Reputation: 85
I think this is a VNC keybindings issue. Try going to 'System' > 'Preferences' > 'Keyboard Shortcuts,' and set the "Hide all normal windows and set focus to desktop" to something other than 'D.'

Also, I think if you want to type a D before you find the right setting, you can do so by holding down Alt.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
The "Applications, Places, System " menu in vnc viewer is missing. lsfw07 Linux - Newbie 4 12-30-2009 03:38 AM
Issue with vnc server "tightVNC: VNC server closed connection", due to Screensaver frenchn00b General 1 07-30-2009 07:55 AM
freenx (with vnc to get to display 0) "Opening password file failed" javaunixsolaris Linux - General 0 02-02-2009 04:46 PM
LXer: Displaying "MyComputer", "Trash", "Network Servers" Icons On A GNOME Desktop LXer Syndicated Linux News 0 04-02-2007 09:31 AM
"ftp: u: unknown option" when script runs through VNC viewer Fillys6 Linux - Networking 7 12-22-2005 08:11 PM


All times are GMT -5. The time now is 10:43 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration