LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 03-02-2012, 12:12 PM   #1
l8tr
LQ Newbie
 
Registered: Mar 2012
Location: Oregon
Distribution: Ubuntu 11.04
Posts: 5

Rep: Reputation: Disabled
Unhappy "The trash has reached its maximum size" in Ubuntu 11.04


I am using Ubuntu 11.04. After I burned a disk in K3b, I tried to move a file to Trash from K3b, and I got the message:

"The trash has reached its maximum size!
Cleanup the trash manually."

So I opened the Trash folder on the desktop and found that it was empty.

I tried "/home/<user>/.local/share/Trash/files" in Terminal and got "bash: /home/larry/.local/share/Trash/files: Is a directory"

So where do I go from here? How can I have a full Trash file and it be empty at the same time?

And how do I resize it so this does not happen again in the future?

Thanks
 
Old 03-02-2012, 12:59 PM   #2
jhwilliams
Senior Member
 
Registered: Apr 2007
Location: Portland, OR
Distribution: Debian, Android, LFS
Posts: 1,168

Rep: Reputation: 207Reputation: 207Reputation: 207
You should delete the contents of your trash:

Code:
rm -rf ~/.local/share/Trash/files/*
Maybe they weren't showing because the GNOME file icons get cached in the same directory, and since it was full, they couldn't be written? Not really sure.

Don't bother resizing it, just find a better place to put your files. Like /home/larry/uninportant_files or something.
 
Old 03-02-2012, 04:19 PM   #3
l8tr
LQ Newbie
 
Registered: Mar 2012
Location: Oregon
Distribution: Ubuntu 11.04
Posts: 5

Original Poster
Rep: Reputation: Disabled
I appreciate the prompt reply jhwilliams, but when I copied and pasted "rm -rf ~/.local/share/Trash/files/* into the Terminal, a I got was the root directory again.

I wanted to delete the file I downloaded so I do not waste space on the hard drive. Don't I have to send them to Trash to delete them?
 
Old 03-02-2012, 04:33 PM   #4
l8tr
LQ Newbie
 
Registered: Mar 2012
Location: Oregon
Distribution: Ubuntu 11.04
Posts: 5

Original Poster
Rep: Reputation: Disabled
After you suggested that I simply find a place to put the files, it came to me that K3b may not actually be holding the file I wanted to send to trash in it's window, but rather listed it so I could direct activity toward it in the folder it was downloaded to.

So I checked the downloads drop-down menu in Foxfire where I got it. Opening the "Open containing folder" took me to the .tmp folder. I found the offending file there and was able to send it to trash from there with no issues. As a result, the K3b folder also dropped the file off the list I wanted to remove it from.

Still the question: Why did:

"The trash has reached its maximum size!
Cleanup the trash manually."

show up in the first place if the was nothing in the Trash folder?

Cheers!
 
Old 03-02-2012, 06:05 PM   #5
yancek
Senior Member
 
Registered: Apr 2008
Distribution: PCLinux, Ubuntu, Slackware
Posts: 4,953

Rep: Reputation: 785Reputation: 785Reputation: 785Reputation: 785Reputation: 785Reputation: 785Reputation: 785
You need to be in your /home/user directory to run the command above so firt do? cd /home/larry, then run the command:

Quote:
rm -rf ~/.local/share/Trash/files/*
Quote:
Don't I have to send them to Trash to delete them?
Sending files to Trash does not delete them. The command suggested to you by jhwilliams deletes.

You can also delete files by navigating to the Trash folder in your file manager and when you are in the files directory, select Edit and then Select All (if you want to delete everything there) to highlight the files, then hit the Shift and Delete keys simultaneously. You will be prompted asking if you really want to Delete, click OK to delete.

t
 
Old 03-02-2012, 06:07 PM   #6
jhwilliams
Senior Member
 
Registered: Apr 2007
Location: Portland, OR
Distribution: Debian, Android, LFS
Posts: 1,168

Rep: Reputation: 207Reputation: 207Reputation: 207
@l8tr, Nice location! I'm in North Portland.

Are you using KDE? That path to the trash file may only be valid for Gnome, not sure.
 
Old 03-02-2012, 06:39 PM   #7
Knightron
Senior Member
 
Registered: Jan 2011
Location: Planet Earth
Distribution: Slackware.
Posts: 1,327
Blog Entries: 7

Rep: Reputation: 158Reputation: 158
Just gksu nautilus, navigate to the trash and then highlight them and select delete. When you delete with root, i'm pretty sure it deletes. Also have you tried right click, empty trash?
 
Old 03-02-2012, 07:11 PM   #8
l8tr
LQ Newbie
 
Registered: Mar 2012
Location: Oregon
Distribution: Ubuntu 11.04
Posts: 5

Original Poster
Rep: Reputation: Disabled
Yancek, I am such a Noobie that I still cut ad paste any advice I get. When I did so with multiple variants of "firt do? cd /home/larry" (Not aware of the syntax of the root language), I just got a lot of errors telling me that what I put in was not recognised immediately and that I would have to install other packages to make any of the variants work. "cd /home/larry" resulted in:
bash: cd/home/larry: No such file or directory.

If I am missing something, please let me Know.

jhwilliams, I am running Natty, using Unity 2D. I am not sure how to check to see if it is KDE or Gnome, but I thought it was in Gnome. How do I check?

Knightron, I copied "gksu nautilus" into the root and it appears to work.

Still don't know why the message:

"The trash has reached its maximum size!
Cleanup the trash manually."

came up with an empty trash file...

To All of You:
Thanks for all the help
 
Old 03-02-2012, 08:51 PM   #9
frankbell
Guru
 
Registered: Jan 2006
Location: Virginia, USA
Distribution: Slackware, Mageia, Mint
Posts: 7,906

Rep: Reputation: 1492Reputation: 1492Reputation: 1492Reputation: 1492Reputation: 1492Reputation: 1492Reputation: 1492Reputation: 1492Reputation: 1492Reputation: 1492
If you're using Konqueror, you can go into Settings-->Configure Konqueror-->File Management and add a menu item for Delete which does not send a file to trash.

I justed checked my Slackware box. The trash path that jhwilliams posted is valid for KDE; both KDE and Gnome conform to the Free Desktop Specifications:

http://standards.freedesktop.org/des...ec-latest.html
 
Old 03-02-2012, 10:48 PM   #10
yancek
Senior Member
 
Registered: Apr 2008
Distribution: PCLinux, Ubuntu, Slackware
Posts: 4,953

Rep: Reputation: 785Reputation: 785Reputation: 785Reputation: 785Reputation: 785Reputation: 785Reputation: 785
Quote:
. "cd /home/larry" resulted in:
bash: cd/home/larry: No such file or directory
From your first post indicating your user name larry, that should work. You do need a space between cd and /home/larry like this:

Quote:
cd /home/larry
 
Old 03-02-2012, 11:12 PM   #11
l8tr
LQ Newbie
 
Registered: Mar 2012
Location: Oregon
Distribution: Ubuntu 11.04
Posts: 5

Original Poster
Rep: Reputation: Disabled
Quote:
If you're using Konqueror, you can If you're using Konqueror, you can go into Settings-->Configure Konqueror-->File Management and add a menu item for Delete which does not send a file to trash.

I justed checked my Slackware box. The trash path that jhwilliams posted is valid for KDE; both KDE and Gnome conform to the Free Desktop Specifications:

[url]http://standards.freedesktop.org/desktop-entry-spec/desktop-entry-spec-latest.htmlgo into Settings-->Configure Konqueror-->File Management and add a menu item for Delete which does not send a file to trash.

I justed checked my Slackware box. The trash path that jhwilliams posted is valid for KDE; both KDE and Gnome conform to the Free Desktop Specifications:

[url]http://standards.freedesktop.org/desktop-entry-spec/desktop-entry-spec-latest.html
I believe Konqueror is in Ubuntu 11.10 which did not want to load on my older machine. (System settings does not indicate that it is in my 11.04). I don't know if it can be installed in this version.

Also, Yancek, I just copied & pasted "cd /home/larry " from your post with the same results.
Not sure how to get there from here.

Cheers
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] The trash has reached its maximum size! Cleanup the trash manually. kiruja Linux - Newbie 8 02-04-2012 12:28 PM
unpredictable "delete" "move to trash" or "cut" file menu option dorianrenato Linux - General 3 11-28-2011 06:41 PM
Trash has reached maximum size bucknap Linux - Newbie 2 03-08-2011 08:45 PM
New user first login attempt gets "Account locked. Maximum attempts reached" p3t0rt Linux - Newbie 2 07-21-2009 04:40 PM
LXer: Displaying "MyComputer", "Trash", "Network Servers" Icons On A GNOME Desktop LXer Syndicated Linux News 0 04-02-2007 08:31 AM


All times are GMT -5. The time now is 05:57 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration