LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 09-17-2009, 06:43 AM   #1
zodehala
Member
 
Registered: Nov 2008
Posts: 53

Rep: Reputation: 15
The requested URL /phpmyadmin was not found on this server.


1- i downloaded phpmyadmin into /home/admin/program/ using following command
Code:
wget -c http://downloads.sourceforge.net/project/phpmyadmin/phpMyAdmin/3.2.2/phpMyAdmin-3.2.2-all-languages.tar.gz?use_mirror=garr

2- and untared it following command
Code:
tar -xvf phpMyAdmin-3.2.2-all-languages.tar.gz -C /var/www/html/
3- renamed its name following commnand
Code:
mv phpMyAdmin-3.2.2-all-languages phpmyadmin
4- in order to open it 192.168.1.100/phpmyadmin but following error occured


Code:
Not Found

The requested URL /phpmyadmin was not found on this server.
Apache/2.2.3 (CentOS) Server at 192.168.1.100 Port 80
 
Old 09-17-2009, 07:38 AM   #2
linuxlover.chaitanya
Senior Member
 
Registered: Apr 2008
Location: Nagpur, India
Distribution: Cent OS 5/6, Ubuntu Server 10.04
Posts: 4,627

Rep: Reputation: Disabled
Have you configured Apache for phpmyadmin? If you have not there is no way apache know about it.
But I would like to ask why did not you install it using the package manager of your distribution? It would have been much easier. Also you would not have needed to configure anything. Package manager would have done it for you.
 
Old 09-17-2009, 08:59 AM   #3
prasanta
Member
 
Registered: Mar 2005
Location: India
Distribution: Debian
Posts: 368

Rep: Reputation: 37
Quote:
1- i downloaded phpmyadmin into /home/admin/program/ using following command
You need to put phpmyadmin in the apache working directory and then configure it. As of now you have downloaded to your home directory. Is your home directory the working directory for apache?

Regards,

--
Prasanta
 
Old 09-19-2009, 01:43 AM   #4
linuxlover.chaitanya
Senior Member
 
Registered: Apr 2008
Location: Nagpur, India
Distribution: Cent OS 5/6, Ubuntu Server 10.04
Posts: 4,627

Rep: Reputation: Disabled
If he has not configured apache, there is very little chance that his /home is working directory for it.
 
Old 09-19-2009, 08:36 AM   #5
zodehala
Member
 
Registered: Nov 2008
Posts: 53

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by prasanta View Post
You need to put phpmyadmin in the apache working directory and then configure it. As of now you have downloaded to your home directory. Is your home directory the working directory for apache?

Regards,

--
Prasanta
Quote:
renamed its name following commnand
Code:
tar -xvf phpMyAdmin-3.2.2-all-languages.tar.gz -C /var/www/html/
how can i configure apache for it ? (any docs ?)

(i can not install it using yum )
 
Old 09-19-2009, 11:05 AM   #6
prasanta
Member
 
Registered: Mar 2005
Location: India
Distribution: Debian
Posts: 368

Rep: Reputation: 37
Quote:
how can i configure apache for it ? (any docs ?)
(i can not install it using yum )
After untaring it, I hope you have done,
Code:
cd /var/www/html
mv phpMyAdmin-3.2.2-all-languages phpmyadmin
as you had done before.

No from the borwser, just browse,
Code:
http://localhost/phpmyadmin
It shall ask for the MySQL root username/password and will let you go through the simple steps. I hope have installed MySQL before.

Regards,

Last edited by prasanta; 09-19-2009 at 11:07 AM.
 
Old 09-23-2009, 01:45 AM   #7
linuxlover.chaitanya
Senior Member
 
Registered: Apr 2008
Location: Nagpur, India
Distribution: Cent OS 5/6, Ubuntu Server 10.04
Posts: 4,627

Rep: Reputation: Disabled
Well phpmyadmin is not just static html pages. It is built with php. So you NEED web server to parse the pages.
Create a virtual host in apache configuration and put Directory index to be where phpmyadmin has been untared. And it should have index.php or index.html file. Configure apache to use this file as document root.
 
Old 08-19-2011, 03:17 AM   #8
warpgeek
LQ Newbie
 
Registered: Aug 2011
Posts: 3

Rep: Reputation: 0
Smile

I know this thread is a little old now, but I came across it via Google.

I had this problem recently on a CentOS machine with VirtualMin installed. Using VirtualMin's installer script, I installed the old version (v2) of PHPMyAdmin into a domain, and then got the same error as described in this thread.

My solution? A bit weird, but basically I edited phpmyadmin/index.php, inserting:

Code:
 echo "hello";
in the next line after the opening <?php tag.

This forced the server to send a header and thus the rest of the page, which (I think) may have had the effect of setting a cookie on my machine.

I then removed the echo line and refreshed the page - it still works.

Hope that helps somebody.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
The requested URL /defaultsite was not found on this server. lqforumuser Linux - Newbie 1 06-28-2009 02:59 PM
The requested URL /server-inifo not found on this server narsimha.v Linux - Software 1 01-18-2008 01:57 AM
The requested URL/sever-info not found on this server narsimha.v Linux - Newbie 1 01-17-2008 08:54 AM
The requested URL could not be retrieved sharad Linux - Networking 4 12-16-2005 01:53 PM
ERROR The requested URL could not be retrieved While trying to retrieve the URL: /re Niceman2005 Linux - General 1 06-29-2005 09:51 AM


All times are GMT -5. The time now is 12:19 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration