LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 06-06-2009, 05:47 AM   #1
farhan.azam
LQ Newbie
 
Registered: Apr 2009
Location: Kolkata
Posts: 2

Rep: Reputation: 0
The import java.util is never used


Hi,

I have installed JAVA 1.4.2_04, but gettting below error at the time of compiling through javac. Please suggest.


[oracle@appserver ~]$ javac asmactivation.java
----------
1. WARNING in asmactivation.java (at line 4)
import java.util.*;
^^^^^^^^^
The import java.util is never used
----------
1 problem (1 warning)
[oracle@appserver ~]$

thnx...farhan
 
Old 06-06-2009, 05:49 AM   #2
jdkaye
LQ Guru
 
Registered: Dec 2008
Location: Westgate-on-Sea, Kent, UK
Distribution: Debian Testing Amd64
Posts: 5,464

Rep: Reputation: Disabled
Quote:
Originally Posted by farhan.azam View Post
Hi,

I have installed JAVA 1.4.2_04, but gettting below error at the time of compiling through javac. Please suggest.


[oracle@appserver ~]$ javac asmactivation.java
----------
1. WARNING in asmactivation.java (at line 4)
import java.util.*;
^^^^^^^^^
The import java.util is never used
----------
1 problem (1 warning)
[oracle@appserver ~]$

thnx...farhan
It doesn't look like an error to me. It looks like a warning. Does the compilation otherwise succeed?
cheers,
jdk
 
Old 06-06-2009, 06:04 AM   #3
farhan.azam
LQ Newbie
 
Registered: Apr 2009
Location: Kolkata
Posts: 2

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by jdkaye View Post
It doesn't look like an error to me. It looks like a warning. Does the compilation otherwise succeed?
cheers,
jdk

Hi,

Copilation isn't working.

Please suggest.

thnx...farhan

Last edited by farhan.azam; 06-06-2009 at 06:58 AM.
 
Old 06-06-2009, 08:21 AM   #4
jdkaye
LQ Guru
 
Registered: Dec 2008
Location: Westgate-on-Sea, Kent, UK
Distribution: Debian Testing Amd64
Posts: 5,464

Rep: Reputation: Disabled
Quote:
Originally Posted by farhan.azam View Post
Hi,

Co[m]pilation isn't working.

Please suggest.

thnx...farhan
Can you explain? What do you mean it isn't working? Are the error messages? You need to give more information if you expect help.
cheers,
jdk
 
Old 06-06-2009, 08:52 AM   #5
AlucardZero
Senior Member
 
Registered: May 2006
Location: USA
Distribution: Debian
Posts: 4,808

Rep: Reputation: 604Reputation: 604Reputation: 604Reputation: 604Reputation: 604Reputation: 604
That's a warning, not an error, and unless you configured it to die on warnings then compilation should still succeed. Is that the only error? You can get rid of it by merely commenting out line 4.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Java.util.Scanner not found by Eclipse in Ubuntu 8.10 charlie0313 Linux - Software 1 01-03-2009 05:11 PM
Where is java.util.Scanner? pda_h4x0r Programming 8 11-12-2007 04:53 PM
java: java.util.Hashmap doesn't work for a custom object kpachopoulos Programming 2 04-15-2007 04:25 PM
java.util.*; in Linux? vmlinuz.gz Programming 3 04-05-2006 03:26 PM
Java can't find package, but PATH set correctly (j2se1.4.0, java.util.regex package) Ethan Programming 5 02-06-2004 10:55 PM


All times are GMT -5. The time now is 04:26 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration