LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 10-20-2006, 07:43 PM   #1
Cyrodox
LQ Newbie
 
Registered: Oct 2006
Location: USA
Distribution: SuSE 10.1, Fedora Core 5, Mandriva Free 2007
Posts: 4

Rep: Reputation: 0
The dreaded WIRELESS! (que scary music) Dlink DWL-G630 on Fedora Core 5; Notebook.


Well, I'm new to Linux, as you can probably tell. I've googled this up, but I just can't find a solution that works. I attempted ndiswrapper, but when using the "make", "make install", and all of those neat commands, I get this error everytime:
Code:
make -C driver
make[1]: Entering directory `/root/Desktop/ndiswrapper-1.26/driver'
Can't find kernel build files in /lib/modules/2.6.15-1.2054_FC5/build;
  give the path to kernel build directory with
  KBUILD=<path> argument to make
make[1]: *** [prereq_check] Error 1
make[1]: Leaving directory `/root/Desktop/ndiswrapper-1.26/driver'
make: *** [all] Error 2
And then I'm stuck. More info:

Ethernet works fine, just trying to setup wireless so I can use it at school.

Card: Dlink Airplus DWL-G630, H/W ver = B1
PC: Stock Gateway Notebook (Don't think that's too important)
Distro: Fedora Core 5

Thanks for the help =D
 
Old 10-21-2006, 03:05 PM   #2
Duster
Member
 
Registered: Jul 2005
Distribution: openSuSE 10.2; PCLinuxOS 0.93a
Posts: 59

Rep: Reputation: 15
for my wireless I own Broadcomm and an rt2500, but ndiswrapper should work the same.

for your sanity, connect via your ethernet and su
then yum install ndiswrapper. That will install it for you. If that does not work update the whole system thruogh yum (good idea anyway) and then install ndiswrapper.

Basically you unpack any drivers you have for windows somewhere on your Linux directory. i generally use my users home directory. go to the command line and switch to su, then go to that directory, like /home/yourusername.

in there you should find the folder you unzipped with your gnome package manager. go to that directory, and look for an .ini file.

use
ndiswrapper -i <filename>.ini
that will install the file to linux.
just to be sure type
ndiswrapper -l
this will list if the driver is installed, and will also tell you if it sees the hardware or if it does not

next
modprobe ndiswrapper
dhcpcd wlan0
ifconfig wlan0 up

this is the manual way to see if the card comes up
I know fedora has a netwrok manager, But I can not remember exactly where it is, besides look through your settings. You should set it up in there as well

at least this will get your ndiswrapper installed.

If you have a not found, or some other message from ndiswrapper -l, just uninstall and try another ini file.

uninstall a driver by ndiswrapper -e <filename>. the filename you use is given with the -l option.

Hope this helps a little.

When I was running Fedora I was unable to connect until I also set the card up in Fedora's network manager, and rebooted.

Last edited by Duster; 10-21-2006 at 03:08 PM.
 
Old 10-23-2006, 08:45 PM   #3
Cyrodox
LQ Newbie
 
Registered: Oct 2006
Location: USA
Distribution: SuSE 10.1, Fedora Core 5, Mandriva Free 2007
Posts: 4

Original Poster
Rep: Reputation: 0
I have ndiswrapper installed, I discovered that Fedora's kernel is located in a different directory. I got the G630 driver, and continued to move it into linux, the .inf file is called SETUP.

I run the command, ndiswrapper -i SETUP.inf in the designated folder, and it says the file is unopenable, upon further examination, the driver is invalid. I uninstall, try again, but same result, and it's the only inf/ini file there.

Any suggestions?
----------
EDIT
----------

I wasn't capitalizing the .INI part, and I got it to install sort of. Now I'm getting the error 'Couldn't Get to Manufacturer Section' and I have no idea what that means.

---
Edit
---

Once again, human fixable, downloaded a new copy of the driver and it worked fine. But now, I'm getting a fatal error whilst using modprobe.

Code:
 modprobe ndiswrapper
FATAL: Error inserting ndiswrapper (/lib/modules/2.6.15-1.2054_FC5/misc/ndiswrapper.ko): Invalid module format

Last edited by Cyrodox; 10-23-2006 at 09:45 PM.
 
Old 10-27-2006, 02:21 PM   #4
Duster
Member
 
Registered: Jul 2005
Distribution: openSuSE 10.2; PCLinuxOS 0.93a
Posts: 59

Rep: Reputation: 15
I had some issues with FC5 in the past . .
Only advice I can try to offer is connect via ethernet, yum remove andiswrapper and try to reinstall with yum. Sometimes I could never get the issues to clear up until I updated the kernel and reinstalled on FC5. . . .

But that is my experience, I would have to point you to someone in the fedora community
 
Old 10-28-2006, 12:56 PM   #5
Cyrodox
LQ Newbie
 
Registered: Oct 2006
Location: USA
Distribution: SuSE 10.1, Fedora Core 5, Mandriva Free 2007
Posts: 4

Original Poster
Rep: Reputation: 0
Tried that already, but FC5 is just a faint memory, as I formatted and installed SUSE 10.1, and now I run into a problem with this.

The problem is, it's picking up networks, my card, and all of that. I got to the KNetwork Manager, and I see the access point I selected But, when i connect, it goes to "Configuring network" (or something like that, I don't have wireless at home, so I can't tell you the exact thing.

Also, when i iwconfig, it's set to off/any, I assume that's the reason it doesn't work, how do I fix that?
 
Old 10-28-2006, 01:45 PM   #6
yttrium88
Member
 
Registered: Oct 2006
Distribution: Almost Kubuntu 6.10
Posts: 32

Rep: Reputation: 15
I am having a similar problem, and I tried the yum thing:

***:/home/***/Desktop/ndiswrapper-1.27 # yum update
Setting up Update Process
Setting up repositories
No Repositories Available to Set Up
Reading repository metadata in from local files
No Packages marked for Update/Obsoletion
***:/home/***/Desktop/ndiswrapper-1.27 # yum install ndiswrapper
Setting up Install Process
Setting up repositories
No Repositories Available to Set Up
Reading repository metadata in from local files
Parsing package install arguments
No Match for argument: ndiswrapper
Nothing to do
***:/home/***/Desktop/ndiswrapper-1.27 #

I am running SUSE 10.1, I hope that doesn't make a difference. So what does all this mean?
 
Old 10-29-2006, 01:01 AM   #7
Cyrodox
LQ Newbie
 
Registered: Oct 2006
Location: USA
Distribution: SuSE 10.1, Fedora Core 5, Mandriva Free 2007
Posts: 4

Original Poster
Rep: Reputation: 0
Didn't work for me either, so I manually installed it.
http://sourceforge.net/projects/ndiswrapper
If you're SUSE kernel is fully updated, then get the latest version (that's what I got). Navigate to the installed menu, and type:
Code:
distclean
Code:
make
Afterwards,
Code:
 makeinstall
And then you ndiswrapper should be installed
 
Old 10-29-2006, 01:49 AM   #8
smaudlin
Member
 
Registered: Dec 2004
Location: Benicia, CA
Distribution: Fedora 6,5,4 Mandrake 10.1
Posts: 46

Rep: Reputation: 15
ndiswrapper installs

I had the same problem. Rather then type everything I can't remmember what all I did to fix it but cut and paste put that error into google and you'll see all kinds of info on what to do. That's what I did.
 
Old 10-30-2006, 09:42 PM   #9
Duster
Member
 
Registered: Jul 2005
Distribution: openSuSE 10.2; PCLinuxOS 0.93a
Posts: 59

Rep: Reputation: 15
Sorry, had 3 tests this week . .
Without seeing each of your monitors here is something you
can all try
su
modprobe ndiswrapper ( I know you guys already know this)

ifconfig( to see if wlan0 is picked up)

iwconfig wlan0 essid <enter your network here>

ifdown eth0

ifup wlan0

Hopefully you should all be connected

YOU MAY need to type in
dhcpcd -k wlan0 (kills the dhcp)
dhcpcd wlan0 (starts back up the dhcp)

might need to toss in a iwconfig wlan0 essid <your network here> in also

Now . . to set it to boot every time

this guide helped me out alot (sorry Suse and Yast Only)
http://ndiswrapper.sourceforge.net/m...ofessional_9.2

For 10.1 in yast NOTE, this is in burried in the article

Note: These steps can be / are incorrect in SuSE Linux 10.1!
In Yast Manual Network Card Configuration, make sure after you choose wireless (from above) that you enter 0 in "Configuration Name" instead of wlan0!
"Hardware Configuration Name" can be left blank.

Now you won't get that "Configuration not found for wlan0 on ifup."
By choosing "wireless" above you create "wlan"
By having "0" as the "Configuration Name" you create wlan0, which is the proper device name, right.
If you find out this helped out, please edit and remove those steps above.
---------------


ALSO on SUSE 10.1, smart will be your friend
go to this page and it will walk you thru when you are connected to update that distro.

http://susewiki.org/index.php?title=...ackage_Manager

Just copy and paste the lines for your flavor of the lizard (32 bit, 64 bit, etc...)

this is a great tool to get many of the bugs in Suse 10.1 out

Last edited by Duster; 10-30-2006 at 09:47 PM.
 
Old 03-12-2007, 06:31 PM   #10
Gogo69
LQ Newbie
 
Registered: Mar 2007
Posts: 1

Rep: Reputation: 0
Unhappy D-Link airplus G DWL-G630

Hi there!
I am so totally new to linux that at the first hardware installation problem, I had to reinstall MS-windows to get my PC to work. I'm not yet a traitor to the cause but I'm not very proud about that. Now I need to know how I can install a PCMCIA-Card (see subject) in a late Debian linux version (probably the latest but who knows?).
I've seen some people talking about commands and stuff: where do I spell them? Does it sound like a joke? well sure it is, from a certain point of view. When you need to get the darn laptop working over night in order to get your work done, it's not.
Can anyone tell me a smart "receipt" how to install hardware onto a computer?

thx.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
dlink dwl - g630 ipseity Linux - Networking 1 10-15-2005 05:03 AM
cannot connect with DLink DWL-G630 w_geek Linux - Wireless Networking 9 02-25-2005 12:36 AM
DLink DWL-G630 herby1620 Linux - Wireless Networking 4 01-18-2005 12:25 AM
D-Link DWL-G630 loses access point -- ndiswrapper 0.12, Fedora Core 3 hotroge Linux - Wireless Networking 1 01-15-2005 02:54 PM
Dlink DWL-G630 works great in slack 10 with ndiswrapper dissolved soul Linux - Wireless Networking 0 07-09-2004 12:01 AM


All times are GMT -5. The time now is 03:11 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration