LinuxQuestions.org
Latest LQ Deal: Complete CCNA, CCNP & Red Hat Certification Training Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 11-01-2005, 10:54 AM   #1
novkhan
Member
 
Registered: Jan 2004
Posts: 59

Rep: Reputation: 15
Question The Destination disk is read-only.


Goodday

Having some trouble copying files into a external Harddisk i just bought.

The error states this
" Error while copying to "/mnt/windows." The Destination disk is read-only."

My system is Redhat 9

And this is the command i used to mount my harddisk/
"mount /dev/sda1 /mnt/windows"

Hope the info i supplied is enough.

Thankyou.
 
Old 11-01-2005, 11:18 AM   #2
ydoih8u
LQ Newbie
 
Registered: Mar 2005
Posts: 3

Rep: Reputation: 0
You didn't specify if it was a NTFS or FAT32 partition in your previous post. If its a FAT partition and you have the proper device name for the drive, then type:
Code:
mount /dev/sda1 /location -t vfat
or you can use this if its NTFS (It will be mounted read-only using this though. This way you won't corrupt your ntfs filesystem.)
Code:
mount /dev/sda1 /location -t ntfs -r
where sda1 is the partition you want to mount and location is where you want to mount it on your linux filesystem.

well i hope this helps.

EDIT:

oops guess i can't read ;D read-only problems
assuming its all mounted correctly you could try using chmod on "location" to make sure you have write permissions there. like:
Code:
chmod a+rw /location
or try using the "-o UMASK=0000" flag in your mount to give everyone all permissions to the mount...though this is dangerous and should probably only be used to test

Last edited by ydoih8u; 11-01-2005 at 11:27 AM.
 
Old 11-01-2005, 07:55 PM   #3
novkhan
Member
 
Registered: Jan 2004
Posts: 59

Original Poster
Rep: Reputation: 15
Quote:
Originally posted by ydoih8u
You didn't specify if it was a NTFS or FAT32 partition in your previous post. If its a FAT partition and you have the proper device name for the drive, then type:
Code:
mount /dev/sda1 /location -t vfat
or you can use this if its NTFS (It will be mounted read-only using this though. This way you won't corrupt your ntfs filesystem.)
Code:
mount /dev/sda1 /location -t ntfs -r
where sda1 is the partition you want to mount and location is where you want to mount it on your linux filesystem.

well i hope this helps.

EDIT:

oops guess i can't read ;D read-only problems
assuming its all mounted correctly you could try using chmod on "location" to make sure you have write permissions there. like:
Code:
chmod a+rw /location
or try using the "-o UMASK=0000" flag in your mount to give everyone all permissions to the mount...though this is dangerous and should probably only be used to test
Thanks your reply buddy!
I tried all the steps but doesnt seems to work

Below is my working!
ATTEMPT 1)
[root@localhost mnt]# mount /dev/sda1 /mnt/windows
[root@localhost mnt]# chmod a+rw /mnt/windows
chmod: changing permissions of `/mnt/windows' (requested: 0777, actual: 0755): Operation not permitted

ATTEMPT 2)
[root@localhost mnt]# mount /dev/sda1 /mnt/windows -t vfat
[root@localhost mnt]# chmod a+rw /mnt/windows
chmod: changing permissions of `/mnt/windows' (requested: 0777, actual: 0755): Operation not permitted

ATTEMPT 3)
[root@localhost mnt]# umount windows
[root@localhost mnt]# mount /dev/sda1 /mnt/windows -t ntfs -r
mount: wrong fs type, bad option, bad superblock on /dev/sda1, or too many mounted file systems

ATTEMPT 4)
[root@localhost mnt]# -o UMASK=0000
bash: -o: command not found

By the way, i beleive my external harddisk should be FAT.
And my login is Root.




Sorry, i am really not experience in linux!

Last edited by novkhan; 11-01-2005 at 07:56 PM.
 
Old 11-02-2005, 09:21 AM   #4
ydoih8u
LQ Newbie
 
Registered: Mar 2005
Posts: 3

Rep: Reputation: 0
it does appear to be FAT. you should do the chmod before you mount the partition. also the "-o UMASK=0000" is a flag that should be on the end of the mount command....sry i didn't specify that before, but really i don't think that should be the problem...hmm try this:
Code:
chmod a+rw /mnt/windows
mount /dev/sda1 /mnt/windows -t vfat
then try to copy something to it. if it doesn't work try this:
Code:
umount /mnt/windows
mount /dev/sda1 /mnt/windows -t vfat -o UMASK=0000
though since you are root that shouldn't matter....and fat doesn't support ownership so whoever mounts it should "own" it....also you could try mounting it in your fstab (which would make it mount when you boot)
Code:
nano /etc/fstab
/dev/hda5      /windows      vfat      rw,noatime,uid=500,gid=500,user   0 0
where nano could be your text editor of choice.
 
Old 11-02-2005, 12:55 PM   #5
novkhan
Member
 
Registered: Jan 2004
Posts: 59

Original Poster
Rep: Reputation: 15
Unhappy

Sorry to trouble you again buddy.
Still unsuccessful

Attempt 1)
[root@localhost root]# chmod a+rw /mnt/windows
[root@localhost root]# mount /dev/sda1 /mnt/windows -t vfat
Tried copying and
"Error while copying to"/mnt/windows". The destination disk is read only.

Attempt 2)
so i did
[root@localhost root]# chmod a+rw /mnt/windows
chmod: changing permissions of `/mnt/windows': Read-only file system

Attempt 3)
[root@localhost root]# cd /mnt
[root@localhost mnt]# umount windows
[root@localhost mnt]# mount /dev/sda1 /mnt/windows -t vfat -o UMASK=0000
Tried copying and
"Error while copying to"/mnt/windows". The destination disk is read only.

 
Old 11-02-2005, 03:58 PM   #6
ydoih8u
LQ Newbie
 
Registered: Mar 2005
Posts: 3

Rep: Reputation: 0
can you read the partition? i mean what happens if you goto /mnt/windows and do an ls after you have mounted it? can you see anything?
 
Old 11-02-2005, 08:24 PM   #7
novkhan
Member
 
Registered: Jan 2004
Posts: 59

Original Poster
Rep: Reputation: 15
Yes.

I can even open the file i have inside.

But i notice that the reply is now different from what i have previously!

Latest attempt base on your second procedures.
root@localhost root]# chmod a+rw /mnt/windows
chmod: changing permissions of `/mnt/windows': Read-only file system

Previous attempt base on your first procedures.
[root@localhost mnt]# chmod a+rw /mnt/windows
chmod: changing permissions of `/mnt/windows' (requested: 0777, actual: 0755): Operation not permitted


Last edited by novkhan; 11-02-2005 at 08:29 PM.
 
Old 11-02-2005, 08:41 PM   #8
novkhan
Member
 
Registered: Jan 2004
Posts: 59

Original Poster
Rep: Reputation: 15
[root@localhost root]# cat /etc/fstab
LABEL=/ / ext3 defaults 1 1
LABEL=/boot /boot ext3 defaults 1 2
none /dev/pts devpts gid=5,mode=620 0 0
LABEL=/home /home ext3 defaults 1 2
none /proc proc defaults 0 0
none /dev/shm tmpfs defaults 0 0
LABEL=/tmp /tmp ext3 defaults 1 2
LABEL=/usr /usr ext3 defaults 1 2
LABEL=/var /var ext3 defaults 1 2
/dev/hda10 swap swap defaults 0 0
/dev/fd0 /mnt/floppy auto noauto,owner,kudzu 0 0
/dev/cdrom /mnt/cdrom udf,iso9660 noauto,owner,kudzu,ro 0 0
/dev/sda1 /mnt/thumbdrive vfat user,noauto,umask=0 0 0
/dev/hda5 /mnt/windows vfat defaults,users,umask=0000

I notice that meant for /dev/sda1 is in /mnt/thumdrive folder?????

And i tried the same procedure for thumbdrive folder is still the same
 
Old 11-21-2005, 04:08 AM   #9
ecampii
LQ Newbie
 
Registered: Sep 2005
Location: philippines
Distribution: debian
Posts: 2

Rep: Reputation: 0
what happened to this post??? was is resolved?? im having the same problem... did the guy able to write in the stubborn floppy?? is there a commercial or a part II/????/
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Why my disk turned to be read-only ? naihe2010 Linux - Enterprise 1 11-07-2005 09:53 AM
READ-ONLY disk Einsteino Fedora 3 05-10-2005 08:06 PM
Floppy disk read-only?? halo14 Debian 3 08-20-2004 05:44 PM
Read Only hard disk? GTBlackwell Linux - Hardware 3 12-16-2003 10:16 AM
The destination disk is read only royalewitcheez Linux - Newbie 9 11-02-2003 04:48 PM


All times are GMT -5. The time now is 02:30 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration