LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (http://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   the "default" ( as we have in grub.conf ) option of lilo.conf ??? (http://www.linuxquestions.org/questions/linux-newbie-8/the-default-as-we-have-in-grub-conf-option-of-lilo-conf-362827/)

b0nd 09-12-2005 10:08 PM

the "default" ( as we have in grub.conf ) option of lilo.conf ???
 
hello all,
i'm new to lilo.
posting my /etc/lilo.conf

Code:

bond@bond:~$ cat /etc/lilo.conf
# LILO configuration file
# generated by 'liloconfig'
#
# Start LILO global section
boot = /dev/hda
message = /boot/boot_message.txt
prompt
timeout = 600
# Override dangerous defaults that rewrite the partition table:
change-rules
  reset
# VESA framebuffer console @ 1024x768x256
vga = 773
# Normal VGA console
# vga = normal
# VESA framebuffer console @ 1024x768x64k
# vga=791
# VESA framebuffer console @ 1024x768x32k
# vga=790
# VESA framebuffer console @ 1024x768x256
# vga=773
# VESA framebuffer console @ 800x600x64k
# vga=788
# VESA framebuffer console @ 800x600x32k
# vga=787
# VESA framebuffer console @ 800x600x256
# vga=771
# VESA framebuffer console @ 640x480x64k
# vga=785
# VESA framebuffer console @ 640x480x32k
# vga=784
# VESA framebuffer console @ 640x480x256
# vga=769
# End LILO global section
# Linux bootable partition config begins
image = /boot/vmlinuz
  root = /dev/hda8
  label = Slackware
  read-only

image = /mnt/fedora/boot/vmlinuz-2.6.5-1.358
  initrd = /mnt/fedora/boot/initrd-2.6.5-1.358.img
  root = /dev/hda7
  label = FedoraCore_2
  append = "rhgb quiet"
  read-only


image = /mnt/vector/boot/vmlinuz
    root = /dev/hda9
    label = VectorLinux
#    append = ""
    read-only
    initrd = /mnt/vector/boot/initrd.gz


# Linux bootable partition config ends
bond@bond:~$

as you can see i've 3 distros...........
but where is the option for default booting selection.....as we have "default" in grub.conf.??

regards

greyhoundz1718 09-12-2005 10:37 PM

default=linux
 
Hi,

It's been a while since I've seen LILO, however, as far as I can remember, there should be a line in lilo.conf similar to default in grub. Please see below, on this example I have a linux option to boot as default :). But then again it's been a while I saw a lilo.conf file:

boot=/dev/hda
map=/boot/map
install=/boot/boot.b
prompt
timeout=50
message=/boot/message
lba32
default=linux

c**,)
greyhoundz

b0nd 09-13-2005 07:31 AM

Re: default=linux
 
Quote:

Originally posted by greyhoundz1718
Hi,

It's been a while since I've seen LILO, however, as far as I can remember, there should be a line in lilo.conf similar to default in grub. Please see below, on this example I have a linux option to boot as default :). But then again it's been a while I saw a lilo.conf file:

boot=/dev/hda
map=/boot/map
install=/boot/boot.b
prompt
timeout=50
message=/boot/message
lba32
default=linux

c**,)
greyhoundz

i've already posted my /etc/lilo.conf.........
but i can't see any "default" there

regards

geeman2.0 09-13-2005 08:40 AM

From the lilo.conf man page

Code:

default=name
Uses the specified image as the default boot image. If `default' is omitted, the image appearing first in the configuration file is used.

So in other words, you don't need a default line.
If it's not there then the first image in the list is default.
If you want to change this, then add in "default=whatever" in the global section.

b0nd 09-14-2005 05:51 AM

Quote:

Originally posted by geeman2.0
From the lilo.conf man page

Code:

default=name
Uses the specified image as the default boot image. If `default' is omitted, the image appearing first in the configuration file is used.

So in other words, you don't need a default line.
If it's not there then the first image in the list is default.
If you want to change this, then add in "default=whatever" in the global section.

Its working man !!!
I tried both the methods.

1. in the global section i added a line ....default="whatever was the name of distro in lilo.conf"
and
2. instead of adding "default" line.......i cut paste the entries for a distro and placed it at first positions.

In both ways its working......
noticed one more thing that unlike in grub.conf......default=0 or default=1 doesn't work in case of lilo.conf.
the name should be specified instead of numeric value

thanks geeman and grayhound

regards


All times are GMT -5. The time now is 07:22 AM.