LinuxQuestions.org
Latest LQ Deal: Linux Power User Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 03-21-2011, 09:25 AM   #1
abarsamaneh
LQ Newbie
 
Registered: Jan 2010
Location: Rasht, Gilan Province, Iran
Distribution: CentOs,Redhat,Debian, Ubuntu
Posts: 3

Rep: Reputation: 0
The Alt + F1key combination does not switch from GUI to text-mode


I have installed Vmware workstation on my Windows Xp and inside it I have installed Linux CentOs 5.4.
My virtual machine works fine. Two user accounts exist on CentOs: One is root and the other is user1.
I also adjusted my VMware to use Alt+Ctrl+Shift+Fi combination (where i is a number from 1 to 6) to switch from GUI to text-mode.
The problem is that when I am in the user1`s GUI log-in this key combination works well and takes me to text-mode, but in the root`s GUI it dosen`t operate at all and in fact nothing happens by pressing these keys.
I found that if I log out from root`s GUI login the combination will work on CentOs login page.
I want to know how can I have these hot keys enabled for root`s GUI to lunch into text-mode.
I would appreciate everyone who gives me help on the issue.
 
Old 03-21-2011, 09:58 AM   #2
camorri
LQ Guru
 
Registered: Nov 2002
Location: Somewhere inside 9.9 million sq. km. Canada
Distribution: Slackware 14.1, 14.2
Posts: 5,090

Rep: Reputation: 483Reputation: 483Reputation: 483Reputation: 483Reputation: 483
Have you tried Ctrl + Alt + f1 ( to f6 )? They should work without any definitions.

Since you are very new, I will tell you, if you have heard this before, please disregard. You should not use the root user in a gui. There is very great danger in you doing things to the system that may cause it not to run correctly. The root account should only be used for modifying things the regular user can not modify. Do it in a terminal, not a gui.

If you have to have the key combo working in root user gui, do in the root gui what you did in the user gui to define the key combo. User definitions and customizations are only for the user you make them in. This is not windoze.

Hope this helps.
 
Old 03-21-2011, 12:59 PM   #3
abarsamaneh
LQ Newbie
 
Registered: Jan 2010
Location: Rasht, Gilan Province, Iran
Distribution: CentOs,Redhat,Debian, Ubuntu
Posts: 3

Original Poster
Rep: Reputation: 0
Smile X to text -mode hot keys

Thank you for the time you spent answering my question.I would like to inform you that I have some good experiences relating to Linux operating systems and also have LPIC-1 certification. The story backs to about two years ago when I registered in LinuxQuestions.org but I never participated in this community`s activities and during this period just studied its materials. Recently I decided to make changes in the current situation. Nevertheless I assume myself as a student and see myself at the beginning of the road ahead.
Anyway now my question is that I have defined the Alt+Ctrl+Shift combination in VMware to avoid conflicting with Alt+Ctrl hot key combination which is used to return from the guest to the host, but don`t know why this combination just works in ordinary user`s GUI environment not in root`s!
As a matter of fact I want to know how can we enable or disable X to text mode hot keys?
 
Old 03-21-2011, 01:49 PM   #4
camorri
LQ Guru
 
Registered: Nov 2002
Location: Somewhere inside 9.9 million sq. km. Canada
Distribution: Slackware 14.1, 14.2
Posts: 5,090

Rep: Reputation: 483Reputation: 483Reputation: 483Reputation: 483Reputation: 483
Quote:
As a matter of fact I want to know how can we enable or disable X to text mode hot keys?
The xserver is an application, like any other application. So if you do not want it running, you can swithch to run level that doesn't run the xserver, you would have to look at your distros documentation here, not all distros use the same run levels. I think run level 3 would work with Slackware, for example. The command would be 'init 3' as root, without the quotes.

I guess the other way is to use the kill command, you need to know the pid of the xserver. That would take root authority. Not at all sure if you could set this up with a hot key.

I do not use VMware, I do use VirtualBox though. I can not help with VMware questions.

Last edited by camorri; 03-21-2011 at 01:55 PM.
 
Old 03-22-2011, 02:57 AM   #5
abarsamaneh
LQ Newbie
 
Registered: Jan 2010
Location: Rasht, Gilan Province, Iran
Distribution: CentOs,Redhat,Debian, Ubuntu
Posts: 3

Original Poster
Rep: Reputation: 0
I don`t want to disable or enable X server or change my current runlevel. I just want to find out why don`t the Alt+Fi(i=1,2,..,6) keys work in root`s GUI whereas they do in user1`s?
Suppose I am using GUI and at the same time need to have some jobs accomplished in text-mode without having to log out from GUI or change my run level or even disable X server so that after accomplishing my jobs, I would be able to switch back using Alt+F7.
You can forget about VMware and look at the scenario in a different manner :imagine two people connecting to Linux locally whose account name is root but one of them is using GUI and another is using text-mode.
Again Thanks a lot.
 
Old 03-22-2011, 01:47 PM   #6
camorri
LQ Guru
 
Registered: Nov 2002
Location: Somewhere inside 9.9 million sq. km. Canada
Distribution: Slackware 14.1, 14.2
Posts: 5,090

Rep: Reputation: 483Reputation: 483Reputation: 483Reputation: 483Reputation: 483
Quote:
Have you tried Ctrl + Alt + f1 ( to f6 )? They should work without any definitions.
Have you tried this? If yes, and you did not get a command line, then you probably do not have a tty running.

You can see which one(s) are running, in a console, run the command 'ps aux | grep tty' and look at the output. My system has two running, here is what it looks like.

Quote:
ps aux | grep tty
root 1941 0.0 0.0 1800 536 tty6 Ss+ 13:32 0:00 /sbin/agetty 38400 tty6 linux
root 1944 2.4 1.1 53820 33568 tty7 Ss+ 13:32 0:11 /usr/bin/X -br -novtswitch -quiet -nolisten tcp :0 vt7 -auth /var/run/xauth/A:0-eRHr4a
cliff 2651 0.0 0.0 2216 656 pts/1 S+ 13:40 0:00 grep tty
tty6 is one, and I can log into it. tty7 is where xserver is running. The last line is me searching for running processes ( the ones above ).

If you don't have a spare tty running, then you have nothing to switch to. Since Centos is primarily set up as a server, it may be any extra tty's are disabled. I would have to find out how to start one. So post your results.

Last edited by camorri; 03-22-2011 at 02:02 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
How to switch from text mode to graphical mode in solaris 10 linuxjamil Solaris / OpenSolaris 3 07-19-2009 04:55 PM
Text is garbled when I switch from X back to text mode Dark Jirachi Linux - Laptop and Netbook 18 09-20-2007 10:41 PM
flickering of screen while returning back to GUI mode from Text mode using Ctl+Alt+F7 varun_shrivastava Linux - Newbie 1 03-30-2007 11:12 AM
2005LE: No text mode console at Ctrl+Alt+F2 JLP Mandriva 0 07-18-2005 12:21 PM
instant switch from GUI to text mode? mr_a_ali Linux - General 1 08-17-2004 03:01 PM


All times are GMT -5. The time now is 03:18 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration