LinuxQuestions.org
Latest LQ Deal: Complete CCNA, CCNP & Red Hat Certification Training Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 02-19-2005, 07:57 PM   #1
CPUguy387
Member
 
Registered: Jul 2003
Location: San Luis Obispo, CA
Distribution: Gentoo 2007.0
Posts: 88

Rep: Reputation: 15
That darn "VFS: unable to mount root..." again!


I'm sorry for posting this again, but I have read through pages of these on the forums and still cannot find an answer to my problem. I run a 2.6.10 kernel on Gentoo 2004.3, and after a fresh install on one of my computers, I get this during boot:

Code:
VFS: Cannot open root device "<NULL>" or unknown-block(33,3)
Please append a correct "root=" boot option
Kernel panic - not syncing: VFS: Unable to mount root fs on unknown-block(33,3)
My Grub install didn't go so well also, so I keep having to start up with the LiveCD and chroot into my new install environment to check the kernel. I have enabled EVERY file system possible NOT as a module, and still no luck. I checked my ATA/IDE settings and they look ok.

To start linux right now, I made a Grub boot disk and type in the following manually, so that it begins to boot:

Code:
root (hd1,0) <-- My 2nd HDD
kernel /boot/kernel-2.6.10-gentoo-r6
boot
Could there also be a problem with the ATA/133 Controller the HDD is attached to? (Even though it detects the drive and begins to boot?)

Matt
 
Old 02-19-2005, 09:17 PM   #2
qwijibow
LQ Guru
 
Registered: Apr 2003
Location: nottingham england
Distribution: Gentoo
Posts: 2,672

Rep: Reputation: 47
Quote:
VFS: Cannot open root device "<NULL>" or unknown-block(33,3)
Please append a correct "root=" boot option
Kernel panic - not syncing: VFS: Unable to mount root fs on unknown-block(33,3)
always always always read error messages.. most of the time they will tell you whats wrong.. in this case, you need to appen the correct root= boot ontion to your kernel line in the grub config file.

somthing like root=/dev/hda1 or whatever devicde is your root partiton.
 
Old 02-19-2005, 09:41 PM   #3
CPUguy387
Member
 
Registered: Jul 2003
Location: San Luis Obispo, CA
Distribution: Gentoo 2007.0
Posts: 88

Original Poster
Rep: Reputation: 15
Well, I fixed my grub and checked my grub.conf file, the root= option is there. Now I can boot up, and I get this:

Code:
VFS: Cannot open root device "hde3" or unknown-block(0,0)
Please append a correct "root=" boot option
Kernel panic - not syncing: VFS: Unable to mount root fs on unknown-block(0,0)
It's a kernel option that's not right, but I don't know where to look in the 2.6 kernel.
 
Old 02-20-2005, 06:43 AM   #4
qwijibow
LQ Guru
 
Registered: Apr 2003
Location: nottingham england
Distribution: Gentoo
Posts: 2,672

Rep: Reputation: 47
if hde-3 is the correct root partiton, then yes, you made a mistake configureing there kernel.

since you are not using an initrd image, it is absolutly vital that you compile all drivers that are vital to mounting the root into the kernel. not as modules.

how can the kernnel mount for example an ext3 filesystem, then the ext3 driver is stored on that filesystem.

you have 2 options...
1) make sure the following drivers are hard compiled into your kernel (selecting yes instead of module)

* your IDE controller driver
* your root filesystem driver

2) create an initrd image containing the IDE controller and filesytems driver, and pass it to the kernel at boot time via the grub command "initrd /path/to/initrd" (that line goes just after the kernel line.

all info on how to do this is on all the kernel compile guides.
 
Old 02-20-2005, 07:57 AM   #5
CPUguy387
Member
 
Registered: Jul 2003
Location: San Luis Obispo, CA
Distribution: Gentoo 2007.0
Posts: 88

Original Poster
Rep: Reputation: 15
Well, I have a Maxtor (Promise) Ultra ATA/133 Card, and I enabled every Promise Driver in the kernel, and I double checked that ext2 and ext3 support was enabled NOT as a module and it still gives the same error message.
 
Old 02-20-2005, 08:43 AM   #6
CPUguy387
Member
 
Registered: Jul 2003
Location: San Luis Obispo, CA
Distribution: Gentoo 2007.0
Posts: 88

Original Poster
Rep: Reputation: 15
Well, I plugged my hard drive into my motherboard instead of the controller, so that it is now hdc, and when I boot ed up with the grub option "root=/dev/hdc3", I still get the same error message. Is there something else in the kernel I am missing?
 
Old 02-20-2005, 09:39 AM   #7
CPUguy387
Member
 
Registered: Jul 2003
Location: San Luis Obispo, CA
Distribution: Gentoo 2007.0
Posts: 88

Original Poster
Rep: Reputation: 15
Well, I used genkernel and now the problem is fixed. However, can I go back to manually configuring the kernel somehow again? Thanks!
 
Old 02-20-2005, 04:54 PM   #8
qwijibow
LQ Guru
 
Registered: Apr 2003
Location: nottingham england
Distribution: Gentoo
Posts: 2,672

Rep: Reputation: 47
yea, you can recompile the kernel as many time ar you like.
just be sure to "make clean && make mrproper" before you start compiling.
 
Old 02-23-2005, 05:31 AM   #9
jiapei100
Member
 
Registered: Jan 2005
Location: Surrey, BC, Canada
Distribution: Ubuntu 12.04
Posts: 66

Rep: Reputation: 15
Well, I don't think what you've suggested can solve this problem thouroughly.

I, as well, ticked every checkboxes to "yes" but not "module", then "make && make install", when booting, it still goes wrong.
And, I'm for sure that I am ussing the correct root partition.

I just wonder why Gentoo has so many pickniks, much more than other linux systems?

BTW, how can I just create an "initrd" file? Why Gentoo cannot create this file when it's configured manually?

Cheers

Quote:
Originally posted by qwijibow
if hde-3 is the correct root partiton, then yes, you made a mistake configureing there kernel.

since you are not using an initrd image, it is absolutly vital that you compile all drivers that are vital to mounting the root into the kernel. not as modules.

how can the kernnel mount for example an ext3 filesystem, then the ext3 driver is stored on that filesystem.

you have 2 options...
1) make sure the following drivers are hard compiled into your kernel (selecting yes instead of module)

* your IDE controller driver
* your root filesystem driver

2) create an initrd image containing the IDE controller and filesytems driver, and pass it to the kernel at boot time via the grub command "initrd /path/to/initrd" (that line goes just after the kernel line.

all info on how to do this is on all the kernel compile guides.
 
Old 02-23-2005, 11:51 PM   #10
hans5849
LQ Newbie
 
Registered: Feb 2005
Posts: 1

Rep: Reputation: 0
hi, im having the same problem with my gentoo setup using a promise ATA card and i was woundering if you could email me the contents of your grub.conf my email is hans5849_at_gmail.com Thanks

Edit

hers what i have posed on the gentoo forums so far

Quote:
error: Kernel Panic - not syncing VFS: unable to mount root fs on unknown-block(0,0).

i have tried using different devices, my hdd is on a PCI IDE card and comes up as /dev/hdf/ so i tried using block(5,0) and that just made the computer go into a reboot cycle. Im thinking i might have to do something because the PCI card might be considered a SCSI addon. but any one have a solution for me.

Quote:
grub.conf
default 0
timeout 15
splashimage=(hd0,0)/grub/splash.xpm.gz
title= Gentoo Linux 2.6.9-R1
root (hd0,0)
kernel /kernel-.2.6.9-r1 root=/dev/hdf3 vga=792

Last edited by hans5849; 02-24-2005 at 12:01 AM.
 
Old 02-26-2005, 03:10 PM   #11
CogSci
LQ Newbie
 
Registered: Feb 2005
Location: Whidbey Island
Distribution: Gentoo
Posts: 3

Rep: Reputation: 0
Quote:
Originally posted by hans5849
hi, im having the same problem with my gentoo setup using a promise ATA card and i was woundering if you could email me the contents of your grub.conf my email is hans5849_at_gmail.com Thanks

Edit

hers what i have posed on the gentoo forums so far

[/QUOTE]

I just had the same problem on my Gentoo system yesterday while upgrading to kernel 2.6.10-r7. Compiling fsreiser support into the kernel instead of as module solved the problem for me.

Hope this helps! Good luck!
 
Old 02-28-2005, 11:51 AM   #12
TechXed
LQ Newbie
 
Registered: Feb 2005
Location: San Diego, CA
Distribution: SuSE/RH/SW/Mdrk/etc
Posts: 2

Rep: Reputation: 0
Kernel panic - not syncing: VFS: Unable to mount root fs

I have the same problem. I've reinstalled Gentoo a several times now and it all comes out the same. At first I thought it might be the fs issues. I had reiserfs compiled into a custom configured kernel (not a module). That should have been sufficient. But I decided to make all partitions ext3 just to keep things simple. I did this whole procedure on a vmware machine simulating SCSI drives. I also did it on a very ordinary ide machine itself. Same thing. The only thing in common really is me and how I went about setting things up. I followed the install guide almost exactly. I didn't really understand how to use the precompiled or pseudo packaged genkernel options so I just got the entire 2.6.10 source and did it myself. I could have overlooked somecritical thing that seemed very inappropriate on my system, but I did get all the devfs and other pseudo fs stuff.

I can see that Gentoo would be the ultimate in cool distros, but, it does not work. I'd like to get past this.
 
Old 02-28-2005, 02:48 PM   #13
CogSci
LQ Newbie
 
Registered: Feb 2005
Location: Whidbey Island
Distribution: Gentoo
Posts: 3

Rep: Reputation: 0
Re: Kernel panic - not syncing: VFS: Unable to mount root fs

Quote:
Originally posted by TechXed
I have the same problem. I've reinstalled Gentoo a several times now and it all comes out the same. At first I thought it might be the fs issues. I had reiserfs compiled into a custom configured kernel (not a module). That should have been sufficient. But I decided to make all partitions ext3 just to keep things simple. I did this whole procedure on a vmware machine simulating SCSI drives. I also did it on a very ordinary ide machine itself. Same thing. The only thing in common really is me and how I went about setting things up. I followed the install guide almost exactly. I didn't really understand how to use the precompiled or pseudo packaged genkernel options so I just got the entire 2.6.10 source and did it myself. I could have overlooked somecritical thing that seemed very inappropriate on my system, but I did get all the devfs and other pseudo fs stuff.

I can see that Gentoo would be the ultimate in cool distros, but, it does not work. I'd like to get past this.
I chose the kernel sources gentoo-dev-sources, using xconfig, no genkernel. I followed these docs to the point:
http://www.gentoo.org/doc/en/migration-to-2.6.xml
http://www.gentoo.org/doc/en/handboo...ok_part1_chap7

Are you sure you installed udev?
Yes, Gentoo is the ultimate in cool distros! I love it!
I'll send you my .config file, so you can compare and see if you may have missed an option.
 
Old 02-28-2005, 02:57 PM   #14
CogSci
LQ Newbie
 
Registered: Feb 2005
Location: Whidbey Island
Distribution: Gentoo
Posts: 3

Rep: Reputation: 0
Re: Re: Kernel panic - not syncing: VFS: Unable to mount root fs

Oops! Couldn't contact you via email. Please send me am email to request a copy of my .config file.
 
Old 03-01-2005, 11:41 AM   #15
TechXed
LQ Newbie
 
Registered: Feb 2005
Location: San Diego, CA
Distribution: SuSE/RH/SW/Mdrk/etc
Posts: 2

Rep: Reputation: 0
Works. Wonder what's the difference.

Ok, I finally got it to boot. I followed cogsci's advice and stuck with the instructions. Instead of ignoring the whole genkernel thing, I learned about it and used it to compile. I used the --menuconfig option and whatever it did (beyond my menu configing), it worked. The part that bugs me (the whole attraction to this distro) is what exactly did it do that I didn't? I don't know. One possible problem is that I didn't use a Gentoo boot disk. I had a sysresccd.org cd (which is based on Gentoo and mightily kicks ass) and I got everything started from that. Maybe that causes subtle problems.

But I'm sticking with it. Gentoo is too great of an idea to get put off by a little thing like it not working.

For example, it wasn't done doing a compile before I had to go to work and I realized that there was a sshd on this rescue disk. I fired that up and now I can monitor and continue installing this OS remotely. Oooh. I'm going to get emotional.....
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Possible solution to common "unable to mount root fs" kernel panic while installing pergesu Linux - Software 2 12-26-2005 03:11 PM
"Unable to mount root fs" error Seventh Linux - Newbie 11 03-03-2004 03:47 PM
"VFS: Unable to mount fs" on 2.6 compile... redkazan Linux - General 18 01-11-2004 01:09 PM
Recompiled kernel error - "Unable to mount root fs on 21:42" vetro91 Linux - Software 3 02-17-2003 07:08 PM
error:"kernel panic: VFS: Unable to mount root fs":-( shyguy Linux - Newbie 1 07-23-2001 04:03 PM


All times are GMT -5. The time now is 07:31 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration