LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 08-30-2004, 08:31 PM   #1
zchoyt
Member
 
Registered: Feb 2003
Location: Boise ID
Distribution: fedora
Posts: 156

Rep: Reputation: 30
That annoying beep


Is there a way to disable the motherboard speaker from beeping everytime I make a wrong key stroke, or totally? Since I have installed linux, I have been "THAT GUY" in class with the noisy computer that everyone get annoyed with.
 
Old 08-30-2004, 08:41 PM   #2
egag
Senior Member
 
Registered: Jul 2004
Location: Netherlands
Distribution: Slackware
Posts: 2,721

Rep: Reputation: 52
yes, there is , i read it on the site of someone :callsign ''Insyte'', but i
can't find his web-adress. ( must be somewhere on the Slackware-forum )

egag
 
Old 08-30-2004, 08:59 PM   #3
IBall
Senior Member
 
Registered: Nov 2003
Location: Perth, Western Australia
Distribution: Ubuntu, Debian, Various using VMWare
Posts: 2,088

Rep: Reputation: 61
Edit the file /etc/inputrc. You will need to be root to do this.
Find the line that says "set bell-style audible" and change it to "set bell-style none"

When you reboot, the beep will be gone

I hope this helps
--Ian
 
Old 08-30-2004, 09:04 PM   #4
zchoyt
Member
 
Registered: Feb 2003
Location: Boise ID
Distribution: fedora
Posts: 156

Original Poster
Rep: Reputation: 30
Thanks, it worked like a charm.

zakk
 
Old 01-03-2007, 04:58 PM   #5
chadwick
Member
 
Registered: Apr 2005
Location: At the 100th Meridian where the great plains begin
Distribution: Debian Testing on T60 laptop
Posts: 105

Rep: Reputation: 16
try removing the pcspkr module

It seems to me that using inputrc only fixes beeping associated with the bash shell. When I do it this way, the beeping from unsuccessful tab completions goes away, but I still get beeping in emacs and in less for example. You can remove the relevant module (called pcspkr) from the kernel and you'll still be able to listen to whatever you want from the soundcard since, as zchoyt mentions, the beeping's not coming from the soundcard. I have the module removed right now and there is no beeping. That's nice since I listen to the radio with headphones and the beeping is REALLY loud with my headphones. If you decide you need it again you can always insert the module back.

Here's an explanation:

http://www.arsgeek.com/?p=484

Sorry, there seems to be a problem right now with kernel 2.6.18 so the blacklisting doesn't work with that particular module but the rmmod works. Maybe there's a better way then that doesn't require always using rmmod.

Last edited by chadwick; 01-03-2007 at 05:26 PM.
 
Old 01-03-2007, 05:27 PM   #6
homey
Senior Member
 
Registered: Oct 2003
Posts: 3,057

Rep: Reputation: 56
On my FC6 box, I put the modprobe -r pcspkr command in a file which gets run at bootup.

Code:
(echo '#!/bin/sh'; echo 'modprobe -r pcspkr') \
> /etc/sysconfig/modules/pcspkr.modules
chmod +x /etc/sysconfig/modules/pcspkr.modules
If for some crazy reason I did want that beep, I could run the command: modprobe pcspkr . NOT!
 
Old 01-05-2007, 08:38 PM   #7
chadwick
Member
 
Registered: Apr 2005
Location: At the 100th Meridian where the great plains begin
Distribution: Debian Testing on T60 laptop
Posts: 105

Rep: Reputation: 16
Thanks for the tip. I did a search and found this really useful site: http://www.debian-administration.org/articles/28
which explained how to do it on my Debian system.
I just put "rmmod pcspkr" into a script and no more beep.

Last edited by chadwick; 01-05-2007 at 08:39 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
How to turn off the annoying beep puzz_1 Linux - Hardware 3 02-22-2009 12:46 AM
How to disable that annoying BEEP? icy-flame Linux - Newbie 19 05-01-2007 06:16 PM
Incredibly annoying pc speaker beep on error in MySql in Windows XP nazdrowie Programming 2 07-15-2005 01:26 AM
looking for a beep lungsucker Programming 3 07-11-2005 08:01 AM
Annoying beep in slackware Havox Slackware 2 02-04-2003 11:37 PM


All times are GMT -5. The time now is 05:28 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration