LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 09-25-2013, 04:23 AM   #1
boby.kumar
Member
 
Registered: Mar 2013
Posts: 92

Rep: Reputation: Disabled
TFTP timeout error


Hi

Getting the following error while keeping backup of cisco switch configuration.

cisco#copy running-config tftp:
Address or name of remote host []? 10.20.31.32
Destination filename [cisco-confg]? new
.....
%Error opening tftp://10.20.31.32/new (Timed out).

TFTP server configuration as follows..

[root@localhost ~]# cat /etc/xinetd.d/tftp
i# default: off
# description: The tftp server serves files using the trivial file transfer \
# protocol. The tftp protocol is often used to boot diskless \
# workstations, download configuration files to network-aware printers, \
# and to start the installation process for some operating systems.
service tftp
{

socket_type = dgram
protocol = udp
port = 69
wait = yes
user = root
server = /usr/sbin/in.tftpd
server_args = -s /tftpboot
disable = no
per_source = 11
cps = 100 2
flags = IPv4
}

[root@localhost ~]# /etc/init.d/iptables status
Table: filter
Chain INPUT (policy ACCEPT)
num target prot opt source destination

Chain FORWARD (policy ACCEPT)
num target prot opt source destination

Chain OUTPUT (policy ACCEPT)
num target prot opt source destination

[root@localhost ~]# tftp localhost
tftp> status
Connected to localhost.
Mode: netascii Verbose: off Tracing: off Literal: off
Rexmt-interval: 5 seconds, Max-timeout: 25 seconds

[root@localhost ~]# tftp localhost
tftp> get hello.txt
Transfer timed out.

can any one trace to this what is wrong with TFTP server?

Thanks
 
Old 09-25-2013, 10:11 AM   #2
TB0ne
LQ Guru
 
Registered: Jul 2003
Location: Birmingham, Alabama
Distribution: SuSE, RedHat, Slack,CentOS
Posts: 17,921

Rep: Reputation: 3690Reputation: 3690Reputation: 3690Reputation: 3690Reputation: 3690Reputation: 3690Reputation: 3690Reputation: 3690Reputation: 3690Reputation: 3690Reputation: 3690
Quote:
Originally Posted by boby.kumar View Post
Hi
Getting the following error while keeping backup of cisco switch configuration.

cisco#copy running-config tftp:
Address or name of remote host []? 10.20.31.32
Destination filename [cisco-confg]? new
.....
%Error opening tftp://10.20.31.32/new (Timed out).

TFTP server configuration as follows..

[root@localhost ~]# cat /etc/xinetd.d/tftp
i# default: off
# description: The tftp server serves files using the trivial file transfer \
# protocol. The tftp protocol is often used to boot diskless \
# workstations, download configuration files to network-aware printers, \
# and to start the installation process for some operating systems.
service tftp
{

socket_type = dgram
protocol = udp
port = 69
wait = yes
user = root
server = /usr/sbin/in.tftpd
server_args = -s /tftpboot
disable = no
per_source = 11
cps = 100 2
flags = IPv4
}

[root@localhost ~]# tftp localhost
tftp> status
Connected to localhost.
Mode: netascii Verbose: off Tracing: off Literal: off
Rexmt-interval: 5 seconds, Max-timeout: 25 seconds

[root@localhost ~]# tftp localhost
tftp> get hello.txt
Transfer timed out.

can any one trace to this what is wrong with TFTP server?
Did you try reading the man page on tftpd??? From the man page:
Quote:
Originally Posted by TFPTD Man Page
--create, -c
Allow new files to be created. By default, tftpd will only allow upload of files that already exist. Files are created with default permissions allowing anyone to read or write them, unless the --permissive or --umask options are specified.
You didn't start the service with the "-c" flag, so you will NEVER be able to upload files to it. Modify the server_args line to include the "-c". And you also need to check the permissions of the directory, to make sure the user running the tftp service has write permissions.
 
Old 09-26-2013, 03:34 AM   #3
boby.kumar
Member
 
Registered: Mar 2013
Posts: 92

Original Poster
Rep: Reputation: Disabled
Thanks TBOne for update.

You didn't start the service with the "-c" flag, so you will NEVER be able to upload files to it. Modify the server_args line to include the "-c".


Its don't work for me. still the issue as tftp timeout error. I find to xinetd or udp service not listening on port 69.

[root@localhost tftpboot]# netstat -anp |grep xinetd
tcp 0 0 :::23 :::* LISTEN 26269/xinetd
unix 2 [ ] DGRAM 341712 26269/xinetd

[root@localhost tftpboot]# netstat -anp |grep udp
udp 0 0 0.0.0.0:58462 0.0.0.0:* 23963/rpc.moun td
udp 0 0 0.0.0.0:55262 0.0.0.0:* 1373/rsyslogd
udp 0 0 0.0.0.0:875 0.0.0.0:* 23947/rpc.rquo tad
udp 0 0 0.0.0.0:111 0.0.0.0:* 26335/portmap
udp 0 0 0.0.0.0:631 0.0.0.0:* 1599/cupsd
udp 0 0 0.0.0.0:36224 0.0.0.0:* 1450/rpc.statd
udp 0 0 0.0.0.0:2049 0.0.0.0:* -
udp 0 0 0.0.0.0:778 0.0.0.0:* 1450/rpc.statd
udp 0 0 0.0.0.0:40467 0.0.0.0:* 23963/rpc.moun td
udp 0 0 0.0.0.0:43030 0.0.0.0:* 23963/rpc.moun td
udp 0 0 0.0.0.0:55452 0.0.0.0:* -
udp 0 0 :::111 :::* 1432/rpcbind
udp 0 0 :::759 :::* 1432/rpcbind
udp 0 0 :::52866 :::* 23963/rpc.moun td
udp 0 0 :::45583 :::* 23963/rpc.moun td
udp 0 0 :::49962 :::* 1450/rpc.statd
udp 0 0 :::49078 :::* 23963/rpc.moun td
[root@localhost tftpboot]# lsof -i :69 --> Nothing output.

Is possible to get udp on port69 or we can set it to tcp port?

Is idea how to listen tftp server on port69? TFTP server installed RHEL6.2 os.

Thanks
 
Old 09-26-2013, 09:19 AM   #4
TB0ne
LQ Guru
 
Registered: Jul 2003
Location: Birmingham, Alabama
Distribution: SuSE, RedHat, Slack,CentOS
Posts: 17,921

Rep: Reputation: 3690Reputation: 3690Reputation: 3690Reputation: 3690Reputation: 3690Reputation: 3690Reputation: 3690Reputation: 3690Reputation: 3690Reputation: 3690Reputation: 3690
Quote:
Originally Posted by boby.kumar View Post
Thanks TBOne for update.
You didn't start the service with the "-c" flag, so you will NEVER be able to upload files to it. Modify the server_args line to include the "-c".

Its don't work for me.
Just saying "its don't work for me", tells us NOTHING new.
Quote:
still the issue as tftp timeout error. I find to xinetd or udp service not listening on port 69. Is possible to get udp on port69 or we can set it to tcp port?

Is idea how to listen tftp server on port69? TFTP server installed RHEL6.2 os.
If the service isn't started/listening, it will VERY OBVIOUSLY not work. Again, did you contact Red Hat support, since you're using RHEL?? You are PAYING for RHEL, right???? Did you restart the tftp daemon after you made the change to the .conf file? Check the service to see if it's running?? There are MANY easily-found guides on how to configure tftp:
http://thehomelab.blogspot.com/2012/...-server-6.html

That has a detailed section on how to configure it, along with iptables rules, etc.
 
1 members found this post helpful.
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
tftp timeout while booting . mohitvad Linux - Newbie 1 12-04-2012 04:09 AM
in.tftp pxelinux.0_ fails with TFTP open timeout deadeyes Linux - Server 1 05-28-2010 11:07 AM
Error "TFTP open timeout" Ogi Linux - Networking 5 10-07-2009 10:16 AM
Set-up of a tftp server for PXE installation gives TIMEOUT error colucix Linux - General 3 06-26-2009 10:14 AM
TFTP timeout LTSP maxsanders Linux - Networking 1 07-07-2007 06:59 AM


All times are GMT -5. The time now is 08:07 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration