LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 03-16-2010, 06:55 AM   #1
tmj
LQ Newbie
 
Registered: Nov 2009
Posts: 1

Rep: Reputation: 0
tftp


Hi Folks,

I'm running Ubuntu (9.10), I have installed tftp, did everything as in the tutorial, see below :

thierry@thierry-eeepc:/tftpboot$ more /etc/xinetd.d/tftp
service tftp
{
protocol = udp
port = 69
socket_type = dgram
wait = yes
user = nobody
server = /usr/sbin/in.tftpd
server_args = /tftpboot
disable = no
}
thierry@thierry-eeepc:/tftpboot$ sudo /etc/init.d/xinetd reload
[sudo] password for thierry:
* Reloading internet superserver configuration xinetd [ OK ]
thierry@thierry-eeepc:/tftpboot$ sudo /etc/init.d/xinetd start
* Starting internet superserver xinetd [fail]
thierry@thierry-eeepc:/tftpboot$ sudo /etc/init.d/xinetd restart
* Stopping internet superserver xinetd [ OK ]
* Starting internet superserver xinetd [ OK ]


but I systematically get this when I try to put or get a file (client is on Solaris 10, same network as the Ubuntu tftp server)

Error code 2: Access violation

What do I do wrong?

many TIA
 
Old 03-16-2010, 06:59 AM   #2
vinaytp
Member
 
Registered: Apr 2009
Location: Bengaluru, India
Distribution: RHEL 5.4, 6.0, Ubuntu 10.04
Posts: 704

Rep: Reputation: 55
When are you getting this error ?
Quote:
Error code 2: Access violation
Try changing this parameter
Code:
user = root
server_args = -s /tftpboot

Last edited by vinaytp; 03-16-2010 at 07:05 AM.
 
Old 12-25-2010, 05:31 PM   #3
emgee3
LQ Newbie
 
Registered: May 2009
Posts: 14

Rep: Reputation: 1
Hopefully you're not still trying, but I ran into the same thing. What did it for me was the following:

Let's say I want to upload filename to the tftp server. On the tftp server I would

Code:
touch /tftproot/filename
chmod 777 /tftproot/filename
Then the upload worked. Not sure if this is by design or what, but it worked.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
in.tftp pxelinux.0_ fails with TFTP open timeout deadeyes Linux - Server 1 05-28-2010 10:07 AM
after re-create tftp dir, tftp doesn't work anymore lastguy Linux - Networking 2 11-16-2007 03:33 PM
tftp issue, unable to transfer kernel image using tftp to boot ltsp-client noobs4linux Linux - Networking 1 02-07-2007 01:53 AM
tftp baparekh Linux - Networking 8 03-11-2005 07:50 AM
TFTP-Problem: TFTP timed out Bikerpete Linux - General 2 08-14-2003 05:25 AM


All times are GMT -5. The time now is 10:00 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration