LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 09-18-2013, 02:05 PM   #1
jervis_tetch
LQ Newbie
 
Registered: Sep 2013
Posts: 10

Rep: Reputation: Disabled
text in terminal emulator flickers while moving the window


hey people,

when i'm moving a terminal emulator window (in this case terminator), all the text in it starts to "flicker".

i figured out that it is noticeable when the background is set to black (or dark) and the font color is set to white (or any bright color).

it's not a big problem to me, but i'm really interested in the reason for this problem.

i'm actually running slackware 14 with openbox as windowmanager (from slackbuilds).

i've installed the nvidia drivers too.


any ideas what can cause this?


thanks
 
Old 09-18-2013, 04:31 PM   #2
porphyry5
Member
 
Registered: Jul 2010
Location: oregon usa
Distribution: Slackware 14.1, Arch
Posts: 443

Rep: Reputation: 21
Quote:
Originally Posted by jervis_tetch View Post
hey people,

when i'm moving a terminal emulator window (in this case terminator), all the text in it starts to "flicker".

i figured out that it is noticeable when the background is set to black (or dark) and the font color is set to white (or any bright color).

it's not a big problem to me, but i'm really interested in the reason for this problem.

i'm actually running slackware 14 with openbox as windowmanager (from slackbuilds).

i've installed the nvidia drivers too.


any ideas what can cause this?


thanks
Assuming you are dragging it with the mouse, its probably because the system is constantly redrawing the gui as you drag it
 
Old 09-18-2013, 07:09 PM   #3
jervis_tetch
LQ Newbie
 
Registered: Sep 2013
Posts: 10

Original Poster
Rep: Reputation: Disabled
so how can i solve this?
 
Old 09-19-2013, 01:07 PM   #4
porphyry5
Member
 
Registered: Jul 2010
Location: oregon usa
Distribution: Slackware 14.1, Arch
Posts: 443

Rep: Reputation: 21
Quote:
Originally Posted by jervis_tetch View Post
so how can i solve this?
You could try enabling double buffering, as described in http://stackoverflow.com/questions/1...a-slow-machine
 
Old 09-19-2013, 01:18 PM   #5
zeebra
Member
 
Registered: Dec 2011
Distribution: Mageia 3, Debian Wheezy, Maemo, Linux Mint 14.
Posts: 200

Rep: Reputation: Disabled
Quote:
Originally Posted by jervis_tetch View Post
hey people,

when i'm moving a terminal emulator window (in this case terminator), all the text in it starts to "flicker".

thanks
What kind of hardware do you have? I can think of a variety of graphics issues which can cause this.
 
Old 09-19-2013, 03:40 PM   #6
jervis_tetch
LQ Newbie
 
Registered: Sep 2013
Posts: 10

Original Poster
Rep: Reputation: Disabled
i've tested if the problem also exists under windows, it does.

i have a geforce gt 430 (newest nvidia drivers for linux installed) and an old flatscreen from gericom, is it possible that the screen causes those problems?
 
Old 09-19-2013, 08:05 PM   #7
zeebra
Member
 
Registered: Dec 2011
Distribution: Mageia 3, Debian Wheezy, Maemo, Linux Mint 14.
Posts: 200

Rep: Reputation: Disabled
Quote:
Originally Posted by jervis_tetch View Post
i've tested if the problem also exists under windows, it does.

i have a geforce gt 430 (newest nvidia drivers for linux installed) and an old flatscreen from gericom, is it possible that the screen causes those problems?
Any TV with a low HZ rate could cause the issue, in particular when there are high contrast(black on white, white on black).

Recommended HZ for PC screens is 60hz and more I believe.
 
Old 09-19-2013, 09:02 PM   #8
jervis_tetch
LQ Newbie
 
Registered: Sep 2013
Posts: 10

Original Poster
Rep: Reputation: Disabled
well this screen got 60-75 hz i think, but the model isn't the best choise i guess.

i'll try to get another one, lets see what happens.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Wheezy, OpenBox. Strange terminal emulator text. 0men Debian 1 05-12-2013 02:46 AM
[SOLVED] Run cron job in terminal emulator window Beaverfriend Linux - Software 3 05-24-2012 05:06 AM
getting text in the terminal window cpski02 Linux - Newbie 2 09-15-2010 11:11 PM
Focusing the terminal emulator window in Kate Shay Linux - Software 1 11-01-2006 03:15 PM
Terminal Window with no text pawlub Linux - Software 2 03-31-2004 04:19 PM


All times are GMT -5. The time now is 04:22 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration