LinuxQuestions.org
Latest LQ Deal: Linux Power User Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 10-09-2013, 04:19 AM   #1
sryzdn
Member
 
Registered: Feb 2013
Posts: 248

Rep: Reputation: 1
Texmaker installing error


Hi,

I am installing Texmaker. I have just been stopped by this error:

Quote:
/bin/ld: .obj/XKeyboard.o: undefined reference to symbol 'XkbGetState'
/bin/ld: note: 'XkbGetState' is defined in DSO /lib64/libX11.so.6 so try adding it to the linker command line
/lib64/libX11.so.6: could not read symbols: Invalid operation
collect2: error: ld returned 1 exit status
make: *** [bidiTeXmaker] Error 1
Compilation and installation done
How can I solve this problem?
 
Old 10-09-2013, 05:52 AM   #2
dive
Senior Member
 
Registered: Aug 2003
Location: UK
Distribution: Slackware
Posts: 3,232

Rep: Reputation: 299Reputation: 299Reputation: 299
Try adding '-lX11' to CFLAGS and CXXFLAGS
 
1 members found this post helpful.
Old 10-09-2013, 07:35 AM   #3
sryzdn
Member
 
Registered: Feb 2013
Posts: 248

Original Poster
Rep: Reputation: 1
Quote:
Originally Posted by dive View Post
Try adding '-lX11' to CFLAGS and CXXFLAGS
Sorry, I don't know how to do that.
 
Old 10-10-2013, 01:43 AM   #4
dive
Senior Member
 
Registered: Aug 2003
Location: UK
Distribution: Slackware
Posts: 3,232

Rep: Reputation: 299Reputation: 299Reputation: 299
You're installing from source I take it?

When you ./configure do something like:

CFLAGS="-lX11" CXXFLAGS="-lX11" ./configure

If you're installing some other way please let us know what you're doing.
 
Old 10-10-2013, 12:45 PM   #5
sryzdn
Member
 
Registered: Feb 2013
Posts: 248

Original Poster
Rep: Reputation: 1
Quote:
Originally Posted by dive View Post
If you're installing some other way please let us know what you're doing.
I am installing a package that contains texmaker together with livetex in a dvd. The command I am using to install texmaker is: sudo sh BUILD.sh
 
Old 10-10-2013, 01:24 PM   #6
dive
Senior Member
 
Registered: Aug 2003
Location: UK
Distribution: Slackware
Posts: 3,232

Rep: Reputation: 299Reputation: 299Reputation: 299
Does your distro not have texmaker in its package repo?

If not, have a look in the file texmaker.pro around line 313. This is probably what it has:

Code:
LIBS         += -lz
Try changing that to:
Code:
LIBS         += -lz -lX11
Save the file and run BUILD.sh again and it should be added to the Makefile. If this doesn't work then some hacking of the Makefile may be required.

Last edited by dive; 10-10-2013 at 01:31 PM.
 
2 members found this post helpful.
Old 10-10-2013, 11:18 PM   #7
sryzdn
Member
 
Registered: Feb 2013
Posts: 248

Original Poster
Rep: Reputation: 1
Thanks, that solved my problem.
But there's no such documents to guide me about how to launch it ?!
 
Old 10-10-2013, 11:22 PM   #8
dive
Senior Member
 
Registered: Aug 2003
Location: UK
Distribution: Slackware
Posts: 3,232

Rep: Reputation: 299Reputation: 299Reputation: 299
There should be a .desktop file installed, which means it show in most application menus. If it doesn't because you're using a simple WM like fluxbox then you need to edit the menu manually to add it.

The command to start it is just 'texmaker' and you can test it from a console.
 
Old 10-11-2013, 12:25 AM   #9
sryzdn
Member
 
Registered: Feb 2013
Posts: 248

Original Poster
Rep: Reputation: 1
Thanks Dive, but I have no texmaker in terminal !!! nor is there any icons on the desktop.
Let me tell you what I did:

I got a DVD of TexLive and installed Texlive by the following command:

Quote:
‫‪perl install-tl -gui‬‬ text
Then there was a TexMaker Package. I untar the package and after locating some parts as default, as you know, I installed it by:

Quote:
sh BUILD.sh
But, I cannot see how I can launch the now!!!
 
Old 10-11-2013, 02:02 AM   #10
dive
Senior Member
 
Registered: Aug 2003
Location: UK
Distribution: Slackware
Posts: 3,232

Rep: Reputation: 299Reputation: 299Reputation: 299
I'm not talking about icons on the desktop - I mean there should be an entry in the menu. Which DE/WM are you using?

And which settings did you put in when running the build.sh?

If you run the command 'texmaker' in a console it says 'Command not found' or similar?

Last edited by dive; 10-11-2013 at 02:03 AM.
 
Old 10-11-2013, 03:45 AM   #11
sryzdn
Member
 
Registered: Feb 2013
Posts: 248

Original Poster
Rep: Reputation: 1
Quote:
I'm not talking about icons on the desktop - I mean there should be an entry in the menu. Which DE/WM are you using?
I am using GNOME Shell 3.8.4

Quote:
And which settings did you put in when running the build.sh?
Enter path to QT4: /usr/lib64/qt4
Enter SYSTEM: 1: UNIX
Enter PREFIX: /usr/local
Enter DIRECTORY for the desktop file: /usr/share/applications
Enter DIRECTORY for the icon file: /usr/share/pixmaps

Quote:
If you run the command 'texmaker' in a console it says 'Command not found' or similar?
It says: bash: texmaker: command not found...
 
Old 10-11-2013, 05:09 AM   #12
dive
Senior Member
 
Registered: Aug 2003
Location: UK
Distribution: Slackware
Posts: 3,232

Rep: Reputation: 299Reputation: 299Reputation: 299
Ok.

Easiest fix:

Copy texmaker from the source directory to /usr/local/bin
Copy utilities/texmaker.desktop to /usr/share/applications
Copy utilities/texmaker.png and utilities/texmaker.svg to /usr/share/pixmaps

Then run the following command:

sudo /usr/bin/update-desktop-database -q /usr/share/applications
 
1 members found this post helpful.
Old 10-11-2013, 07:41 AM   #13
sryzdn
Member
 
Registered: Feb 2013
Posts: 248

Original Poster
Rep: Reputation: 1
Dive, you must forgive my dumbness. The TexMaker I am using is bidiTexMaker (able to switch betwen languages) That's why I had to write the command biditexmaker to run it. Forgive me... and thanks a lot.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] TexMaker Qt problems in XFCE mlpa Slackware 1 10-26-2010 04:34 AM
latex problems (texmaker) elishac Linux - Software 10 01-28-2010 09:29 AM
change texmaker default RudraB Linux - Software 1 10-04-2009 10:14 PM
LXer: Texmaker tames LaTeX LXer Syndicated Linux News 1 03-28-2008 08:45 AM
Texmaker & inverse-search setting Blue Jacket Linux - Software 1 04-19-2006 04:27 PM


All times are GMT -5. The time now is 10:32 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration