LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 09-23-2011, 03:21 PM   #1
merc669
LQ Newbie
 
Registered: Sep 2011
Posts: 5

Rep: Reputation: Disabled
Terminal Issues


First Off;
Ubuntu 11.04/32
Sony Vaio VPCF115FM Laptop with NVidia Dedicated Video 1G ram
Display Running at 1920x1280
Running Ubuntu from External Passport 1TB USB2.0 Drive, Windows 7/64 on main drive
I have searched this web site along with Ubunto Site with no joy.

Ubuntu loaded fine with no serious issues. Desktop is fine and all apps working. However, normally you would use Ctrl-Alt F1 thru F6 to get to a non-xwindow terminal. I can do a switch using the Ctrl-Alt F* or F7 to get back to desktop. But all I get is a black screen and no cursor. It also does not accept tty inputs. Have reviewed some things to try and change in Grub/Grub.d Directory, etc with no joy. I used to play with Linux a number of years ago and started getting back into it again but this issue although not serious is bugging me. What am I missing or is there an option or controls to change to get these terminals enabled? Used to use Mandrake but that was a while ago. Thanks Much!

Bill
 
Old 09-23-2011, 04:05 PM   #2
zuzoa
Member
 
Registered: Nov 2008
Location: USA
Distribution: Arch 64-bit
Posts: 159

Rep: Reputation: 35
Are you using NVIDIA proprietary drivers, or open-source? If you don't know, open the file /etc/X11/xorg.conf and find a section like this:
Quote:
Section "Device"
Identifier "Device0"
Driver "nvidia"
VendorName "NVIDIA Corporation"
EndSection
My suggestion would be to try another driver. If you're using nvidia, try nv, and vice-versa. Just replace whatever's in the Driver section in that file and save it, then restart X. (CTRL-ALT-Backspace)
 
Old 09-23-2011, 04:39 PM   #3
merc669
LQ Newbie
 
Registered: Sep 2011
Posts: 5

Original Poster
Rep: Reputation: Disabled
Looked in the /etc/X11 directory and no such file there. There is a xorg.conf.failsafe. Also forgot to add "Ctrl-Alt-Backspace" does not work also. So cannot stop X windows. This is a stock Ubuntu load. NVidia Driver installed is 270.41.06. Latest driver from NVidia is "NVIDIA-Linux-x86-280.13", however I cannot install since I cannot get into a non-graphical terminal mode. I keep getting errors stating I am in X11. Sorry for forgetting...Thanks!!

Bill....

Last edited by merc669; 09-23-2011 at 04:54 PM.
 
Old 09-23-2011, 04:51 PM   #4
zuzoa
Member
 
Registered: Nov 2008
Location: USA
Distribution: Arch 64-bit
Posts: 159

Rep: Reputation: 35
OK, try clicking on System>Administration>Hardware Drivers, and change the checkbox to another video driver. Sorry, I haven't used Ubuntu for awhile so I apologize if my suggestions are now invalid.
 
Old 09-23-2011, 05:03 PM   #5
zuzoa
Member
 
Registered: Nov 2008
Location: USA
Distribution: Arch 64-bit
Posts: 159

Rep: Reputation: 35
So wait, is your problem that once you change virtual consoles (CTRL-ALT-F1, F2, etc) you cannot return your graphical desktop? Or is it that you cannot get to these other virtual consoles?

If it's the latter, I retract my suggestion for changing your video driver. You may just not have those consoles enabled in /etc/inittab.

If you're in a graphical desktop, you should be able to access a terminal with a terminal emulator such as gnome-terminal or xterm, FYI.
 
Old 09-23-2011, 05:13 PM   #6
merc669
LQ Newbie
 
Registered: Sep 2011
Posts: 5

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by zuzoa View Post
So wait, is your problem that once you change virtual consoles (CTRL-ALT-F1, F2, etc) you cannot return your graphical desktop? Or is it that you cannot get to these other virtual consoles?

If it's the latter, I retract my suggestion for changing your video driver. You may just not have those consoles enabled in /etc/inittab.

If you're in a graphical desktop, you should be able to access a terminal with a terminal emulator such as gnome-terminal or xterm, FYI.
I am in a graphical desktop. And desktop terminals work. However to update NVidia drivers using the latest version means you need to do this in a non-graphical terminal (X11 stopped). This is not possible at this time. Also in case of X11 errors or freeze "Ctrl-Alt-Bacspace" does not work from laptop. Not sure why. From reading about Ubuntu these Virtual Consoles (Ctrl-Alt-F1 thru F6) should be working. Ctrl-Alt-F7 does bring you back to X11 Desktop.

Bill....

P.S. Here is the Xorg.0.log after trying to use Ctrl-Alt-F1;
8562.928] (II) Open ACPI successful (/var/run/acpid.socket)
[ 8563.032] (II) NVIDIA(0): Setting mode "nvidia-auto-select"
[ 8563.421] (II) AlpsPS/2 ALPS GlidePoint: failed to open grail, no gesture support
[ 8563.421] (--) AlpsPS/2 ALPS GlidePoint: touchpad found
[ 8607.614] (II) Open ACPI successful (/var/run/acpid.socket)
[ 8607.836] (II) NVIDIA(0): Setting mode "nvidia-auto-select"
[ 8608.261] (II) AlpsPS/2 ALPS GlidePoint: failed to open grail, no gesture support
[ 8608.261] (--) AlpsPS/2 ALPS GlidePoint: touchpad found

And this is from syslog;
Sep 23 17:20:21 merc669-VPCF115FM acpid: client 1029[0:0] has disconnected
Sep 23 17:20:21 merc669-VPCF115FM acpid: client 1029[0:0] has disconnected
Sep 23 17:20:21 merc669-VPCF115FM acpid: client connected from 1029[0:0]
Sep 23 17:20:21 merc669-VPCF115FM acpid: 1 client rule loaded
Sep 23 17:20:22 merc669-VPCF115FM acpid: client connected from 1029[0:0]
Sep 23 17:20:22 merc669-VPCF115FM acpid: 1 client rule loaded

Both of these updated with this after trying to use "Ctrl-Alt-F1", F7 to return to X11 Desktop.

Last edited by merc669; 09-23-2011 at 05:23 PM.
 
Old 09-23-2011, 05:30 PM   #7
zuzoa
Member
 
Registered: Nov 2008
Location: USA
Distribution: Arch 64-bit
Posts: 159

Rep: Reputation: 35
Try looking at the contents of your /etc/inittab file. There should be something like this:

Quote:
c1:2345:respawn:/sbin/agetty -8 -s 38400 tty1 linux
c2:2345:respawn:/sbin/agetty -8 -s 38400 tty2 linux
c3:2345:respawn:/sbin/agetty -8 -s 38400 tty3 linux
c4:2345:respawn:/sbin/agetty -8 -s 38400 tty4 linux
c5:2345:respawn:/sbin/agetty -8 -s 38400 tty5 linux
c6:2345:respawn:/sbin/agetty -8 -s 38400 tty6 linux
indicating that you have virtual consoles (TTY) 1-6 enabled. If this is not there, that could be your problem.

As for upgrading your nvidia driver, if you have already downloaded the .bin file from the nvidia website, you just need to kill the GUI to install it-- which as I remember from ubuntu is harder than it sounds. Try "killall X gdm" from a terminal emulator.
 
Old 09-23-2011, 05:56 PM   #8
merc669
LQ Newbie
 
Registered: Sep 2011
Posts: 5

Original Poster
Rep: Reputation: Disabled
Thanks for working with me first of all!!

Well, there is not inittab file in the /etc directory. There is three directories;
1. init
2. init.d
3. initramfs-tools

But no inittab file. There are tty1 thru 6.conf files in the /etc/init directory.

Does not work "killall X gdm". Thanks Much!!!

Bill....

Last edited by merc669; 09-23-2011 at 05:58 PM.
 
Old 09-23-2011, 06:38 PM   #9
michaelk
Moderator
 
Registered: Aug 2002
Posts: 14,939

Rep: Reputation: 1520Reputation: 1520Reputation: 1520Reputation: 1520Reputation: 1520Reputation: 1520Reputation: 1520Reputation: 1520Reputation: 1520Reputation: 1520Reputation: 1520
init from the sysvinit package has been replaced with Upstart so there isn't an inittab file anymore.


To shutdown gnome
sudo /etc/init.d/gdm stop
or KDE
sudo /etc/init.d/kdm stop

ctrl-alt-f1 will switch to a terminal where you can login.
To restart if running gnome
sudo /etc/init.d/gdm start


However I also found this:
https://help.ubuntu.com/community/Bi...erHowto/Nvidia

Last edited by michaelk; 09-23-2011 at 06:42 PM.
 
Old 09-24-2011, 06:56 AM   #10
merc669
LQ Newbie
 
Registered: Sep 2011
Posts: 5

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by michaelk View Post
init from the sysvinit package has been replaced with Upstart so there isn't an inittab file anymore.


.
However I also found this:
https://help.ubuntu.com/community/Bi...erHowto/Nvidia
Thanks!! Looked at link given above. There is additional drivers. It refers to propierty driver. Says it it is needed for Unity System.
3D-accelerated proprietary graphics driver for NVIDIA cards. Required if you want to run Unity.

This driver is required to fully utilise the 3D potential of NVIDIA graphics cards, as well as provide 2D acceleration of newer cards.

You need to install this driver if you wish to use the Unity desktop, enable desktop effects, or run software that requires 3D acceleration, such as some games.

However there is no option to install only remove. It also says that this driver is NOT in use. Current driver used is listed as 270.41.06. I have downloaded "NVIDIA-Linux-x86-280.13.run". Documentation says to run "sudo sh NVIDIA-Linux........" and it will decompress. Then install from there. System will not allow it unless 1. you are root or from sudo command it appears and 2. you are in a non-X11 terminal. Will give the "sudo /etc/init.d/gdm stop" later this morninng and try from there and resart as you suggested or after a reboot of the computer. Well, tried the gdm stop, did not do anything but bring me a black screen and no cursor or text. Had to do a hard reboot...So still cannot update the driver. Thanks!!

Bill.....

Last edited by merc669; 09-24-2011 at 11:25 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Terminal Issues cavibird Linux - Newbie 2 01-23-2010 03:34 PM
root terminal issues diaboluslamia Linux - Software 1 10-03-2009 02:46 PM
Terminal ./configure issues InsanE_X_Coconuts Ubuntu 8 12-16-2006 06:35 PM
issues in the terminal nixerwannab Linux - Software 10 01-25-2005 06:38 PM
Suse 8.2 terminal issues Twiggy794 Linux - Distributions 4 10-09-2003 10:23 PM


All times are GMT -5. The time now is 05:16 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration